Tvguru

Members
  • Content Count

    11
  • Joined

  • Last visited

Posts posted by Tvguru

  1. I have updated my config file and it works great. 

     

    One issue I do have, which I believe is a fault with the liftmaster2 package and not this docker, when the docker restarts I get an error:

    (node:32) UnhandledPromiseRejectionWarning: Error: Cannot add a bridged Accessory with the same UUID as another bridged Accessory: eb518639-e128-494e-a833-150122d70b6c

     

    The solution is to delete the cachedaccessories file. Is there a command I could set up to do that on each startup of the docker?

     

    Either way I very much appreciate you adding the ability to add this package!

     

    Justin

  2. Ok, not sure what happened to fix it, but I went to github and copied and pasted from there vs from this forum for git+https://github.com/luisiam/homebridge-liftmaster2.git i then edited the packages (removed the git+etc and pasted from the the github copy) now it loaded up just fine. Haven’t edited the config yet, but we’re in business!

  3. 20 hours ago, Siwat2545 said:

    Did you forced update the container yet?, Also please try to remove the image and install it again just incase

     

    Thank you again for your continued efforts!

    Tonight I removed both images, GUI and non, and deleted the homebridge folder in app data for good measure. 

     

    I recieve the following error on the GUI versions first run:

    --2018-11-20 01:20:17-- https://raw.githubusercontent.com/SiwatINC/unraid-ca-repository/master/docker-template/config.json
    Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 151.101.0.133, 151.101.64.133, 151.101.128.133, ...
    Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.0.133|:443... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 485 [text/plain]
    Saving to: '/root/.homebridge/config.json'

    0K 100% 48.8M=0s

    2018-11-20 01:20:17 (48.8 MB/s) - '/root/.homebridge/config.json' saved [485/485]

    npm ERR! addLocal Could not install /git+https:/github.com/luisiam/homebridge-liftmaster2.git
    npm ERR! Linux 4.18.17-unRAID
    npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install" "-g" "--unsafe-perm" "git+https://github.com/luisiam/homebridge-liftmaster2.git" "homebridge-pilight" "homebridge-info" "homebridge-wemo"
    npm ERR! node v8.10.0
    npm ERR! npm v3.5.2
    npm ERR! path /git+https:/github.com/luisiam/homebridge-liftmaster2.git
    npm ERR! code ENOENT
    npm ERR! errno -2
    npm ERR! syscall open

    npm ERR! enoent ENOENT: no such file or directory, open '/git+https:/github.com/luisiam/homebridge-liftmaster2.git'
    npm ERR! enoent ENOENT: no such file or directory, open '/git+https:/github.com/luisiam/homebridge-liftmaster2.git'
    npm ERR! enoent This is most likely not a problem with npm itself
    npm ERR! enoent and is related to npm not being able to find a file.
    npm ERR! enoent

    npm ERR! Please include the following file with any support request:
    npm ERR! /npm-debug.log

     

    I am not versed in this in the slightest, but could it be the extra / being added (/git+https:/github.com/luisiam/homebridge-liftmaster2.git)?

     

    Justin

  4. 58 minutes ago, Siwat2545 said:

    I updated the container put git+https://github.com/luisiam/homebridge-liftmaster2.git in the packages field and it should work now!

     

    I appreciate your efforts!

    However it doesn’t appear to work yet. 

    I placed git+https://github.com/luisiam/homebridge-liftmaster2.git In the package field of the template first with the stock packages and then by itself. 

     

    In each case this is is the errors it’s throwing:

    File '/root/.homebridge/config.json' already there; not retrieving.
    npm ERR! addLocal Could not install /git+https:/github.com/luisiam/homebridge-liftmaster2.git
    npm ERR! Linux 4.18.17-unRAID
    npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install" "-g" "--unsafe-perm" "git+https://github.com/luisiam/homebridge-liftmaster2.git"
    npm ERR! node v8.10.0
    npm ERR! npm v3.5.2
    npm ERR! path /git+https:/github.com/luisiam/homebridge-liftmaster2.git
    npm ERR! code ENOENT
    npm ERR! errno -2
    npm ERR! syscall open

    npm ERR! enoent ENOENT: no such file or directory, open '/git+https:/github.com/luisiam/homebridge-liftmaster2.git'
    npm ERR! enoent ENOENT: no such file or directory, open '/git+https:/github.com/luisiam/homebridge-liftmaster2.git'
    npm ERR! enoent This is most likely not a problem with npm itself
    npm ERR! enoent and is related to npm not being able to find a file.
    npm ERR! enoent

    npm ERR! Please include the following file with any support request:
    npm ERR! /npm-debug.log

     

     

    Thanks again,

    Justin

     

    Edit: For what it’s worth, both the GUI and non GUI version throw the same error. 

  5. Firstly, thank you for making these Homebridge dockers!

     

    I’m having an issue getting homebridge-liftmaster2 working. It’s throwing an error which appears to be due to the latest published version bring 0.1.0 where github has 0.5.0. See Here

     

    The solution apears to be run npm install -g git+https://github.com/luisiam/homebridge-liftmaster2.git to get the latest version installed, but doesn’t appear to be possible with this docker. Is that correct or am I missing something.

     

    Thanks!

    Justin

  6. 1 hour ago, Schlichi said:

    You‘re missing the whole qemu:arg stuff at the end of the XML. Without that, the VM won‘t be able to boot.

     

    Important: You lose your manual editings of the XML file if you use the regular VM mask of UNRAID again afterwards.

     

    Greets

    Schlichi

     

    Man, that’s embarrassing, but I’m glad it was simple. I guess that’s what I get for trying to do it with a 3 year old running around and a baby in my arms. 

    I even rewatched the video thinking, yup did that, did that too...

     

    Thanks for your help, it’s much appreciated. 

  7. 8 hours ago, Schlichi said:

    Can you post your XML?

     

    Greets

    Schlichi

     

    Sure thing I appologize for the formatting. I am on my iPad on break. 

     

    Thanks for you time.

     

    <domain type='kvm'>
    2
      <name>OS High Sierra</name>
    3
      <uuid>d69ee06c-5144-db8c-bf49-ea626e7b973c</uuid>
    4
      <metadata>
    5
        <vmtemplate xmlns="unraid" name="Linux" icon="linux.png" os="linux"/>
    6
      </metadata>
    7
      <memory unit='KiB'>8388608</memory>
    8
      <currentMemory unit='KiB'>8388608</currentMemory>
    9
      <memoryBacking>
    10
        <nosharepages/>
    11
      </memoryBacking>
    12
      <vcpu placement='static'>8</vcpu>
    13
      <cputune>
    14
        <vcpupin vcpu='0' cpuset='0'/>
    15
        <vcpupin vcpu='1' cpuset='1'/>
    16
        <vcpupin vcpu='2' cpuset='2'/>
    17
        <vcpupin vcpu='3' cpuset='3'/>
    18
        <vcpupin vcpu='4' cpuset='4'/>
    19
        <vcpupin vcpu='5' cpuset='5'/>
    20
        <vcpupin vcpu='6' cpuset='6'/>
    21
        <vcpupin vcpu='7' cpuset='7'/>
    22
      </cputune>
    23
      <os>
    24
        <type arch='x86_64' machine='pc-q35-2.9'>hvm</type>
    25
        <loader readonly='yes' type='pflash'>/usr/share/qemu/ovmf-x64/OVMF_CODE-pure-efi.fd</loader>
    26
        <nvram>/etc/libvirt/qemu/nvram/d69ee06c-5144-db8c-bf49-ea626e7b973c_VARS-pure-efi.fd</nvram>
    27
      </os>
    28
      <features>
    29
        <acpi/>
    30
        <apic/>
    31
      </features>
    32
      <cpu mode='host-passthrough' check='none'>
    33
        <topology sockets='1' cores='8' threads='1'/>
    34
      </cpu>
    <clock offset='utc'>
    36
        <timer name='rtc' tickpolicy='catchup'/>
    37
        <timer name='pit' tickpolicy='delay'/>
    38
        <timer name='hpet' present='no'/>
    39
      </clock>
    40
      <on_poweroff>destroy</on_poweroff>
    41
      <on_reboot>restart</on_reboot>
    42
      <on_crash>restart</on_crash>
    43
      <devices>
    44
        <emulator>/usr/local/sbin/qemu</emulator>
    45
        <disk type='file' device='disk'>
    46
          <driver name='qemu' type='raw' cache='writeback'/>
    47
          <source file='/mnt/user/isos/highsierra.img'/>
    48
          <target dev='hdc' bus='sata'/>
    49
          <boot order='1'/>
    50
          <address type='drive' controller='0' bus='0' target='0' unit='2'/>
    51
        </disk>
    52
        <disk type='file' device='disk'>
    53
          <driver name='qemu' type='raw' cache='writeback'/>
    54
          <source file='/mnt/user/domains/OS High Sierra/vdisk2.img'/>
    55
          <target dev='hdd' bus='sata'/>
    56
          <address type='drive' controller='0' bus='0' target='0' unit='3'/>
    57
        </disk>
    58
        <controller type='usb' index='0' model='ich9-ehci1'>
    59
          <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x7'/>
    60
        </controller>
    61
        <controller type='usb' index='0' model='ich9-uhci1'>
    62
          <master startport='0'/>
    63
          <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x0' multifunction='on'/>
    64
        </controller>
    65
        <controller type='usb' index='0' model='ich9-uhci2'>
    66
          <master startport='2'/>
    67
          <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x1'/>

     

    </controller>
    69
        <controller type='usb' index='0' model='ich9-uhci3'>
    70
          <master startport='4'/>
    71
          <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x2'/>
    72
        </controller>
    73
        <controller type='sata' index='0'>
    74
          <address type='pci' domain='0x0000' bus='0x00' slot='0x1f' function='0x2'/>
    75
        </controller>
    76
        <controller type='pci' index='0' model='pcie-root'/>
    77
        <controller type='pci' index='1' model='pcie-root-port'>
    78
          <model name='pcie-root-port'/>
    79
          <target chassis='1' port='0x10'/>
    80
          <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0' multifunction='on'/>
    81
        </controller>
    82
        <controller type='pci' index='2' model='pcie-root-port'>
    83
          <model name='pcie-root-port'/>
    84
          <target chassis='2' port='0x11'/>
    85
          <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x1'/>
    86
        </controller>
    87
        <controller type='pci' index='3' model='pcie-root-port'>
    88
          <model name='pcie-root-port'/>
    89
          <target chassis='3' port='0x12'/>
    90
          <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x2'/>
    91
        </controller>
    92
        <controller type='pci' index='4' model='pcie-root-port'>
    93
          <model name='pcie-root-port'/>
    94
          <target chassis='4' port='0x13'/>
    95
          <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x3'/>
    96
        </controller>
    97
        <controller type='virtio-serial' index='0'>
    98
          <address type='pci' domain='0x0000' bus='0x02' slot='0x00' function='0x0'/>
    99
        </controller>

     

      <interface type='bridge'>
    101
          <mac address='52:54:00:62:e7:99'/>
    102
          <source bridge='br0'/>
    103
          <model type='virtio'/>
    104
          <address type='pci' domain='0x0000' bus='0x01' slot='0x00' function='0x0'/>
    105
        </interface>
    106
        <serial type='pty'>
    107
          <target port='0'/>
    108
        </serial>
    109
        <console type='pty'>
    110
          <target type='serial' port='0'/>
    111
        </console>
    112
        <channel type='unix'>
    113
          <target type='virtio' name='org.qemu.guest_agent.0'/>
    114
          <address type='virtio-serial' controller='0' bus='0' port='1'/>
    115
        </channel>
    116
        <input type='tablet' bus='usb'>
    117
          <address type='usb' bus='0' port='1'/>
    118
        </input>
    119
        <input type='mouse' bus='ps2'/>
    120
        <input type='keyboard' bus='ps2'/>
    121
        <graphics type='vnc' port='-1' autoport='yes' websocket='-1' listen='0.0.0.0' keymap='en-us'>
    122
          <listen type='address' address='0.0.0.0'/>
    123
        </graphics>
    124
        <video>
    125
          <model type='qxl' ram='65536' vram='65536' vgamem='16384' heads='1' primary='yes'/>
    126
          <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x0'/>
    127
        </video>
    128
        <memballoon model='virtio'>
    129
          <address type='pci' domain='0x0000' bus='0x03' slot='0x00' function='0x0'/>
    130
        </memballoon>
    131
      </devices>
    132
    </domain>

     

     

  8. Hello all,

     

    I followed the guide and successfully passed the point where you reboot and change the resolution. Next step is to boot into the installer. The Apple logo show up then it reboots. I downloaded the latest clover when building the installer. 

     

    I couldn’t seem to find a similar issue in this thread, but there’s a couple comments on the YouTube video without a solution. 

     

    Thanks for everyone’s time and to threadrunner for the amazing videos!