phat_cow

Members
  • Posts

    101
  • Joined

  • Last visited

Everything posted by phat_cow

  1. Windows 11 latest update Unraid 6.10.0-RC2
  2. I can't seem to access my shares in Windows anymore. This happened after I updated Unraid? How do i turn on shares so that windows can see my server?
  3. Stick to bare metal for gaming. Unraid really sucks for gaming.
  4. Mine 2070 Super doesn't have USB-C port but the controller is present so I to has it through. I think I'm gonna ditch unraid and go back to baremetal and get a synology.
  5. When i'm gaming my game stutters for 1 second then goes back to normal. Few seconds later it will happen again. It's very consistent Motherboard: Gigabyte X570 Aorus Pro Wifi CPU: AMD Ryzen 3900X GPU: Nvidia 2070 Super Currently pinning core: 6 cores 12 threads, 3-8, 15-20 (HT). Is there something I can do to make this better? kernel /bzimage append initrd=/bzroot isolcpus=1-10,13-22 video=efifb:off <?xml version='1.0' encoding='UTF-8'?> <domain type='kvm' id='2'> <name>Windows 10 - Gaming</name> <uuid> </uuid> <metadata> <vmtemplate xmlns="unraid" name="Windows 10" icon="windows.png" os="windows10"/> </metadata> <memory unit='KiB'>16777216</memory> <currentMemory unit='KiB'>16777216</currentMemory> <memoryBacking> <nosharepages/> </memoryBacking> <vcpu placement='static'>12</vcpu> <cputune> <vcpupin vcpu='0' cpuset='3'/> <vcpupin vcpu='1' cpuset='15'/> <vcpupin vcpu='2' cpuset='4'/> <vcpupin vcpu='3' cpuset='16'/> <vcpupin vcpu='4' cpuset='5'/> <vcpupin vcpu='5' cpuset='17'/> <vcpupin vcpu='6' cpuset='6'/> <vcpupin vcpu='7' cpuset='18'/> <vcpupin vcpu='8' cpuset='7'/> <vcpupin vcpu='9' cpuset='19'/> <vcpupin vcpu='10' cpuset='8'/> <vcpupin vcpu='11' cpuset='20'/> <emulatorpin cpuset='0,12'/> </cputune> <resource> <partition>/machine</partition> </resource> <os> <type arch='x86_64' machine='pc-q35-5.1'>hvm</type> <loader readonly='yes' type='pflash'>/usr/share/qemu/ovmf-x64/OVMF_CODE-pure-efi.fd</loader> <nvram>/etc/libvirt/qemu/nvram/e4edb934-87ec-3e84-26e5-44d449a4ddb0_VARS-pure-efi.fd</nvram> <smbios mode='host'/> </os> <features> <acpi/> <apic/> <hyperv> <relaxed state='on'/> <vapic state='on'/> <spinlocks state='on' retries='8191'/> <vendor_id state='on' value='1234567890ab'/> </hyperv> <kvm> <hidden state='on'/> </kvm> <ioapic driver='kvm'/> </features> <cpu mode='host-passthrough' check='none' migratable='on'> <topology sockets='1' dies='1' cores='6' threads='2'/> <cache mode='passthrough'/> <feature policy='require' name='topoext'/> </cpu> <clock offset='localtime'> <timer name='hypervclock' present='yes'/> <timer name='hpet' present='yes'/> </clock> <on_poweroff>destroy</on_poweroff> <on_reboot>restart</on_reboot> <on_crash>restart</on_crash> <devices> <emulator>/usr/local/sbin/qemu</emulator> <disk type='file' device='disk'> <driver name='qemu' type='raw' cache='writeback'/> <source file='/mnt/user/domains/Windows 10 - Gaming/vdisk1.img' index='5'/> <backingStore/> <target dev='hdc' bus='virtio'/> <boot order='1'/> <alias name='virtio-disk2'/> <address type='pci' domain='0x0000' bus='0x05' slot='0x00' function='0x0'/> </disk> <disk type='block' device='disk'> <driver name='qemu' type='raw' cache='writeback'/> <source dev='/dev/disk/by-id/ata-WDC_WD3003FZEX-00Z4SA0_WD-WCC132352776' index='4'/> <backingStore/> <target dev='hdd' bus='virtio'/> <alias name='virtio-disk3'/> <address type='pci' domain='0x0000' bus='0x06' slot='0x00' function='0x0'/> </disk> <disk type='block' device='disk'> <driver name='qemu' type='raw' cache='writeback'/> <source dev='/dev/disk/by-id/ata-CT500MX500SSD1_1752E108D9BD' index='3'/> <backingStore/> <target dev='hde' bus='scsi'/> <alias name='scsi0-0-0-4'/> <address type='drive' controller='0' bus='0' target='0' unit='4'/> </disk> <disk type='block' device='disk'> <driver name='qemu' type='raw' cache='writeback'/> <source dev='/dev/disk/by-id/ata-CT2000MX500SSD1_1920E2045697' index='2'/> <backingStore/> <target dev='hdf' bus='scsi'/> <alias name='scsi0-0-0-5'/> <address type='drive' controller='0' bus='0' target='0' unit='5'/> </disk> <disk type='file' device='cdrom'> <driver name='qemu' type='raw'/> <source file='/mnt/user/isos/virtio-win-0.1.190-1.iso' index='1'/> <backingStore/> <target dev='hdb' bus='sata'/> <readonly/> <alias name='sata0-0-1'/> <address type='drive' controller='0' bus='0' target='0' unit='1'/> </disk> <controller type='scsi' index='0' model='virtio-scsi'> <alias name='scsi0'/> <address type='pci' domain='0x0000' bus='0x04' slot='0x00' function='0x0'/> </controller> <controller type='pci' index='0' model='pcie-root'> <alias name='pcie.0'/> </controller> <controller type='pci' index='1' model='pcie-root-port'> <model name='pcie-root-port'/> <target chassis='1' port='0x15'/> <alias name='pci.1'/> <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x5'/> </controller> <controller type='pci' index='2' model='pcie-root-port'> <model name='pcie-root-port'/> <target chassis='2' port='0x9'/> <alias name='pci.2'/> <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x1'/> </controller> <controller type='pci' index='3' model='pcie-root-port'> <model name='pcie-root-port'/> <target chassis='3' port='0xa'/> <alias name='pci.3'/> <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x2'/> </controller> <controller type='pci' index='4' model='pcie-root-port'> <model name='pcie-root-port'/> <target chassis='4' port='0xb'/> <alias name='pci.4'/> <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x3'/> </controller> <controller type='pci' index='5' model='pcie-root-port'> <model name='pcie-root-port'/> <target chassis='5' port='0xc'/> <alias name='pci.5'/> <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x4'/> </controller> <controller type='pci' index='6' model='pcie-root-port'> <model name='pcie-root-port'/> <target chassis='6' port='0xd'/> <alias name='pci.6'/> <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x5'/> </controller> <controller type='pci' index='7' model='pcie-root-port'> <model name='pcie-root-port'/> <target chassis='7' port='0xe'/> <alias name='pci.7'/> <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x6'/> </controller> <controller type='pci' index='8' model='pcie-root-port'> <model name='pcie-root-port'/> <target chassis='8' port='0xf'/> <alias name='pci.8'/> <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x7'/> </controller> <controller type='pci' index='9' model='pcie-root-port'> <model name='pcie-root-port'/> <target chassis='9' port='0x10'/> <alias name='pci.9'/> <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0' multifunction='on'/> </controller> <controller type='pci' index='10' model='pcie-root-port'> <model name='pcie-root-port'/> <target chassis='10' port='0x11'/> <alias name='pci.10'/> <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x1'/> </controller> <controller type='pci' index='11' model='pcie-root-port'> <model name='pcie-root-port'/> <target chassis='11' port='0x12'/> <alias name='pci.11'/> <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x2'/> </controller> <controller type='pci' index='12' model='pcie-root-port'> <model name='pcie-root-port'/> <target chassis='12' port='0x13'/> <alias name='pci.12'/> <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x3'/> </controller> <controller type='pci' index='13' model='pcie-root-port'> <model name='pcie-root-port'/> <target chassis='13' port='0x14'/> <alias name='pci.13'/> <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x4'/> </controller> <controller type='pci' index='14' model='pcie-to-pci-bridge'> <model name='pcie-pci-bridge'/> <alias name='pci.14'/> <address type='pci' domain='0x0000' bus='0x01' slot='0x00' function='0x0'/> </controller> <controller type='pci' index='15' model='pcie-root-port'> <model name='pcie-root-port'/> <target chassis='15' port='0x8'/> <alias name='pci.15'/> <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x0' multifunction='on'/> </controller> <controller type='virtio-serial' index='0'> <alias name='virtio-serial0'/> <address type='pci' domain='0x0000' bus='0x02' slot='0x00' function='0x0'/> </controller> <controller type='sata' index='0'> <alias name='ide'/> <address type='pci' domain='0x0000' bus='0x00' slot='0x1f' function='0x2'/> </controller> <controller type='usb' index='0' model='nec-xhci' ports='15'> <alias name='usb'/> <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x0'/> </controller> <interface type='bridge'> <mac address='52:54:00:6d:74:c6'/> <source bridge='br0'/> <target dev='vnet0'/> <model type='virtio-net'/> <alias name='net0'/> <address type='pci' domain='0x0000' bus='0x03' slot='0x00' function='0x0'/> </interface> <serial type='pty'> <source path='/dev/pts/0'/> <target type='isa-serial' port='0'> <model name='isa-serial'/> </target> <alias name='serial0'/> </serial> <console type='pty' tty='/dev/pts/0'> <source path='/dev/pts/0'/> <target type='serial' port='0'/> <alias name='serial0'/> </console> <channel type='unix'> <source mode='bind' path='/var/lib/libvirt/qemu/channel/target/domain-2-Windows 10 - Gaming/org.qemu.guest_agent.0'/> <target type='virtio' name='org.qemu.guest_agent.0' state='connected'/> <alias name='channel0'/> <address type='virtio-serial' controller='0' bus='0' port='1'/> </channel> <input type='mouse' bus='ps2'> <alias name='input0'/> </input> <input type='keyboard' bus='ps2'> <alias name='input1'/> </input> <hostdev mode='subsystem' type='pci' managed='yes'> <driver name='vfio'/> <source> <address domain='0x0000' bus='0x0a' slot='0x00' function='0x0'/> </source> <alias name='hostdev0'/> <rom file='/mnt/user/domains/msi2070supereditted.rom'/> <address type='pci' domain='0x0000' bus='0x07' slot='0x00' function='0x0'/> </hostdev> <hostdev mode='subsystem' type='pci' managed='yes'> <driver name='vfio'/> <source> <address domain='0x0000' bus='0x0c' slot='0x00' function='0x4'/> </source> <alias name='hostdev1'/> <address type='pci' domain='0x0000' bus='0x08' slot='0x00' function='0x0'/> </hostdev> <hostdev mode='subsystem' type='pci' managed='yes'> <driver name='vfio'/> <source> <address domain='0x0000' bus='0x03' slot='0x00' function='0x0'/> </source> <alias name='hostdev2'/> <address type='pci' domain='0x0000' bus='0x09' slot='0x00' function='0x0'/> </hostdev> <hostdev mode='subsystem' type='pci' managed='yes'> <driver name='vfio'/> <source> <address domain='0x0000' bus='0x07' slot='0x00' function='0x0'/> </source> <alias name='hostdev3'/> <address type='pci' domain='0x0000' bus='0x0a' slot='0x00' function='0x0'/> </hostdev> <hostdev mode='subsystem' type='pci' managed='yes'> <driver name='vfio'/> <source> <address domain='0x0000' bus='0x07' slot='0x00' function='0x1'/> </source> <alias name='hostdev4'/> <address type='pci' domain='0x0000' bus='0x0b' slot='0x00' function='0x0'/> </hostdev> <hostdev mode='subsystem' type='pci' managed='yes'> <driver name='vfio'/> <source> <address domain='0x0000' bus='0x07' slot='0x00' function='0x3'/> </source> <alias name='hostdev5'/> <address type='pci' domain='0x0000' bus='0x0c' slot='0x00' function='0x0'/> </hostdev> <hostdev mode='subsystem' type='pci' managed='yes'> <driver name='vfio'/> <source> <address domain='0x0000' bus='0x0a' slot='0x00' function='0x2'/> </source> <alias name='hostdev6'/> <address type='pci' domain='0x0000' bus='0x0d' slot='0x00' function='0x0'/> </hostdev> <hostdev mode='subsystem' type='pci' managed='yes'> <driver name='vfio'/> <source> <address domain='0x0000' bus='0x0a' slot='0x00' function='0x3'/> </source> <alias name='hostdev7'/> <address type='pci' domain='0x0000' bus='0x0f' slot='0x00' function='0x0'/> </hostdev> <memballoon model='none'/> </devices> <seclabel type='dynamic' model='dac' relabel='yes'> <label>+0:+100</label> <imagelabel>+0:+100</imagelabel> </seclabel> </domain>
  6. Hey, I've been having a microstuttering problems. What did you do to fix this? I have a 3900X.
  7. Got this card in today but not installed yet. Does this card require a sata power cable plugged in?
  8. After playing games for a bit. My game will crash resulting in a blue screen. Once VM restarts I check the error log in Event Viewer and found this: Windows successfully diagnosed a low virtual memory condition. The following programs consumed the most virtual memory: ModernWarfare.exe (4584) consumed 14206382080 bytes, chrome.exe (3832) consumed 525623296 bytes, and chrome.exe (10676) consumed 394199040 bytes. What does this mean?
  9. Programs crashing and found these errors in the Event Viewer. My gave my vdisk 60GB and I still have around 17GB free + 16GB of RAM. How is it possible that i'm getting these errors? Should I give my vdisk more space? Windows successfully diagnosed a low virtual memory condition. The following programs consumed the most virtual memory: HuntGame.exe (17132) consumed 12970504192 bytes, chrome.exe (14476) consumed 624963584 bytes, and MBAMService.exe (4492) consumed 338804736 bytes. The Windows Error Reporting Service service terminated with the following error: The paging file is too small for this operation to complete.
  10. Watch SpaceInvader One tutorial on youtube. Just remember to do what you do with isolcpus to nohz_full + rcu_nocs as well. I find adding nohz_full + rcu_nocs makes my games stuttered a lot. I had to remove it and just use isolcpus to make my games stutter free.
  11. So, best to do is 3c6t?
  12. Since the 3900x has 2 Dies (0-5, 12-17 is a die), Should I only assign Cores from a single die to my VM? For example: 2-5, 14-17?
  13. For my 3900x. Which cores should I be assigning to my gaming vm? I currently have 3-11,15-23 but I think this is wrong since my game (Hunt Showdown) crashes to desktop like ALL the time and when ever there is disk activity my VM stutters. I'm hoping assigning correct CPUs to my VM will fix this.
  14. When will this be fixed? If i made a wm10 vm using q35 5.1 and downgrade unraid to beta 25 and use q35 5.0 instead. Will i need another win10 license?
  15. Can't make changes to vm if array is disabled.
  16. I know this is an old post but i have the same issue except my vm is not a kvm image. My windows 10 is installed on an ssd and i passed the entire disk to my vm. How would i go about turning auto start off? My unraid freezes when ever vm is turned on.
  17. Sorry the 2nd image is someone's iommu but the iommu groups are pretty much the same except the GPU. I have a 2070 Super. I can't get an image of my old iommu group anymore.
  18. 2nd image (more iommu groups) is before and 1st image is after. No changes in hardware. I'm gonna downgrade the bios later tonight.
  19. Any reason why all my device ids changed and it appears there are fewer iommu groups. Motherboard is a Gigabyte x570 aorus pro wifi
  20. 0000:00:1f.2 Serms to have something to do with the sata controller.
  21. default menu.c32 menu title Lime Technology, Inc. prompt 0 timeout 50 label Unraid OS menu default kernel /bzimage append initrd=/bzroot video=efifb:off isolcpus=3-11,15-23 label Unraid OS GUI Mode kernel /bzimage append isolcpus=3-11,15-23 initrd=/bzroot,/bzroot-gui label Unraid OS Safe Mode (no plugins, no GUI) kernel /bzimage append initrd=/bzroot unraidsafemode label Unraid OS GUI Safe Mode (no plugins) kernel /bzimage append initrd=/bzroot,/bzroot-gui unraidsafemode label Memtest86+ kernel /memtest And this is what my vfio-pci.cfg looks like: BIND=0000:06:00.0|1022:1485 0000:06:00.1|1022:149c 0000:06:00.3|1022:149c 0000:03:00.0|1987:5012
  22. I just deleted old template and made a new one. Still getting this error.