Jump to content

TypeDan

Members
  • Content Count

    15
  • Joined

  • Last visited

Community Reputation

0 Neutral

About TypeDan

  • Rank
    Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Boom , yeah i did that . I just came back to here to close this. Thanks for getting back to me
  2. Hi, I've got a VM that I want to change the USB Controller from 2.0 EHCI to 3.0 but I get an error XML error: Attempted double use of PCI Address 0000:00:07.0. Here is a copy of my System Devices and IOMMU Groups PCI Devices and IOMMU Groups IOMMU group 0: [1022:1452] 00:01.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe Dummy Host Bridge IOMMU group 1: [1022:15d3] 00:01.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 15d3 IOMMU group 2: [1022:15d3] 00:01.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 15d3 IOMMU group 3: [1022:1452] 00:08.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe Dummy Host Bridge [1022:15dc] 00:08.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 15dc [1022:7901] 39:00.0 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 61) IOMMU group 4: [1022:15db] 00:08.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 15db IOMMU group 5: [1022:790b] 00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 61) [1022:790e] 00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 51) IOMMU group 6: [1022:15e8] 00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15e8 [1022:15e9] 00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15e9 [1022:15ea] 00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15ea [1022:15eb] 00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15eb [1022:15ec] 00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15ec [1022:15ed] 00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15ed [1022:15ee] 00:18.6 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15ee [1022:15ef] 00:18.7 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15ef IOMMU group 7: [10de:1c03] 10:00.0 VGA compatible controller: NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] (rev a1) [10de:10f1] 10:00.1 Audio device: NVIDIA Corporation GP106 High Definition Audio Controller (rev a1) IOMMU group 8: [1022:43d5] 15:00.0 USB controller: Advanced Micro Devices, Inc. [AMD] Device 43d5 (rev 01) [1022:43c8] 15:00.1 SATA controller: Advanced Micro Devices, Inc. [AMD] Device 43c8 (rev 01) [1022:43c6] 15:00.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 43c6 (rev 01) [1022:43c7] 1d:00.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 43c7 (rev 01) [1022:43c7] 1d:01.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 43c7 (rev 01) [1022:43c7] 1d:04.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 43c7 (rev 01) [1022:43c7] 1d:06.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 43c7 (rev 01) [1022:43c7] 1d:07.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 43c7 (rev 01) [10ec:8168] 25:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15) IOMMU group 9: [1002:15dd] 38:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] (rev c6) IOMMU group 10: [1002:15de] 38:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Device 15de [1022:15df] 38:00.2 Encryption controller: Advanced Micro Devices, Inc. [AMD] Device 15df [1022:15e0] 38:00.3 USB controller: Advanced Micro Devices, Inc. [AMD] Device 15e0 [1022:15e1] 38:00.4 USB controller: Advanced Micro Devices, Inc. [AMD] Device 15e1 [1022:15e3] 38:00.6 Audio device: Advanced Micro Devices, Inc. [AMD] Device 15e3 CPU Thread Pairings Pair 1: cpu 0 / cpu 1 Pair 2: cpu 2 / cpu 3 Pair 3: cpu 4 / cpu 5 Pair 4: cpu 6 / cpu 7 USB Devices Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 001 Device 002: ID 0781:5583 SanDisk Corp. Ultra Fit Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 004 Device 002: ID 1058:0820 Western Digital Technologies, Inc. My Passport Ultra (WDBMWV, WDBZFP) Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub SCSI Devices [0:0:0:0] disk SanDisk Ultra Fit 1.00 /dev/sda 15.3GB [1:0:0:0] disk ATA WDC WD40EFRX-68N 0A82 /dev/sdb 4.00TB [5:0:0:0] disk ATA Samsung SSD 850 2B6Q /dev/sdc 500GB [10:0:0:0] disk WD My Passport 0820 1012 /dev/sdd 2.00TB Does anyone have any ideas? I know I could make a new machine, but I'd rather not. Knowing my luck the new machine just wouldnt boot again.
  3. Hi, Finally got my Unraid server up and running, its brilliant. Trawling through this forum has helped solved the few annoying issues I had. Is there a way I can pull nvidia-smi stats from a card that's being passed through? Im running Telegraf , InFlux and Grafana, so I've pulled in what I've needed, it's just card statistics.. Thanks!
  4. Solved The above link fixed my issue, I didn't add pcie_aspm=off
  5. For now I've forced PCIe Gen 2 and the errors have gone away and so far, the VM seems more stable? Started to look into this a little more, I need to add this pcie_aspm=off , where :)? Edit Still havent added the line pcie_aspm=off, but now I have a problem with choppy sound going through HDMI, I'll try this https://lime-technology.com/wiki/UnRAID_6/VM_Guest_Support#Enable_MSI_for_Interrupts_to_Fix_HDMI_Audio_Support
  6. Hi, I purchased a Nvidia GTX 1060 , it passed through fine which I'm grateful for. Annoyingly, I had to use a riser but not unusual. Though I'm getting these errors in the log, ErrorWarningSystemArrayLogin Jan 15 16:02:46 Tower kernel: pcieport 0000:00:01.1: device [1022:15d3] error status/mask=00001000/00006000 Jan 15 16:02:46 Tower kernel: pcieport 0000:00:01.1: [12] Replay Timer Timeout Jan 15 16:02:46 Tower kernel: pcieport 0000:00:01.1: AER: Corrected error received: 0000:00:01.0 Jan 15 16:02:46 Tower kernel: pcieport 0000:00:01.1: PCIe Bus Error: severity=Corrected, type=Data Link Layer, (Receiver ID) Jan 15 16:02:46 Tower kernel: pcieport 0000:00:01.1: device [1022:15d3] error status/mask=00000040/00006000 Jan 15 16:02:46 Tower kernel: pcieport 0000:00:01.1: [ 6] Bad TLP Jan 15 16:02:46 Tower kernel: pcieport 0000:00:01.1: AER: Corrected error received: 0000:00:01.0 Jan 15 16:02:46 Tower kernel: pcieport 0000:00:01.1: can't find device of ID0008 Jan 15 16:02:46 Tower kernel: pcieport 0000:00:01.1: AER: Corrected error received: 0000:00:01.0 Jan 15 16:02:46 Tower kernel: pcieport 0000:00:01.1: PCIe Bus Error: severity=Corrected, type=Data Link Layer, (Receiver ID) Jan 15 16:02:46 Tower kernel: pcieport 0000:00:01.1: device [1022:15d3] error status/mask=00000040/00006000 Looking in PCI Devices and IOMMU Groups , IOMMU group 1: [1022:15d3] 00:01.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 15d3 IOMMU group 2: [1022:15d3] 00:01.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 15d3 PCIe ACS Override is disabled VFIO allow unsafe interrupts - no Any ideas?
  7. Purchased a 1060 GTX, passed through fine. This can be closed
  8. Still no joy, found an option on the motherboard to enable iommu, which I did . I have no idea what next to try.
  9. Thanks for getting back to me , appreciate it. Ive tried with a Q35, no joy :(, then I switched back. Ill bin this i440fx VM and soon up another with Q35 anyway. Atleast then I’m at a good place to start thanks
  10. Hi, I'm new to Unraid , so far it's the nuts. Though now I've got myself stuck. I built a Windows 10 VM using i440fx-3.0 OVMF. On the host , its just running a terrible GT 620 and on the VM I'm set the graphics card to the Vega iGPU. I get no output on the monitor, and all I can find is Jan 11 14:52:47 Tower kernel: iommu ivhd0: IOTLB_INV_TIMEOUT device=38:00.0 address=0x000000022e8502a0] Jan 11 14:52:48 Tower kernel: AMD-Vi: Completion-Wait loop timed out Jan 11 14:52:49 Tower kernel: AMD-Vi: Completion-Wait loop timed out Can anyone point me in the right direction what to do next? I know it seems pointless as its just an iGPU but that's all I have for now! [Solved] Purchased a a 1060 and managed to pass it through
  11. Yeah, its sorted now, across 10/100/1000 its A OK. Sorry for the troubles!
  12. Lol I know :D. They are through Powerline adaptors, I reckon one is turd, just connecting to the switch instead. Let's see!
  13. It's only a 100Mb/s but it should be faster than 2. Other tests I perform on the network to a different machine, yield higher results. I'll connect it through 10/100/1000 switch , lets see Still isn't right though
  14. Hi, I'm currently still investigating, but I have a problem with my newly installed Unraid 6.6.6 Created an SMB called media, connected to it via Windows 10 . When I perform a transfer to SMB, I get extremely slow performance. As it stands, I only have 1 WD 4TB Red installed, no cache , no parity. I haven't ordered more yet, I will :). When I say slow performance, I'm transferring from an SSD and getting 1-2 MB/s I've performed a disktest - it's performing as expected. SMART tells me there aren't any issues. I wouldn't expect there to be, its a fairly new disk. I've had a look at the Sticky already, cant find anything that's helping me, yet. Attached are the diagnostics. tower-diagnostics-20190110-0346.zip