bjornatic

Members
  • Content Count

    53
  • Joined

  • Last visited

Posts posted by bjornatic

  1. Yes it's passed through. And its a SAMSUNG 980PRO.

     

    1128765452_Capturedecran2021-05-22a09_50_07.png.1a59d023f9008a3c2cbf79c1ab94c6cd.png

    1195152740_Capturedecran2021-05-22a09_55_38.thumb.png.05d6b62ea29c492f5a6361495179f2ce.png

    <hostdev mode='subsystem' type='pci' managed='yes'>
          <driver name='vfio'/>
          <source>
            <address domain='0x0000' bus='0x04' slot='0x00' function='0x0'/>
          </source>
          <alias name='hostdev0'/>
          <address type='pci' domain='0x0000' bus='0x04' slot='0x00' function='0x0'/>
    </hostdev>

     

    I read that the Samsung controller where tricky and not advised on a Hackintosh. But I found no specific info/comment on this one ("Elpis" controller).

  2. So, I just installed Big Sur 11.3 Beta 5 (I think... I lost track). Anyway its build 20E5217a.

     

    I wanted to try e1000-82545em again as virtio-net was working fine except when I put the system to sleep : on wake I had lost all network.

     

    And so far I do not see the kernel panic I had on previous betas.

     

    I haven't done extended testing yet, but so far so good. And I can put my system to sleep again and not lose network on wake. File transfert from the Unraid server file also seems faster.

    • Thanks 1
  3. So. I'm happy to report that I found a solution to my problem. For the record, using NTS shares worked a little better (no instant kp), but it evnetually lead to a kp.

     

    The solution was to switch the adaptor to from e1000-82545em to virtio-net. And now everything is smooth. I can do TimeMachine backups and also tranfert a 15GB file in 4min.

     

    I knew about vmxnet3 as an alternative to e1000, but I noticed that another VM of mine was using virtio-net.... So I gave it a try and it was such a simple solution that I was mad not having found it earlier.

     

    I still could not find relevant infos on the different possible network adaptet... vmxnet3, e1000-.., virtio-net... Does other exist ? Where could I find info about them ?

    • Thanks 1
  4. panic(cpu 3 caller 0xffffff800969a036): [kext.kalloc.512]: element modified after free (off:8, val:0x0000000000000001, sz:512, ptr:0xffffff9352a13400, prot:zero)
        8: 0x0000000000000001
       32: 0x0000000400000000
      360: 0x0000000000000194
      368: 0x0000000022477c09
      376: 0x0000000000000194
      384: 0x0000000022477c09
    Backtrace (CPU 3), Frame : Return Address
    0xffffffa07d552c40 : 0xffffff8008e8af3d 
    [...]
    0xffffffa07d553fa0 : 0xffffff8008e301f6 
          Kernel Extensions in backtrace:
             com.apple.filesystems.smbfs(3.5)[187ED778-E51A-34B6-81DE-9462540A2F8F]@0xffffff7fa2eaa000->0xffffff7fa2f1ffff
                dependency: com.apple.kec.corecrypto(11.1)[AE778828-78BF-365E-8C5A-2B5BCBE843DF]@0xffffff800c0a9000->0xffffff800c13afff
                dependency: com.apple.kext.triggers(1.0)[7A3DE42E-FDB4-3B20-A098-EE36FFE425E2]@0xffffff7fa2f25000->0xffffff7fa2f27fff

     

    This is the crash report... I read "CPU panic" and "com.apple.filesystems.smbfs"...

     

    My vm uses the 4 last cores (8 HT) and now I'll try with isolating them.

  5. It does not hang anymore. It either passes or crashes. I do not get a transfert hang at 134.2meg followed by a error -8084 like I did on 11.2...

    I do not think a succesfull transfert log would be useful, right ?

     

    I was suspecting my samsung 980PRO nvme drive to be part of the problem as it only occures at speed (when transferring from my 100Mbps Pi, it all goes well). But copying from the unraid server to a USB drive via the VM leads to the same problem.

     

    I will tweak around my CPU settings (number and isolation) and see if there is any difference.

     

     

  6. Well. I just installed Wireshark and I'm playing with it.

    I recorded different file transfert from my Pi (100mbps) as from this source, the copy works fine even with a 9GB+ file.

     

    And then I recorded file transfert from my Unraid server. Small mp3 file : OK. 500meg .zip : OK. 5Gb ISO : started OK to my surprise, but it suddently crashed (and by crash I mean back to boot screen).

     

    Here are the last lines recorded : 16 beeing the unraid server, and 24 beeing my Big Sur VM.933284330_Capturedecran2021-02-19a13_24_58.thumb.png.5b5efde860630660a1975ed2c98484b0.png

     

    So I see nothing in praticular.

     

    I'm trying now to search the console for hints, but as I'm quite the beginner in this area, this may take a while ^^

     

  7. I still can't figure out why it is not working for me and it's starting to be problematic.

     

    I switched to vmxnet3 for a while and local network worked okayish (I could transfert data from the server and I could do TimeMachine backups), but the upload rate to the www was close to non existant. So I'm back on e1000-82545em.

     

    And as I'm not getting any progress on my own here are my settings :

     

    <interface type='bridge'>
          <mac address='xx:xx:xx:xx:xx:xx'/>
          <source bridge='br0'/>
          <target dev='vnet0'/>
          <model type='e1000-82545em'/>
          <alias name='net0'/>
          <address type='pci' domain='0x0000' bus='0x01' slot='0x00' function='0x0'/>
        </interface>

     

    My network settings :

    736541134_Networksettings.thumb.png.610fb24425a39aa3a39b2c578f3c10a4.png

     

    And SMB settings :

    84292078_SMBsettings.thumb.png.98c437afcd7a14a0554aa489ed95a540.png

     

    If some of you can see somthing wrong, that would be helpfull as I still do not understand why the solution proposed by Ghost82 is working for some and not for me.

  8. Hi !

    Is there a way to add a condition to prevent sleep based on UPS consumption ?

     

    My problem is : I use the S3 sleep pluging to automatically put my server to sleep. It checks if no VM is runnig by pinging them. BUT, If I'm in a OS update process, the VM is not responding to the ping, so the S3 sleep pluging puts the server to sleep. Crashing my update process.

     

    Graphic cards are passed through my VM resulting in more power consumption when active. I thought that by checking if the UPS power is below a certain value, the plugin could be "sure" that no VM is running.

     

    But maybe there is a smarter solution with virsh ?

  9. I do not now. I think it would be possible by adding the correct command in the sleep plugin (as sleep is not officially supported by Unraid).

     

    And it may be a clean way, but not the logical way in my opinion. The VM has to decide by itself (or by manual command) to be put to sleep. And THEN, the Unraid server, "seeing" that everyone is sleeping, puts himself to sleep. And that's how I have it working.

     

    The problem I have is on wake up ^^ (for MacOS only, though).

     

    EDIT : and by "sleep" I mean hibernate... just to be clear. And It this state I can even restart the server and the W10 VM will resume OK.

     

    EDIT again :  I looked around and noticed the option "Enable Virtual BMC :" in the VM manager. And I think that could enable what you suggested.

  10. I can answer this as I use a Windows 10 and BigSur VM :

     

    I can put to sleep the Windows Vm and put to sleep  Unraid with no problem : I wake Unraid, then the W10 wm, and all work fine. Everytime. All bueno.

     

    For my Bigsur VM (and for Catalina before it), it's another story and it's the ONLY thing that I can't solve on my Unraid system (well beside network troubles under BigSur..). Meaning the same operation as with the W10 VM works... sometimes. And I can't figure out why as the problem is not happening everytime. But that would be the subject of another thread 🤫

  11. Soooo... I moved to 11.2 beta 2 (20D5042d) with big hopes and faith it would be fixed so I can go on with my life.

     

    But no. Every single big file copy from my Unraid shares stops at 134,2Mo. Hangs and then error -8084

     

    With or without ghost82 proposed solution.

     

    Trying to make a full Time Machine backup lead to a complete system crash.

     

    I could make my first complete Time Machine backup without carshing. So there is a bright side to this update.

  12. 3 hours ago, Espressomatic said:

    Can anyone recommend a USB card that's still readily available that will work in pass through for MacOS?

     

    That's really the only thing I want to pass through at the moment as this VM otherwise runs headless. Hot-plug USB support and the ability to keep hold of USB-connected devices all the time are high priority for me.

     

    Running on a Supermicro server mainboard, which I recall may have some issues with certain chipsets.

    I'm using this one with no apparent problem : "nateck Carte Contrôleur USB 3.0 2 Ports PCI Express pour Win XP/7/8/10 Auto alimentée,KT4006"

    https://www.amazon.fr/gp/product/B00JEVLEFQ/

     

  13. I can report the same problem.

     

    More in detail :

    Unraid 6.9.0-beta35

    VM pc-q35-5.1 BigSur 11.1 / OpenCore 0.6.4

    e1000-82545em

     

    Copying a 9Gb file from my MacBook Pro (Catalina) connected over wifi works fine (at least the few times I tested) . Copying the same file from the same Macbook connect over ethernet 1Gb/s leads to a halt after exactly 134,2Mo and then error -8084

    Copying file directly from Unraid shares leads to kernel panic.

     

    The difference on copying over wifi or ethernet would be the speed (and even more copying from unraid shares).

     

    From what I understand from the discussions above, there is nothing much to do on our side, right ?

    • Like 1