[Support] diamkil - Overseerr


diamkil

57 posts in this topic Last Reply

Recommended Posts

59 minutes ago, progrockusa said:

Anyone know why the app still tries to go to port 3000? Already reinstalled this from scratch, including erasing the app data folder

 

container settings

click

wrong port

looks like you have some incorrect settings in your container. they repopulated when you reinstalled because the container template persists even if you remove the appdata folder (templates can be removed by going to the docker tab -> add container -> select template to delete -> press red x to delete). I think if you'll just fix/change your ports it should solve your issue.

 

Here's pictures of my current working and proxied setup for anyone that might find it helpful. WebUI port can be changed by clicking "advanced view" in the top right of the container settings page.

1972448565_2020-12-1807_43_51pm.thumb.png.a433377a085f814400734fe20cba0566.png

 

40959712_2020-12-1807_44_24pm.thumb.png.e9b992d5485429348226527a0a3e2bf7.png

Link to post
  • Replies 56
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

v3 is still not 'latest' release, its still marked as beta, and until this changes im afraid it will stay tagged as v3, as soon as it gets tagged as 'latest release' then i will merge the change from

Overview: Support for the docker template and container for Overseerr App: Overseerr - https://github.com/sct/overseerr Docker Hub: https://registry.hub.docker.com/r/sctx/overseerr

This is awesome! I've tried Ombi before but I like this better even in the ALPHA state. Looking forward to the updates!

Posted Images

Weird. I fixed it and it's accessible on internal network, but when I try to access external with Nginx Proxy Manager as my reverse proxy, it won't work.

I still have it redirecting to http://[internal IP]:5055 on the proxy manager.

 

Sigh.

 

EDIT: Further testing reveals that my entire reverse proxy is screwed up for some reason, will try and fix that first.

EDIT2: OH MY GOD, my freakin ISP changed my IP and all it took was to restart my router. Everything works now. Sorry, I'm just dumb lol.

Edited by Anthwerp
Link to post

I must say I really like Overseerr. I have tried Ombi before but it was a bit to cluttered and a bit messy. The interface for Overseer even in Alpha stage is really great. Need to push this through a reverse proxy and test this outside as well.

 

Link to post

Not sure if it's a problem my end but I had Overseer working great. This morning there was an update for the docker which I applied and I can no longer connect - I'm getting 'This site cannot be reached xx.xx.xx.xx refused to connect.

 

I'm using the default settings for the docker - not sure what other information to give

Link to post

Is this a space to make product suggestions? I've been using this for a week now with a bunch of my Plex users. Would appreciate the ability to auto-delete fulfilled requests after X hours or days. I'm a bit OCD and I like the request page clean :) 

Maybe also put in an expiry on requests that can't be fulfilled... There are some that don't have any sources and I'd like to auto-wipe them as well after a set number of days...

Link to post
14 hours ago, Anthwerp said:

Is this a space to make product suggestions? I've been using this for a week now with a bunch of my Plex users. Would appreciate the ability to auto-delete fulfilled requests after X hours or days. I'm a bit OCD and I like the request page clean :) 

Maybe also put in an expiry on requests that can't be fulfilled... There are some that don't have any sources and I'd like to auto-wipe them as well after a set number of days...

Their Discord is the best place for discussion: https://discord.gg/PkCWJSeCk7

 

Their GitHub Issues page allows you to make suggestions: https://github.com/sct/overseerr/issues

Link to post
  • 2 months later...

Is anyone else having issues getting Overseer to connect with Sonarr recently?

 

I don't get as much use out of Overseerr as I would like. So, I haven't noticed it until today, as I was having issues with the recent update to DelugeVPN, and I decided to go through and check to make sure all is well with the rest of my dockers.

 

When I try to connect to Sonarr in Overserr, it just says it can't connect. However, I can connect to Radarr (same IP/port 7878) just fine. I thought it may have been because I enabled the login page, but I disabled it, restarted and it didn't work. I made sure my API key matches, and even tried generating a new one and restarting Sonarr, but still no luck. Restarted Overseerr and Sonarr multiple times. Anything else I should try before deleting Overseer and starting over (really don't want to lol)?

 

Unraid server IP: 10.100.1.3

 

Overseerr:

image.thumb.png.8fe9544226e9bc088704a11891f79d23.png

 

Sonarr:

image.thumb.png.b85e810c4f714b1873af30620f658956.png

 

EDIT: Adding Overseer logs:
 

2021-02-26T17:17:58.367Z [[32minfo[39m]: Starting Overseerr version 1.20.0

2021-02-26T17:17:58.501Z [[32minfo[39m][Notifications]: Registered Notification Agents
2021-02-26T17:17:58.533Z [[32minfo[39m][Jobs]: Scheduled jobs loaded
2021-02-26T17:17:58.713Z [[32minfo[39m][Server]: Server ready on port 5055
2021-02-26T17:20:00.015Z [[32minfo[39m][Jobs]: Starting scheduled job: Plex Recently Added Sync
2021-02-26T17:20:00.018Z [[32minfo[39m][Plex Sync]: Plex Sync Starting {"sessionId":"e3a3e4d8-83bc-47ff-99a3-d0303f0448af"}
2021-02-26T17:20:00.023Z [[32minfo[39m][Plex Sync]: At least one 4K Radarr server was detected. 4K movie detection is now enabled
2021-02-26T17:20:00.024Z [[32minfo[39m][Plex Sync]: At least one 4K Sonarr server was detected. 4K series detection is now enabled
2021-02-26T17:20:00.038Z [[32minfo[39m][Plex Sync]: Beginning to process recently added for library: Movies
2021-02-26T17:20:22.026Z [[32minfo[39m][Plex Sync]: Beginning to process recently added for library: TV Shows
2021-02-26T17:20:22.508Z [[31merror[39m][Sonarr API]: Request failed with status code 404

2021-02-26T17:20:22.508Z [[31merror[39m][Sonarr]: Failed to get profiles

2021-02-26T17:20:23.288Z [[31merror[39m][Sonarr API]: Request failed with status code 404

2021-02-26T17:20:23.289Z [[31merror[39m][Sonarr]: Failed to get profiles

2021-02-26T17:20:25.184Z [[31merror[39m][Sonarr API]: Request failed with status code 404

2021-02-26T17:20:25.185Z [[31merror[39m][Sonarr]: Failed to get profiles

2021-02-26T17:20:26.078Z [[31merror[39m][Sonarr API]: Request failed with status code 404

2021-02-26T17:20:26.078Z [[31merror[39m][Sonarr]: Failed to get profiles

2021-02-26T17:20:27.057Z [[32minfo[39m][Plex Sync]: Recently Added Scan Complete
2021-02-26T17:21:21.320Z [[31merror[39m][Sonarr API]: Request failed with status code 404

2021-02-26T17:21:21.323Z [[31merror[39m][Sonarr]: Failed to get profiles

2021-02-26T17:22:20.817Z [[31merror[39m][Sonarr API]: Request failed with status code 401

2021-02-26T17:22:20.817Z [[31merror[39m][Sonarr]: Failed to get profiles

2021-02-26T17:22:22.945Z [[31merror[39m][Sonarr API]: Request failed with status code 404

2021-02-26T17:22:22.945Z [[31merror[39m][Sonarr]: Failed to get profiles

2021-02-26T17:25:00.071Z [[32minfo[39m][Jobs]: Starting scheduled job: Plex Recently Added Sync
2021-02-26T17:25:00.072Z [[32minfo[39m][Plex Sync]: Plex Sync Starting {"sessionId":"d81276a9-97d5-4120-8db8-7f565ab46387"}
2021-02-26T17:25:00.076Z [[32minfo[39m][Plex Sync]: At least one 4K Radarr server was detected. 4K movie detection is now enabled
2021-02-26T17:25:00.076Z [[32minfo[39m][Plex Sync]: At least one 4K Sonarr server was detected. 4K series detection is now enabled
2021-02-26T17:25:00.108Z [[32minfo[39m][Plex Sync]: Beginning to process recently added for library: Movies
2021-02-26T17:25:20.978Z [[32minfo[39m][Plex Sync]: Beginning to process recently added for library: TV Shows
2021-02-26T17:25:25.752Z [[32minfo[39m][Plex Sync]: Recently Added Scan Complete

 

Edited by carnivorebrah
Link to post
On 2/26/2021 at 11:23 AM, carnivorebrah said:

Is anyone else having issues getting Overseer to connect with Sonarr recently?

 

I don't get as much use out of Overseerr as I would like. So, I haven't noticed it until today, as I was having issues with the recent update to DelugeVPN, and I decided to go through and check to make sure all is well with the rest of my dockers.

 

When I try to connect to Sonarr in Overserr, it just says it can't connect. However, I can connect to Radarr (same IP/port 7878) just fine. I thought it may have been because I enabled the login page, but I disabled it, restarted and it didn't work. I made sure my API key matches, and even tried generating a new one and restarting Sonarr, but still no luck. Restarted Overseerr and Sonarr multiple times. Anything else I should try before deleting Overseer and starting over (really don't want to lol)?

 

Unraid server IP: 10.100.1.3

 

Overseerr:

image.thumb.png.8fe9544226e9bc088704a11891f79d23.png

 

Sonarr:

image.thumb.png.b85e810c4f714b1873af30620f658956.png

 

EDIT: Adding Overseer logs:
 


2021-02-26T17:17:58.367Z [[32minfo[39m]: Starting Overseerr version 1.20.0

2021-02-26T17:17:58.501Z [[32minfo[39m][Notifications]: Registered Notification Agents
2021-02-26T17:17:58.533Z [[32minfo[39m][Jobs]: Scheduled jobs loaded
2021-02-26T17:17:58.713Z [[32minfo[39m][Server]: Server ready on port 5055
2021-02-26T17:20:00.015Z [[32minfo[39m][Jobs]: Starting scheduled job: Plex Recently Added Sync
2021-02-26T17:20:00.018Z [[32minfo[39m][Plex Sync]: Plex Sync Starting {"sessionId":"e3a3e4d8-83bc-47ff-99a3-d0303f0448af"}
2021-02-26T17:20:00.023Z [[32minfo[39m][Plex Sync]: At least one 4K Radarr server was detected. 4K movie detection is now enabled
2021-02-26T17:20:00.024Z [[32minfo[39m][Plex Sync]: At least one 4K Sonarr server was detected. 4K series detection is now enabled
2021-02-26T17:20:00.038Z [[32minfo[39m][Plex Sync]: Beginning to process recently added for library: Movies
2021-02-26T17:20:22.026Z [[32minfo[39m][Plex Sync]: Beginning to process recently added for library: TV Shows
2021-02-26T17:20:22.508Z [[31merror[39m][Sonarr API]: Request failed with status code 404

2021-02-26T17:20:22.508Z [[31merror[39m][Sonarr]: Failed to get profiles

2021-02-26T17:20:23.288Z [[31merror[39m][Sonarr API]: Request failed with status code 404

2021-02-26T17:20:23.289Z [[31merror[39m][Sonarr]: Failed to get profiles

2021-02-26T17:20:25.184Z [[31merror[39m][Sonarr API]: Request failed with status code 404

2021-02-26T17:20:25.185Z [[31merror[39m][Sonarr]: Failed to get profiles

2021-02-26T17:20:26.078Z [[31merror[39m][Sonarr API]: Request failed with status code 404

2021-02-26T17:20:26.078Z [[31merror[39m][Sonarr]: Failed to get profiles

2021-02-26T17:20:27.057Z [[32minfo[39m][Plex Sync]: Recently Added Scan Complete
2021-02-26T17:21:21.320Z [[31merror[39m][Sonarr API]: Request failed with status code 404

2021-02-26T17:21:21.323Z [[31merror[39m][Sonarr]: Failed to get profiles

2021-02-26T17:22:20.817Z [[31merror[39m][Sonarr API]: Request failed with status code 401

2021-02-26T17:22:20.817Z [[31merror[39m][Sonarr]: Failed to get profiles

2021-02-26T17:22:22.945Z [[31merror[39m][Sonarr API]: Request failed with status code 404

2021-02-26T17:22:22.945Z [[31merror[39m][Sonarr]: Failed to get profiles

2021-02-26T17:25:00.071Z [[32minfo[39m][Jobs]: Starting scheduled job: Plex Recently Added Sync
2021-02-26T17:25:00.072Z [[32minfo[39m][Plex Sync]: Plex Sync Starting {"sessionId":"d81276a9-97d5-4120-8db8-7f565ab46387"}
2021-02-26T17:25:00.076Z [[32minfo[39m][Plex Sync]: At least one 4K Radarr server was detected. 4K movie detection is now enabled
2021-02-26T17:25:00.076Z [[32minfo[39m][Plex Sync]: At least one 4K Sonarr server was detected. 4K series detection is now enabled
2021-02-26T17:25:00.108Z [[32minfo[39m][Plex Sync]: Beginning to process recently added for library: Movies
2021-02-26T17:25:20.978Z [[32minfo[39m][Plex Sync]: Beginning to process recently added for library: TV Shows
2021-02-26T17:25:25.752Z [[32minfo[39m][Plex Sync]: Recently Added Scan Complete

 

Yes I am experiencing this as well this morning i was unable to get it to work. 

Link to post
3 minutes ago, rguinn said:

Any chance you can update the old repo ? 

v3 is still not 'latest' release, its still marked as beta, and until this changes im afraid it will stay tagged as v3, as soon as it gets tagged as 'latest release' then i will merge the change from v3 branch to master and latest will then be v3, make sense?.

  • Like 1
  • Thanks 1
Link to post
1 minute ago, binhex said:

v3 is still not 'latest' release, its still marked as beta, and until this changes im afraid it will stay tagged as v3, as soon as it gets tagged as 'latest release' then i will merge the change from v3 branch to master and latest will then be v3, make sense?.

Yes it does! very helpful info thank you for your support and all you hard work 

Link to post
  • 2 weeks later...

Just installed and I had things set up with Radarr and Sonnarr (binhex) and it was working perfectly for a few hours...now I am getting errors and it won't connect?? I believe I do have the newest version?? I verified API keys. 

at RadarrAPI.getQueue (/app/dist/api/radarr.js:145:23)
at runMicrotasks (<anonymous>)
at processTicksAndRejections (internal/process/task_queues.js:93:5)
at async /app/dist/lib/downloadtracker.js:51:36
at async Promise.all (index 0)
(node:27) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag `--unhandled-rejections=strict` (see https://nodejs.org/api/cli.html#cli_unhandled_rejections_mode). (rejection id: 92)

(node:27) UnhandledPromiseRejectionWarning: Error: [Radarr] Failed to retrieve queue: connect EHOSTUNREACH 192.168.1.5:8989

at SonarrAPI.getQueue (/app/dist/api/sonarr.js:22:23)
at runMicrotasks (<anonymous>)
at processTicksAndRejections (internal/process/task_queues.js:93:5)
at async /app/dist/lib/downloadtracker.js:96:36
at async Promise.all (index 0)
(node:27) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag `--unhandled-rejections=strict` (see https://nodejs.org/api/cli.html#cli_unhandled_rejections_mode). (rejection id: 94)

(node:27) UnhandledPromiseRejectionWarning: Error: [Radarr] Failed to retrieve queue: connect EHOSTUNREACH 192.168.1.3:7878

 

Edited by dja
Link to post

In case it helps anyone...my problem above was solved by NOT using HOST ip  config for the docker. My RADARR and SONARR are hosted by UNRAID dockers, so I don't think they can talk to each other in host mode. Might be good to change this on the docker install? Maybe I'm doing something wrong..lol

 

Set a custom bridge IP and perfecto. I'm really curious how it worked in the first place...but whatever. 

Edited by dja
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.