Unraid 6.9.0-rc1 - CPU TEMP NCT6687 Linux Driver Support


Bolagnaise

Recommended Posts

Apparently, my CPU temps come from k10temp (after upgrading to RC2 yesterday, haven't tried ich777's workaround before that since I missed it):

image.png.ee6a23390262b79ad1b0ad83bfb239a0.png

Also running sensors-detect in unRAID terminal (with default answers to confirmations) outputs this (if it is of any use):

Now follows a summary of the probes I have just done.
Just press ENTER to continue: 

Driver `k10temp' (autoloaded):
  * Chip `AMD Family 17h thermal sensors' (confidence: 9)

Driver `nct6775':
  * ISA bus, address 0x290
    Chip `Nuvoton NCT6798D Super IO Sensors' (confidence: 9)

Do you want to generate /etc/sysconfig/lm_sensors? (yes/NO): 
To load everything that is needed, add this to one of the system
initialization scripts (e.g. /etc/rc.d/rc.local):

#----cut here----
# Chip drivers
modprobe nct6775
/usr/bin/sensors -s
#----cut here----

You really should try these commands right now to make sure everything
is working properly. Monitoring programs won't work until the needed
modules are loaded.

Unloading i2c-dev... OK

 

Edited by UNOPARATOR
changed quote to code for output
Link to comment
23 minutes ago, ich777 said:

Then you maybe have another chip that manages the temps, fans,... Or it could even be that you have to install WMI ASUS but I even don't know what that is...

 

@Bolagnaise does the plugin work on RC2 for you?

Yep, Works on RC2 as well. I’m not sure if you really need to do to much work because it will be supported in the kernel soon(tm) anyway. let me find the asus WMI plugin i’ve seen people work on.

Link to comment
root@UNONAS:~# lsmod
Module                  Size  Used by
veth                   24576  0
xt_nat                 16384  34
xt_CHECKSUM            16384  1
macvlan                24576  0
ipt_REJECT             16384  2
ip6table_mangle        16384  1
ip6table_nat           16384  1
iptable_mangle         16384  1
ip6table_filter        16384  1
ip6_tables             28672  3 ip6table_filter,ip6table_nat,ip6table_mangle
vhost_net              24576  0
tun                    45056  4 vhost_net
vhost                  28672  1 vhost_net
vhost_iotlb            16384  1 vhost
tap                    24576  1 vhost_net
xt_MASQUERADE          16384  15
iptable_filter         16384  1
iptable_nat            16384  7
nf_nat                 36864  4 ip6table_nat,xt_nat,iptable_nat,xt_MASQUERADE
ip_tables              28672  3 iptable_filter,iptable_nat,iptable_mangle
xfs                   671744  8
md_mod                 45056  7
nct6775                53248  0
hwmon_vid              16384  1 nct6775
bonding               114688  0
edac_mce_amd           32768  0
btusb                  45056  0
kvm_amd                90112  10
btrtl                  16384  1 btusb
btbcm                  16384  1 btusb
btintel                24576  1 btusb
kvm                   421888  1 kvm_amd
bluetooth             380928  5 btrtl,btintel,btbcm,btusb
crct10dif_pclmul       16384  1
crc32_pclmul           16384  0
crc32c_intel           24576  2
ghash_clmulni_intel    16384  0
aesni_intel           364544  0
mvsas                  53248  8
wmi_bmof               16384  0
crypto_simd            16384  1 aesni_intel
cryptd                 16384  2 crypto_simd,ghash_clmulni_intel
ecdh_generic           16384  1 bluetooth
libsas                 69632  1 mvsas
i2c_piix4              24576  0
i2c_core               45056  1 i2c_piix4
wmi                    24576  1 wmi_bmof
k10temp                16384  0
scsi_transport_sas     32768  2 mvsas,libsas
glue_helper            16384  1 aesni_intel
igc                    86016  0
ecc                    24576  1 ecdh_generic
ahci                   40960  1
ccp                    69632  1 kvm_amd
libahci                28672  1 ahci
rapl                   16384  0
acpi_cpufreq           16384  0
button                 16384  0

 

Link to comment
11 minutes ago, UNOPARATOR said:

Ok, I will try that and report back.

  1. Should I be using your package and modprobe nct6687 then use sensors command to see what can be read?
  2. Or use sensors-detect and use the output commands for modprobe then use sensors command to see what can be read?

You do not have the nct6687 chip, it will not read anything from it. try 2.

Link to comment
3 minutes ago, Bolagnaise said:

You do not have the nct6687 chip, it will not read anything from it. try 2.

Alright just did #2. It is exactly the same as before.

k10temp is auto loaded. If I run "sensors" command it shows:

root@UNONAS:~# sensors
k10temp-pci-00c3
Adapter: PCI adapter
Tctl:         +66.6°C  
Tdie:         +66.6°C 

"sensor-detect" shows the same output:

#----cut here----
# Chip drivers
modprobe nct6775
/usr/bin/sensors -s
#----cut here----

 If I run the above lines, and then run "sensors" command, the same output is shown (only k10-temp, no values from nct6775).

root@UNONAS:~# modprobe nct6775
root@UNONAS:~# /usr/bin/sensors -s
root@UNONAS:~# sensors
k10temp-pci-00c3
Adapter: PCI adapter
Tctl:         +33.1°C  
Tdie:         +33.1°C

I guess I'm out of luck for the time being. Any other ideas?

Link to comment
  • 2 months later...
1 minute ago, Bolagnaise said:

@ich777 No longer works in 6.9.0 stable

Yep, exactly you have to download the new version for this Kernel version (so to speak the link has changed):

 

  1. cd /tmp
  2. wget https://github.com/ich777/unraid-plugins-repo/releases/download/5.10.19-Unraid/nct6687d-1.txz
  3. installpkg nct6687d-1.txz
  4. depmod -a
  5. modprobe nct6687
  • Like 1
  • Haha 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.