S3-Sleep geht nicht mehr?


47 posts in this topic Last Reply

Recommended Posts

Ich ärger mich auch quasi schon seit ich meinen Server hab mit dem Sleep plugin rum aber mitlerweile hab ich es für mich zuverlässig zum laufen bekommen.
Ich hab mich damit abgefunden das ich gänzlich auf den spindown status scheißen kann und den schonmal deaktiviert.
Als nächstes hab ich die Stunden des Tages in denen er meistens eh an ist und er nicht in den Sleep gehen soll wenn er an ist eingetragen.
Dann hab ich das Network monitoring an gemacht und auf 500kb/s gestellt. Natürlich kopiert man aber nicht dauerhaft Daten von und zu dem Server, deshalb hab ich noch bei "Wait for host inactivity" alle lokalen ip's eingetragen auf die er warten soll bis er schlafen geht. Das funktioniert aber auch nur wenn diese Geräte wirklich ausgeschaltet werden und nicht selbst in einem sleep ähnlichen Zustand verweilen.

Link to post
1 hour ago, darkside40 said:

Sind schon mehrere PR's zum S3 Plugin drin, der älteste wartet scheinbar schon gute 2 Monate.

 

Ja die Plugins scheinen leider kaum noch gepflegt zu werden:

IMG_20210201_205004.thumb.jpg.601070d9f269860648088cffbcaac822.jpg

 

Wird sich wohl irgendwann einer die Mühe machen müssen das zu forken und als neues Plugin einzustellen. Freiwillige vor ^^

 

 

Link to post

Und da kommen wir wir dann zu dem Problem mit der fehlenden Entwicklerdoku.

Diese besteht für das Plugin System zum größten Teil aus dieser "lose Blatt Sammlung" die sich größtenteils auf längst vergangene unRaid Versionen bezieht:

 

Btw ich habe die Master von meinem Plugin gestern mal geupdatet, jetzt sollte auch die überwachung des Arrays unter unRaif 6.9 funktionieren.

Wenn ich keine groben fehler gemacht habe dann sollte diese sich auch installieren lassen (das mit den Lizenzen für testmaschinen ist auch noch so ne Sache ;-) ).

Vorher aber am besten ein Config Backup machen.

Link to post
11 hours ago, Ford Prefect said:

Danke...werde das bis zum WE mal auf meinem grossen unRaid 6.8.3 testen.

 

Nur zur Info: Wenn der Server neu gestartet wird, dann muß man "einmal" die Disks händisch in den sleep schicken, weil sie sonst nur in den Standby gehen und dadurch der Server natürlich nicht mehr schlafen geht - aber ich vermute, dass das bekannt ist.

 

Und nach "jedem Aufwecken" mußt du dafür sorgen, dass die Platten alle "denselben Zustand" haben - das ist so gut wie nie der Fall.

Manche sind im Sleep-Mode, andere im Standby-Mode. Die Platten im Standby-Mode verhindern, dass der Server schlafen gehen kann.

Man kann das mit einem Befehl unter "Custom commands after wake-up:" korrigieren:

 

sleep 120;
hdparm -y $(ls /dev/sd*|grep "[a-z]$") >/dev/null 2>&1

 

Damit werden alle Platten definiert in den sleep geschickt und der Server kann dann auch schlafen gehen.

Edited by Zonediver
Link to post

...danke @Zonediver, sehr hilfreich!

Wie am Eingang beschrieben, hat der Server die Schlaf-Arbeit einfach eingestellt, ohne eine Konfig-Änderung.

irgendwas lässt das Plugin glauben, dass eine Disk immer noch im Zugriff sei....manuelles spin-down behebt das sofort.

 

Link to post
20 minutes ago, Ford Prefect said:

...danke @Zonediver, sehr hilfreich!

Wie am Eingang beschrieben, hat der Server die Schlaf-Arbeit einfach eingestellt, ohne eine Konfig-Änderung.

irgendwas lässt das Plugin glauben, dass eine Disk immer noch im Zugriff sei....manuelles spin-down behebt das sofort.

 

 

Ja wenn der Server nicht schlafen geht, dann ist eine/mehrere Disks aktiv - daher auch das Prüf-Kommando, damit man sieht welche es ist.

Bei jeder Disk muß "standby" stehen. Wenn das nicht der Fall ist, geht der Server nicht in den Sleep.

Dann kann man schaun, ob auf der betreffenden Disk sonst irgendwas abgeht.

Ich denke nicht, dass das etwas mit dem Plugin zu tun hat.

Es könnte auch an der Hardware liegen - SAS-Disk z.B. sind da so ne Sache...

Edited by Zonediver
Link to post

@Zonediver dieser Workaround ist nötig weil 2018 im S3 Sleep Plugin eine zustätzliche überprüfung via hdparm eigeführt wurde. Ab da hat das Plugin nie mehr richtig funktioniert.

Ich habe den Check bei meinem Fork einfach rausgenommen, deshalb kann ich darauf verzichten noch irgendwelche Kommandos nach dem Reboot etc. auszuführen.

Manchmal sollte man manche Dinge lieber unangetastet lassen.

Link to post
5 minutes ago, darkside40 said:

@Zonediver dieser Workaround ist nötig weil 2018 im S3 Sleep Plugin eine zustätzliche überprüfung via hdparm eigeführt wurde. Ab da hat das Plugin nie mehr richtig funktioniert.

Ich habe den Check bei meinem Fork einfach rausgenommen, deshalb kann ich darauf verzichten noch irgendwelche Kommandos nach dem Reboot etc. auszuführen.

Manchmal sollte man manche Dinge lieber unangetastet lassen.

 

Hast du ein neues Plugin geschrieben? Das wäre interessant.

Das S3-Plugin hat bei mir erst richtig funktioniert, nachdem ich die Disks kontrolliert in den Standby versetzt habe. Dieses Problem ist aber uralt und der Programmierer hat das nie "ausgebessert".

Scheinar ist das ebenfalls von Hardware zu Hardware verschieden...

Edited by Zonediver
Link to post

Nein ich habe garnichts neu entwickelt. Ich habe das Script mal vor Jahren für mich angepasst nachdem die Änderungen den HDD Activity check bei mir unbrauchbar gemacht haben und der ursprüngliche Entwickler auf keine meiner Anmerkungen reagiert hat. Irgendwann hab ich es dann man Freunden zur verfügung gestellt die das gleiche Problem hatten.

Seitdem halte ich das Script auf nem aktuellen Stand wenn auch Bergware was ändert.

 

Die Version des Script gibt es hier: https://github.com/bjoerns1983/S3Sleep/tree/master

Support gebe ich normalerweise hier: https://www.kodinerds.net/index.php/Thread/68247-unRaid-S3-Sleep-Plugin-darkside40-Edition/?pageNo=1

Link to post
43 minutes ago, darkside40 said:

Nein ich habe garnichts neu entwickelt. Ich habe das Script mal vor Jahren für mich angepasst nachdem die Änderungen den HDD Activity check bei mir unbrauchbar gemacht haben und der ursprüngliche Entwickler auf keine meiner Anmerkungen reagiert hat. Irgendwann hab ich es dann man Freunden zur verfügung gestellt die das gleiche Problem hatten.

Seitdem halte ich das Script auf nem aktuellen Stand wenn auch Bergware was ändert.

 

Die Version des Script gibt es hier: https://github.com/bjoerns1983/S3Sleep/tree/master

Support gebe ich normalerweise hier: https://www.kodinerds.net/index.php/Thread/68247-unRaid-S3-Sleep-Plugin-darkside40-Edition/?pageNo=1

 

Ah ok - versteh - danke für die Links - schau ich mir gleich an 👍

Edited by Zonediver
Link to post
  • 2 weeks later...
  • 4 weeks later...
  • 2 weeks later...

Hallo Leute,

 

bin newbie und hab ein automatisches "Einschlafproblem" 😀

 

es gibt bein meinem Server einen task (find) der ihn vor der ersehten Ruhe bewahrt und ich weiß nicht woher der kommt. Manuelles einschlafen funktioniert (Rechner kann nur mit WOL geweckt werden aber bei der Automatik versagt das. hier ist ein log Ausschnitt.

 

Bin für Hinweise sehr dankbar.

 

Zappmax

Unraid 6.9.1

Darksides plugin

 

 

 

 

 

 

s3_log

Edited by Zappmax
Link to post
2 hours ago, Zappmax said:

hier ist ein log Ausschnitt.

Ich verstehe leider nicht wie man den Backtrace lesen muss, aber in den Logs siehst du die pid, die das Schlafen verhindert:

Mar 24 00:24:11 Tower kernel: task:find            state:D stack:    0 pid: 9362 ppid:  9361 flags:0x00004004

 

Jetzt könntest du kurz danach im Webterminal das ausführen um herauszufinden wie dieser Prozess heißt:

ps -p 9362 -o command

 

Muss aber zeitnah passieren, da Prozesse die pid wechseln können.

Link to post

Hi,

 

sorry für die späte Meldung hatte wohl übersehen im Account email notification zu aktivieren.

ja ich habe das dynamix cache directory plug in installiert.

 

den ps befehl auszuführen war schwierig da die pid sehr schnell wechselt, mit htop konnte ich aber super komfortabel auf find filtern.

 

Demnach verweist es auf meine backupfolder. Ich nutze duplicati und backuppc als eigenständige docker container. Selbst wenn ich  beide container stoppe taucht der 

find befehl zyklisch auf.

 

 

 

remmina_1.png

remmina_2.png

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.