HELP - Windows 10 VM stuck at boot screen


frakman1

7 posts in this topic Last Reply

Recommended Posts

So my Windows 10 VM has been working fine for months. I recently went in and enabled the Sandbox option via the "Turn Windows features on or off" menu in Control Panel Settings. After a required reboot, the VM now refuses to boot and is stuck in the bootup screen.

 

image.png.9fba10ea3094e7bb3a10d4d425113d45.png

 

After rebooting a few times, it goes into "Preparing Automatic Repair" 

I went into the Repair options page but nothing worked.

 

image.png.dd6a718e6596056bbc30e409ec0c3e08.png

 

"System Restore" option wouldn't even recognize a windows installation.

Under "Command Prompt", I could see the drive with the Windows installation.

I have the install media and virtio driver isos both connected. I tried the "drvload <path to>viostor.inf" command and that made the windows 10 installation be recognized by the Rescue menu but Startup repair still failed. 

I don't see any option for a Safe Mode boot.

 

I tried booting from the insall disk to see what other repair options exist but nothing seemed to help.

I tried changing the template to use a single core but that didn't work.

I tried creating a new Windows VM using both Win 7 and Win 10 templates and pointing to a copy of the vdisk1.img file but got the same behaviour.

 

These are the drives I see:

 

image.png.32b481365d28d58fbcc0c3e718c9fa42.png

 

image.png.b925606b671f465aa81e7ac6676243b2.png

 

image.png.4831e755479d150a4242f69eeca94acb.png

 

I attached the XML file for reference.

 

I  don't know what else to do and I really don't want to start from scratch again.

Unfortunately, I didn't back up the VM ( I wish I did now)

Any help would be greatly appreciated.

 

win10.xml

Edited by frakman1
Link to post

I loaded the viostor driver like this:

 

image.png.b8946563e62cce674f616d4e289c9d2e.png

 

Then used dism to inject the driver into the windows installation

 

image.png.6419bd83b90c39a6451d96b2c7f30231.png

 

I tried rebooting here but nothing changed. So I went back and redid the above steps then used bcdedit to make it go to safemode

 

bcdedit /set {current} safeboot minimal

 

But that didn't change anything after a reboot (or choosing "continue to boot from Windows 10") either.

I also tried without the {current} string:

 

bcdedit /set safeboot minimal

 

I am out of ideas at this point. 

Link to post

It turned out that I had to use {default} instead of {current} to make it go into safe mode properly. 

 

bcdedit /set {default} safeboot minimal

 

The way to know which one to use, it to look at the output of bcdedit

 

Once I did that and rebooted, it went ito Safemode after complaining about an update failing and that it was undoing changes. It did that a second time after rebooting. Finally, it booted into Windows in SafeMode. I then ran msconfig and turned off SafeMode, rebooted and it worked normally again. Phew!

 

This link was helpful in getting things working

Edited by frakman1
Link to post
  • 1 month later...

Added Notes.

If the above didn't work, then try this (worked on a different failed VM)

 

Bootrec.exe /FixMbr

Bootrec.exe /FixBoot

Bootrec.exe /ScanOs

Edited by frakman1
Link to post
  • 1 month later...

Hello @frakman1 thank you for this topic.

 

I'm struggling with the same problem here. It looks like your solution should help me but when I try to do

"drvload viostor.inf" I get the loaded successful message, but then the system stop responding and freezes.

 

Any ideas why is this happening? I really don't want to reinstall windows. Any help is welcome.

 

Thank's 

Link to post

The "drvload" command should be run within the "Command Prompt" box, so it is surprising to me that anything would hang since it's not a full-blown windows environment. 

I don't really know but if it's hanging after loading the virtio driver, then take a look at which iso you are using. I'm using this one:

image.png.32e62b0c19161ae181b05b7947fe315e.png

 

Maybe you could try different ones.

Link to post

@frakman1

 

Yes, that is pretty weird... But I'm doing exactly that, via CMD line.... I've also tried multiple  virtio isos... no luck, it always frezes...

 

This is very annoying, I'm now building a VM from scratch, unfortunately I'll lose everything on the other one... A shame, it was running perfectly until a bad reboot...

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.