Einige Docker Apps nicht mehr aufrufbar


7 posts in this topic Last Reply

Recommended Posts

Hallo Zusammen,

 

ich habe nun mitlerweile mein unRAID NAS zusammen gebaut und habe das vorab eingerichtete System groesstenteils migriert.

Anfangs lief auch alles aber nach kurzer Zeit nicht mehr.

 

Mein Problem ist, dass ich die Docker Apps InfluxDB und NginxProxyManager nicht mehr per WebGUI oeffnen kann.

Ich habe bereits fast alles was mir einfiel ausprobiert, sprich deinstalliert und neu installiert. Bridge und Host probiert, NAS neugestartet uvm.

 

Andere WebGUIs, wie Nextcloud,Emby, JDownloader, Krusader, Ombi und RSScralwer gehen.

 

Wenn ich also eine der nicht funktionierenden Apps aufrufe kommt lediglich:

InfluxDB - http://192.168.1.127:8083/

Unable to connect

Firefox can’t establish a connection to the server at 192.168.1.127:8083.

Habe ich gerade erneut geloescht und wollte es installieren ueber CommuityApps, mit neuen appdata ordner aber es kommt folgende Fehlermeldung:

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='Influxdb' --net='bridge' -e TZ="Europe/Berlin" -e HOST_OS="Unraid" -p '8083:8083/tcp' -p '8086:8086/tcp' -v '/mnt/user/appdata/influxdb2':'/var/lib/influxdb':'rw' 'influxdb:latest'

/usr/bin/docker: Error response from daemon: stat /var/lib/docker/btrfs/subvolumes/2d6293938de9e71409d3b3285f1398a5a582218f56890618309c435cdc7d3ee7: no such file or directory.
See '/usr/bin/docker run --help'.
The command failed.


Kann mir jemand helfen? Danke!
 

 

Edited by postboy99
Link to post

Das könnte auf ein korruptes docker Image hindeuten. 

Hast du in den logs weitere Fehlermeldung bzgl. Btrfs, loop2? 

Wenn nach einem Server reboot weiterhin immer die selben Docker Probleme machen (nicht starten bzw nicht ordentlich laufen) würde ich mal das docker.img löschen (settings>docker) und anschließend neu erstellen. Danach über Apps>Previous deine Docker neu installieren. Wenn du über Apps>Previous gehst werden alle Docker genau so installiert und konfiguriert wie beim letzten mal. 

Aber check erst mal das Log. 

Link to post
36 minutes ago, saber1 said:

Hast Du es einmal mit CA Cleanup Appdata versucht?

Hat leider nicht geholfen.

 

29 minutes ago, vakilando said:

Das könnte auf ein korruptes docker Image hindeuten. 

Hast du in den logs weitere Fehlermeldung bzgl. Btrfs, loop2? 

Wenn nach einem Server reboot weiterhin immer die selben Docker Probleme machen (nicht starten bzw nicht ordentlich laufen) würde ich mal das docker.img löschen (settings>docker) und anschließend neu erstellen. Danach über Apps>Previous deine Docker neu installieren. Wenn du über Apps>Previous gehst werden alle Docker genau so installiert und konfiguriert wie beim letzten mal. 

Aber check erst mal das Log. 

Im Log stand nichts, hat aber scheinbar geholfen. Geht wieder alles ausser influxdb, bin mir aber nicht sicher wie das vorher dort war.

Muss jetzt eh grafana etc. neu einrichten...

 

Aber danke fuer die Hilfe!

Link to post



Geht wieder alles ausser influxdb


Ich hatte bzgl. Datenbanken mit postgres das Problem, dass ich das volume mit /mnt/cache/appdata... und nicht /mnt/user/appdata... einbinden musste, sonst wollte postgres nicht starten.
Probier das ggf mal so.
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.