GTX 1050 ti passthrough error 43


Maginos

Recommended Posts

error code 43 disappears after installation of Game Ready driver, then comes back after reboot

 

 

Hi guys,

 

as the title suggests, I also have problems with code 43 error and wanted to know, if someone can help me. This my setup:

-Unraid server with latest OS (6.8.3, AMD Ryzen 5 2600X, Asus TUF B450-Plus Gaming)

-WIN 10 VM with passthroughed GTX 1050 ti (no vdisk, but existing WIN 10 installation on hardware SSD)

 

When I start the vm, the error 43 occurs. Driver booster says, it has the recent drivers (27.21.14.6109, from 31.12.2020). When I install GeForce Game Ready Driver from GeForce Experience (finishes with "Installation successful"), I can observe two things:

-The error code 43 disappears, which is good

-The option to install the latest Game ready drivers does not disappear

When I then reboot the VM, the error occurs again and the latest game ready driver can again be installed.

 

What I’ve tried so far (I’ve watched all related youtube videos from spaceinvader):

 

-update motherboard bios

-Dump edited vbios (I got the vbios with GPU-Z on another WIN machine)

-passthrough sound card

-activate multifunction

-activate kvm hidden state

-activate iommu

-deactivate hyper-v

-put in random vendor id

-boot unraid in legacy mode

-vfioed the gpu and the sound card

-added „video=efifb:off“ to syslinux under „Unraid OS“ (here’s what’s written there: append pcie_acs_override=downstream,multifunction vfio_iommu_type1.allow_unsafe_interrupts=1 initrd=/bzroot iommu=on video=efifb:off)

-remove vnc and connect via anydesk (I did this with and without gpu vbios)

-remove the display drivers in the vm with DDU and install the gpu driver manually

 

 

Please find the xml File of the vm below.

 

Can anyone help me with this?

 

Thank you very much in advance!

Maginos

 

win10.rtf

Edited by Maginos
Link to comment

Your XML is not showing up properly. 

 

Edit your PCIe ACS override to both(settings ->VM manger -> Advanced. Then re-add the video card. (if you are passing though your NVMEE/sate you will have to redo this passthrough also after changing this.

Edited by runamuk
Link to comment
8 hours ago, runamuk said:

Your XML is not showing up properly. 

 

Edit your PCIe ACS override to both(settings ->VM manger -> Advanced. Then re-add the video card. (if you are passing though your NVMEE/sate you will have to redo this passthrough also after changing this.

@runamuk thank you for your answer, I changed the xml, it should work now. 
PCIe ACS override I already set to both according to spaceinvaders video, I just forgot it to mention in the list above.

Link to comment

I generally only have good luck passing through GPUs when I create a new VM and do not use the VNC driver initially but instead the GPU (I have a 3970x with 3 2080TIs as gaming VMs).  Also Q35 5.1.  In my case I pass through M.2 SSDs but I've used virtual disks before with no problem.  

Link to comment
On 1/23/2021 at 5:49 AM, sprange said:

I generally only have good luck passing through GPUs when I create a new VM and do not use the VNC driver initially but instead the GPU (I have a 3970x with 3 2080TIs as gaming VMs).  Also Q35 5.1.  In my case I pass through M.2 SSDs but I've used virtual disks before with no problem.  

Unfortunately it didn't work with the new vm. Do you have any other tips?

Link to comment
39 minutes ago, Maginos said:

Unfortunately it didn't work with the new vm. Do you have any other tips?

So you mean the new VM (created using the GPU passed through for the install and no VNC driver) still gives you a code 43 in windows?  Do you have CSM enabled?  I have nothing special in my config...just the vendor name to some random 12 digit ID and nothing else changed.  Audio device passed through as well?  Is the 1050 your only video card?

Link to comment
On 1/25/2021 at 10:25 PM, sprange said:

So you mean the new VM (created using the GPU passed through for the install and no VNC driver) still gives you a code 43 in windows?  Do you have CSM enabled?  I have nothing special in my config...just the vendor name to some random 12 digit ID and nothing else changed.  Audio device passed through as well?  Is the 1050 your only video card?

@sprange Sorry for the late answer.

Yes exactly. I have CSM enabled with following settings:

Boot: UEFI and Legacy OPROM

Boot from network devices: Legacy only (also for Boot from external devices and for Boot from PCIe extension cards)

 

Yes I added kvm hidden state and these things to the xml, but that didn't change anything. Infact, WIN freezes after entering the login credentials... Two times yes, I passed through the audio device and the 1050 ti is the only video card. I have a AMD Radeon HD6870 laying around, if needed.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.