[Support] FlippinTurt PiHole DoT-DoH


Recommended Posts

I just updated to the latest and now I get the following constantly in my log:

[06:51:23.898979] STUBBY: Read config from file /config/stubby.yml
Starting cloudflared
./run: line 7: /usr/local/bin/cloudflared: No such file or directory
Stopping stubby
Stopping cloudflared
cloudflared: no process found

It just repeats over and over, and all queries in my web browser result in Name Unresolved errors.

Link to comment
48 minutes ago, pokeguru87 said:

I just updated to the latest and now I get the following constantly in my log:

[06:51:23.898979] STUBBY: Read config from file /config/stubby.yml
Starting cloudflared
./run: line 7: /usr/local/bin/cloudflared: No such file or directory
Stopping stubby
Stopping cloudflared
cloudflared: no process found

It just repeats over and over, and all queries in my web browser result in Name Unresolved errors.

Fixing this now, apologies!
Will post a comment once the fix has been uploaded

Link to comment
1 hour ago, pokeguru87 said:

I just updated to the latest and now I get the following constantly in my log:

[06:51:23.898979] STUBBY: Read config from file /config/stubby.yml
Starting cloudflared
./run: line 7: /usr/local/bin/cloudflared: No such file or directory
Stopping stubby
Stopping cloudflared
cloudflared: no process found

It just repeats over and over, and all queries in my web browser result in Name Unresolved errors.

Fixed now, please force update (Or select check for updates)
Have also updated cloudflared to the latest available version (2021.9.0)

Sorry for that!
Should run even better now though :)

Link to comment
32 minutes ago, sagfvgj said:

looks like stubby.yml now uses google instead of cloudflare.

Stubby (DOT/TLS) by default uses google. you can change this in the stubby config file in your appdata by adding # to the google config and removing them from the cloudflare config. If you already did this then perhaps the file got removed or corrupt on the last update and was replaced.

 

I've had issues in the past with cloudflared(DOH/https) but it seems to be working fine for me for a long time now, so consider using that. As in my opinion it is marginally better privacy wise as you will "hide" your dns traffic under the gianourmous load of https traffic. You could use both doh and dot but I do need see the benefit of this.

Link to comment

Hey,

First of all, thanks for the great docker!

However I'm trying to add this whitelist but for that I need python3 inside the docker. Any idea I can get a walk through on how to do it? I've tried searching for it, but I don't get a concrete answer on how to install python3 inside a docker container (or if it's even possible). I tried entering in the console "sudo apt-get python3" but to no avail...

Any help would be greatly appreciated.

 

Thanks!

Link to comment

First time using this particular version of pihole docker. I was previously using a different one that worked. However, I really was drawn to the more encrypted nature of this docker. Thanks to those who support it.

 

Any who. I just updated my DNS in my router settings to use the local IP of the Pihole docker like I've done in the past, but instead of my network traffic being routed through pihole, it actually ended up preventing me for a short time from accessing the internet and my server/ pihole until I changed the DNS back to its previous IP.


Am I missing something unique with this particular version? Some of this stuff is a bit over my head so I'm definitely learning as I go. 

Link to comment

Hi there,

I've just set this up for the most part everything is working fine apart from two things. 

1. Spam within the logs of timeouts. 
2. When attempting to update graverty (aka the ads lists), I'm getting timeouts. 

More on #1:
image.thumb.png.2ff8356a540ab7508a00094252875665.png

More on #2:
image.thumb.png.6ff5cda23451a54e8f26292e4916af3b.png

 

I have both custom addresses set so as follows: 127.1.1.1#5153, 127.2.2.2#5253.

Any help would be appreciated! 

Link to comment

Hi folks, just in case anyone else was having the DNS resolution issues here is the fix. 

Go to edit the docker container, enable Advanced options in the top right, then under "Extra Parameters" enter `--dns=8.8.8.8` (or a dns server of your choosing) and select Apply. This solved the issue for me. Still getting the above log spam through that seems specific to this container. This from what I've seen online tells the docker container what DNS server to use for its own "internal" lookups e.g. gravity updates. 

Edited by Inch
Link to comment
On 9/18/2021 at 4:14 PM, sergio.calheno said:

Hey,

First of all, thanks for the great docker!

However I'm trying to add this whitelist but for that I need python3 inside the docker. Any idea I can get a walk through on how to do it? I've tried searching for it, but I don't get a concrete answer on how to install python3 inside a docker container (or if it's even possible). I tried entering in the console "sudo apt-get python3" but to no avail...

Any help would be greatly appreciated.

 

Thanks!

 

Hmm, apt installing python3 and then running those whitelist scripts works perfectly for me...

 

sudo apt update

sudo apt install python3

 

 

Edited by zer0zer0
  • Thanks 1
Link to comment
  • 3 weeks later...

Hello,

 

Trying to install on Raspberry Pi 4. Docker installs fine with command below, no errors. RBP4 IP is 192.168.1.5. The problem is I cant access the Pi-hole interface at 192.168.1.5/admin. Any ideas? also tried with testdasi/pihole-dot-doh:stable-rpi4 as per the readme at https://hub.docker.com/r/flippinturt/pihole-dot-doh.

 

docker run -d \
    --name='pihole-dot-doh-1' \
    --cap-add=NET_ADMIN \
    --restart=unless-stopped \
    --net='bridge' \
    -e TZ="Europe/London" \
    -e HOST_OS="Pi4" \
    -v '/mnt/user/appdata/pihole-dot-doh/pihole/':'/etc/pihole/':'rw' \
    -v '/mnt/user/appdata/pihole-dot-doh/dnsmasq.d/':'/etc/dnsmasq.d/':'rw' \
    -v '/mnt/user/appdata/pihole-dot-doh/config/':'/config':'rw' \
    -e 'DNS1'='127.1.1.1#5153' \
    -e 'DNS2'='127.2.2.2#5253' \
    -e 'TZ'='Europe/London' \
    -e 'WEBPASSWORD'='password' \
    -e 'INTERFACE'='br0' \
    -e 'ServerIP'='192.168.1.5' \
    -e 'ServerIPv6'='' \
    -e 'IPv6'='False' \
    -e 'DNSMASQ_LISTENING'='all' \
    -p '10053:53/tcp' \
    -p '10053:53/udp' \
    -p '10067:67/udp' \
    -p '10080:80/tcp' \
    -p '10443:443/tcp' \
    'testdasi/pihole-dot-doh:latest'

 

Link to comment
  • 2 weeks later...

nslookup used to reply with my custom hostname, but now always says "pi.hole"

 

C:\ nslookup google.com
Server:  pi.hole  {does not match hostname}
Address:  x.x.x.x {correct dns ip}

Non-authoritative answer:
Name:    google.com
Addresses:  2607:f8b0:4007:810::200e
          142.250.72.142

 

Logs show this as well

Nov 10 17:01:28 dnsmasq[471]: query[A] pi.hole from 127.0.0.1
Nov 10 17:01:28 dnsmasq[471]: Pi-hole hostname pi.hole is 10.0.10.4

 

But hostname in webgui (and everywhere else I look) is "aquahole"

root@aquahole:/# hostname
aquahole

image.png.1b72ee0dea6c13ca825953bed4def4fa.png

Edited by hoodust
more detail
Link to comment

Sorry for the begginers question, but how do you update this? 

In my docker page it says its up to date, but pihole itself keeps showing this:

Pi-hole v5.5 · Update available!
FTL v5.10.2 · Update available!
Web Interface v5.7 · Update available!

 

I was running it as a VM before, and i was updating it with pihole -up, but i switched to a docker, and i am in the unknown :)

Link to comment

Thank you for the suggestion, from the console pihole -up gets "Function not supported in Docker images"

So no luck there.

 

I am on the latest version of the repo, at least that`s what it shows: flippinturt/pihole-dot-doh:latest

Any way to force it to check for updates? or re-download it?

 

edit.

OK.. actually my bad.. i was expecting Docker containers were checking for updates on their own, but i actually used the "check for updates" button.. and it showed there is a newer version.. And now everything is updated..

 

 

Edited by Previous
Link to comment
  • 3 weeks later...
  • 2 weeks later...
On 12/6/2021 at 10:24 AM, ruhrpotter said:

Hi,

 

is there a way to obtain the ipv6 adress of the pihole in order to also set it as default ipv6 dns in the router?

Network information is gone from the GUI as of recently. Also, commands like ip -6 addr do not work in the docker terminal.

 

thanks!

UP!

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.