[Support] C4artZ Templates


Recommended Posts

awesome work :) Thank you.

 

I would like to use kutt. unfortunately I filled the domain field in the template initial with the Protokoll `https://kutt.mydoma.in/`

I already did change it to just `kutt.mydoma.in` but still, if I start the webui (from unraid) the browser try to open `https://https//kutt.mydoma.in`

How can I change this? I couldn't find a entry in the postgresql database. Where is this info stored? 

 

Does anybody do have a valid config for use with the swag container (Nginx config)?

Edited by odiby
Link to comment
6 hours ago, odiby said:

awesome work :) Thank you.

 

I would like to use kutt. unfortunately I filled the domain field in the template initial with the Protokoll `https://kutt.mydoma.in/`

I already did change it to just `kutt.mydoma.in` but still, if I start the webui (from unraid) the browser try to open `https://http//kutt.mydoma.in`

How can I change this? I couldn't find a entry in the postgresql database. Where is this info stored? 

 

Does anybody do have a valid config for use with the swag container (Nginx config)?

 

Edit the Docker and toggle the Basic/Advanced button on the top right.

Change the WebUI to: http://[IP]:[PORT:####]/

Leave IP alone.

Change the #### to the actual port number.

 

Edited by AwesomeAustn
Link to comment

sorry, did forget to mention that I checkt that already too. I guess it is either saved to a db or a config file. I also checked some of the config files from within the container via console

image.png.9bd342cfed2d71c9de0329e07b217734.png

 

I probably would have already tried to remove the container and start over again but if it is stored to a db that would help neither.

 

I also just noticed that if a try to access the container over the "ip:port" than I get instant redirected to "https://http//kutt.mydoma.in"

 

image.png.8bda6bdf8d6f8b104d76750e0026f225.png

Edited by odiby
Link to comment
On 2/20/2021 at 12:13 AM, odiby said:

awesome work :) Thank you.

 

I would like to use kutt. unfortunately I filled the domain field in the template initial with the Protokoll `https://kutt.mydoma.in/`

I already did change it to just `kutt.mydoma.in` but still, if I start the webui (from unraid) the browser try to open `https://https//kutt.mydoma.in`

How can I change this? I couldn't find a entry in the postgresql database. Where is this info stored? 

 

Does anybody do have a valid config for use with the swag container (Nginx config)?

I don't have "https://" in the domain field and I also didn't change the WebUI like AwesomeAustn suggested.

Can you try the following proxy conf with "kutt.yourdomain.com" in the domain field?

When I click on WebUI it redirects me to the specified domain. Here is my swag config (don't forget to use a seperate docker network):

server {
    listen 443 ssl;
    listen [::]:443 ssl;

    server_name kutt.*;

    include /config/nginx/ssl.conf;

    client_max_body_size 0;

    location / {

        include /config/nginx/proxy.conf;
        resolver 127.0.0.11 valid=30s;
        set $upstream_app kutt;
        set $upstream_port 3000;
        set $upstream_proto http;
        proxy_pass $upstream_proto://$upstream_app:$upstream_port;

    }
}

 

Link to comment
12 minutes ago, thorkull said:

Hi,

 

I installed PornVault and Elasticsearch but can't seem to get the automatic search and tagging working. Not sure what I may have done wrong, any suggested actions?

 

Thanks!

I personally haven't tried it. Did you add elasticsearch to your PornVault config like it is described here?

Link to comment
32 minutes ago, thorkull said:

I tried using http://localhost:9200, I've just tried with http://elasticsearch:9200 and even the IP address. No change.

Sadly I can't get it to work aswell. I know too little about elasticsearch to be of any help. You might want to try creating an issue on their Github page.

Link to comment
7 hours ago, BBoYTuRBo said:

Thanks for your work!

 

For farmOS, does the template create the database as well? Or do I need to setup up a separate container containing the DB and link them?

The template does not create a database. You can either create a database in a seperate container or use the internal sqlite database. During the first time setup farmOS will ask you what you prefer.

Link to comment
On 2/22/2021 at 10:00 PM, Keek Uras said:

Porn Vault doesn't seem to work with a lot of mp4 files. Any suggestion on what might be done for that? Every one that won't play in the interface works fine in VLC or any other media player used. Thanks in advance.

 

Could it be this? Can you tell what's the difference between the ones that play and the ones that don't?

  • Thanks 1
Link to comment
1 hour ago, Keek Uras said:

Turns out, that is it. Unfortunately I may have to ditch PV then because a large part of my collection is in this format. Thanks for the help!

That is due to your browser not being able to play them, they'll still be processed though. This may change in the future by transcoding on the fly. Until then, you can just continue to open them in VLC or similar.

Link to comment
15 hours ago, C4ArtZ said:

The template does not create a database. You can either create a database in a seperate container or use the internal sqlite database. During the first time setup farmOS will ask you what you prefer.

 

Ah, thanks! I didn't realize scripts were being blocked when I opened the config page and the database setup options were all garbled. I'll be able to get it up and running now!

Link to comment
22 hours ago, boi12321 said:

That is due to your browser not being able to play them, they'll still be processed though. This may change in the future by transcoding on the fly. Until then, you can just continue to open them in VLC or similar.

I understand that but if the majority don't play in the browser, it renders using this docker a bit moot for me because Plex and Emby will play them in the browser without issue. I was trying this out with hopes I wouldn't have to keep a hidden library in either of those programs. Thanks for the response!

Link to comment

PornVault is no longer working. It was fine a couple of days ago. But refuses to run now. 

 

 

2021-03-02T08:32:07.663Z [vault] [33mwarn[39m: Binaries downloaded. Please restart.
2021-03-02T08:32:29.710Z [vault] [32minfo[39m: Max. memory: 8105 MB
2021-03-02T08:32:29.711Z [vault] [32minfo[39m: Loading "/config/config.json"...
2021-03-02T08:32:29.714Z [vault] [32minfo[39m: Registered plugins: []
2021-03-02T08:32:29.720Z [vault] [32minfo[39m: Check https://github.com/porn-vault/porn-vault for discussion & updates
2021-03-02T08:32:29.710Z [vault] [32minfo[39m: Max. memory: 8105 MB
2021-03-02T08:32:29.711Z [vault] [32minfo[39m: Loading "/config/config.json"...
2021-03-02T08:32:29.714Z [vault] [32minfo[39m: Registered plugins: []
2021-03-02T08:32:29.720Z [vault] [32minfo[39m: Check https://github.com/porn-vault/porn-vault for discussion & updates
2021-03-02T08:32:29.762Z [vault] [32minfo[39m: Server running on port 3000
2021-03-02T08:32:29.762Z [vault] [32minfo[39m: Creating backup in /config/backups/klrr6hc2...
2021-03-02T08:32:29.764Z [vault] [32minfo[39m: Backup done.
2021-03-02T08:32:29.770Z [vault] [31merror[39m: Error pinging Elasticsearch @ http://localhost:9200, please make sure Elasticsearch is running at the given URL: connect ECONNREFUSED 127.0.0.1:9200

Link to comment
2 hours ago, Fpsware said:

PornVault is no longer working. It was fine a couple of days ago. But refuses to run now. 

 

 

2021-03-02T08:32:07.663Z [vault] [33mwarn[39m: Binaries downloaded. Please restart.
2021-03-02T08:32:29.710Z [vault] [32minfo[39m: Max. memory: 8105 MB
2021-03-02T08:32:29.711Z [vault] [32minfo[39m: Loading "/config/config.json"...
2021-03-02T08:32:29.714Z [vault] [32minfo[39m: Registered plugins: []
2021-03-02T08:32:29.720Z [vault] [32minfo[39m: Check https://github.com/porn-vault/porn-vault for discussion & updates
2021-03-02T08:32:29.710Z [vault] [32minfo[39m: Max. memory: 8105 MB
2021-03-02T08:32:29.711Z [vault] [32minfo[39m: Loading "/config/config.json"...
2021-03-02T08:32:29.714Z [vault] [32minfo[39m: Registered plugins: []
2021-03-02T08:32:29.720Z [vault] [32minfo[39m: Check https://github.com/porn-vault/porn-vault for discussion & updates
2021-03-02T08:32:29.762Z [vault] [32minfo[39m: Server running on port 3000
2021-03-02T08:32:29.762Z [vault] [32minfo[39m: Creating backup in /config/backups/klrr6hc2...
2021-03-02T08:32:29.764Z [vault] [32minfo[39m: Backup done.
2021-03-02T08:32:29.770Z [vault] [31merror[39m: Error pinging Elasticsearch @ http://localhost:9200, please make sure Elasticsearch is running at the given URL: connect ECONNREFUSED 127.0.0.1:9200

I get the same error

Link to comment

Looks like some code changes for version 0.26.0 broke the Elasticsearch integration somehow. At least in all cases I tested.

 

To get this running again, do the following:

  1. Edit the Docker container
  2. Change the repository from leadwolf/porn-vault to leadwolf/porn-vault:0.25.0 or leadwolf/porn-vault:0.25.0-alpine
    1. The Alpine build is smaller than the default Debian build and is what I use.
  3. Apply and restart the container

If you run into issues, check the logs. It may be complaining about the config.json. If that's the case, go into your /mnt/user/appdata/PornVault directory and delete the config.json and config.merged.json files. Restart the container, and it will regenerate the config without losing your data.

 

Edit: I fixed the issue with 0.26.0.

 

Hindsight: I believe allowing the macvlan connections may fix this as well. Stop the Docker service, check the Host access to custom networks, and restart the Docker service. I didn't test this because I have this working with the custom br0 network that I typically use for anything that needs its own IP anyway. This option is needed if you have a reverse proxy running on the bridge network that you want to use to serve PornVault.

 

I put both Elasticsearch and PornVault on a custom br0 network and gave each container a static IP on my normal subnet. For example, 192.168.69.68 and 192.168.69.69 respectively. I edited the config to point to this new IP for the Elasticsearch container, and the issue is resolved. You can remove the tag from the repository and it should start up correctly. You may need to remove and regenerate the config.json. The necessary entry in the JSON is:

 

  "search": {
    "host": "http://192.168.69.68:9200",
    "log": false,
    "version": "7.x",
    "auth": null
  }

 

Edited by DenizenEvil
  • Like 1
  • Thanks 1
Link to comment

Release 0.26 seems to break the Elasticsearch integration. When the template was created, Elasticsearch was optional. I have updated the template to only target /porn-vault:porn-vault:0.25.0-alpine. (Thank you @DenizenEvil!) You should be able to get the new template in about 2 hours from now. I would recommend removing the old container + image from your server before downloading the new one. All your data should be in the persistent share you specified. I will try release 0.26 again in a week or two.

Link to comment

I added the top line to my config file per the instructions, but I keep getting this error

 

2021-03-05T16:20:10.068Z vault:message Loading "/config/config.json"...
2021-03-05T16:20:10.071Z vault:error ERROR when loading config, please fix it. Run your file through a linter before trying again (search for 'JSON/YAML linter' online).
2021-03-05T16:20:10.071Z vault:error Unexpected string in JSON at position 101

 

I edited the json file using notepad++ on my windows vm and then copied it back to the config dir in appdata

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.