Problems with USB


4 posts in this topic Last Reply

Recommended Posts

I'm having some issues with my unRAID server, and it seems to be related to USB devices.  Other than the flash drive containing unRAID, I've got a ConBee II ZigBee interface, an Aeotec Z-Stick Gen5 Z-Wave interface and an RFXCOM RFXtrx433XL 433MHz interface connected to USB ports.  I've had some issues with both unRAID freezes (lose all communication with both unRAID web GUI and containers), and with the home automation interfaces falling out.  Last in line was the ZigBee interface.

 

I see in my unRAID system log that there are some error messages related to the ZigBee interface.  Can anybody tell me what the problem here is?  Is it likely that I have a faulty USB controller?  It's the onboard controller that I'm using, but the mainboard is fairly old (approx. 10 years) so it wouldn't surprise me if this causes problems...

 

 

2021-02-22 12_38_18-System Log.png

Link to post

Its does look like its hardware related as its getting a timeout. Have you disconnected the stick for a bit and then reconnected or tried a different port?

35 minutes ago, ohj said:

ZigBee interface

 

#define ETIMEDOUT 110 /* Connection timed out */

Edited by SimonF
Link to post
10 hours ago, SimonF said:

Have you disconnected the stick for a bit and then reconnected or tried a different port?

No, I haven't.  The sticks have been plugged in the entire time.  The ZigBee interface is connected to the server through a USB extension cable though.  A fairly low quality one, which wouldn't surprise me if causes voltage drop over the thin cable.  I've already ordered a better USB3 extension cable, so I'll see if this improves the behavior.

 

The error code you found, is that a Linux specific error code?  The 71 code should be EPROTO (Protocol Error) then, I guess.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.