Help! Unraid issue format/rebuild/etc.

Recommended Posts


I was one of the unlucky Texans impacted by the recent storms...cycling electricity (mostly off for 4 days) and then frozen busted pipes with flooding.  That said, my unraid server stayed dry.  I am running unRAID Server Pro v5.0.2 .  I received a red ball on of my drives but when I ran smartdisk it looked okay.  I ultimately just removed it from array and then reinserted it at which point a full rebuild occurred and was successful.  I could access everything.  The next day, I received a red ball on a different disk.  Note that I had intermittent slowness in my webGUI.  I ran smartdisk everything looked fine so I did the same thing.  At some point in the rebuild of that disk, things went wrong.  Where I sit now is that I have a started array with the "failed" disk in orange(?) status  but the problem is that it says Data-ReBuild in process (with a cancel button) as well as an unformatted disk present.  Nothing is moving on the Data ReBuild front from what I can see.  Ohhh, I forgot to mention that I think my actual problem is one of the NIC ports is bad.  I discovered a bunch of dropped packets so I just unplugged from that ethernet port on the server and everything is operating fine outside of the aforementioned issue.  I think the network issue was what was creating my problem (or perhaps lack of disk problem) in the beginning.  


So, what should I do now?  Again when I look on my other computers the failed disk is missing so it seems like something is messed up with the array.  I am hoping it's a config issue and the data is still there in parity somewhere vs. just missing.


Huge thank you in advance!



Scott Albright

Link to comment
14 minutes ago, Scott A said:

unRAID Server Pro v5.0.2

2 minutes ago, Squid said:

Post your diagnostics - Tools / Diagnostics

  Not possible on that version.


Unfortunately you are using a very old version of Unraid so it is going to take some work on your part to get us more information, and none of the people who usually help on the forum are running that very old version. Unraid V6 would give us a lot of info with a simple click to download a zip file to post. You should upgrade.


Get us the syslog and SMART for each disk, and tell us which disks specifically are having problems, assigned slot and last 4 characters of serial.


I don't know if you have unMenu installed or not and I don't even remember what other info you might be able to get from that.



Link to comment

Thank you.  Here is the syslog.  


I also ran the smartctl command on each disk and they all passed.  I did have one error on one of the disks even though it passed but it's not my orange/problem drive. I have included the error portion below but think it is something with the configuration vs. the disk but again I'm no expert.  Thanks again!



It said AT error Count: 1 


ATA Error Count: 1
        CR = Command Register [HEX]
        FR = Features Register [HEX]
        SC = Sector Count Register [HEX]
        SN = Sector Number Register [HEX]
        CL = Cylinder Low Register [HEX]
        CH = Cylinder High Register [HEX]
        DH = Device/Head Register [HEX]
        DC = Device Command Register [HEX]
        ER = Error register [HEX]
        ST = Status register [HEX]
Powered_Up_Time is measured from power on, and printed as
DDd+hh:mm:SS.sss where DD=days, hh=hours, mm=minutes,
SS=sec, and sss=millisec. It "wraps" after 49.710 days.

Error 1 occurred at disk power-on lifetime: 58461 hours (2435 days + 21 hours)
  When the command that caused the error occurred, the device was active or idle.

  After command completion occurred, registers were:
  -- -- -- -- -- -- --
  84 51 01 c7 00 00 00  Error: ICRC, ABRT at LBA = 0x000000c7 = 199

  Commands leading to the command that caused the error were:
  CR FR SC SN CL CH DH DC   Powered_Up_Time  Command/Feature_Name
  -- -- -- -- -- -- -- --  ----------------  --------------------
  ca 00 08 c0 00 00 e0 00      00:01:04.641  WRITE DMA
  c8 00 08 08 8a 00 e0 00      00:01:04.641  READ DMA
  c8 00 08 10 8a 00 e0 00      00:01:04.641  READ DMA
  c8 00 08 00 8a 00 e0 00      00:01:04.637  READ DMA
  c8 00 08 d0 00 01 e0 00      00:01:04.627  READ DMA

SMART Self-test log structure revision number 1
Num  Test_Description    Status                  Remaining  LifeTime(hours)  LBA_of_first_error
# 1  Short offline       Completed without error       00%      9660         -

SMART Selective self-test log data structure revision number 1
    1        0        0  Not_testing
    2        0        0  Not_testing
    3        0        0  Not_testing
    4        0        0  Not_testing
    5        0        0  Not_testing
Selective self-test flags (0x0):
  After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.



unRAID Scott A.txt

Edited by Scott A
Link to comment


Thank you for the suggestion.  I will need to locate the cable and figure out exactly what to purchase/replace.  Can you let me know how you arrived at that conclusion so tht I can learn?  Also, when you say disk5, do you mean the disk listed in the webGUI disk 5 slot?


Link to comment

I still don't understand though why even if one disk is unformatted/unmounted why I can't access its contents on the array as it should be there from the parity disk.  The disk is absent when looking from another PC through windows explorer.  Furthermore, it is trying to rebuild the disk even though it lists it as unformatted.  I let it complete one time which took hours and then nothing was there once complete.  I don't want to format though yet as am concerned I lose all the data.  Again, I appreciate the guidance!

Link to comment

The disk is disabled and so it is emulated by parity. Unfortunately, the emulated disk (and probably the physical disk) is also unmountable (corrupt filesystem). Parity is able to emulate the disk but it is unmountable so no files can be accessed. The filesystem must be repaired, either before or after rebuilding it.


The safest approach would be to rebuild to another disk and keep the original disk untouched in case there is a problem with the rebuild. Possibly the original disk is actually mountable but the emulated disk isn't.


Understanding your complete situation would be so much simpler if you were on V6, and there would be ways to work with a replacement and the original disk both.


You need to get us the SMART report for at least the problem disk. It would be even better if you could get us the SMART report for all of your disks. All of that and much more would be a simple click to download a single zip on V6.



Looks like they have been reworking the wiki and I don't know if there is any way to get any documentation for V5 anymore. That link I gave earlier has links to the wiki but they don't help now.


What plugins do you have installed? If you have unMenu maybe you can get something from that. Basically we need the output of

smartctl -a /dev/sdX

where X is replaced with the sd drive letter of each of your disks.

Link to comment

Thanks.  No plug-ins.  I do and ran smartdisk at the command line.  I went ahead and removed bad disk and replaced it with a new one.  Did a rebuild (of course after formatting) and the disk shows but any information that was there isn't anymore so it looks like the parity disk lost its information during the original issue.  I can run smartdisk and post each one but not sure that matters now but let me know.  Again, all disks are functioning and accessible.  It's just that the Disk 4 information is no longer there.


Link to comment
1 minute ago, Scott A said:

Did a rebuild (of course after formatting) and the disk shows but any information that was there isn't anymore so it looks like the parity disk lost its information during the original issue.

The parity disk was updated when you formatted the disk so it agreed the disk was empty.


I guess I should have SHOUTED this earlier:

12 hours ago, trurl said:

If you format you will lose all that data. You need to repair the filesystem.


Link to comment

If you are comfortable with the linux command line, or even have another linux server, you could try to work with that original disk to see if it has your files, or if it can be repaired to recover some of your files. But it would require some research to figure out what to do.


Or you can see about upgrading your server to Unraid V6.

Link to comment

I'm halfway comfortable.  My next step is that I ordered a usb to SATA connector and will plug in old drive and use RSTool to see if I see anything on the old disk.  If not then it's toast.  If so, I'll see next steps.  Only other thing would be if the parity disk still has something which seems doubtful and not sure how I would see that.  It's almost like the parity for the failed disk got erased as well...


I'll also look at upgrading but that looks to be a bigger task for me.


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.