Cannot access internet from new interface

Recommended Posts

Hi. I feel like I asked this years ago but can find no evidence.


When I first set up unraid it was on a single ethernet lead into Nic 1. That worked fine.


Today I tried setting up a bond on 4 other nics. And whilst it connects internally just fine, it cannot access the internet, none of my dockers work etc.


I tried deleting the config files for network from the USB and start again, but this clearly does not delete all networking stuff because unraid complained that Nic1 was down and to plug in a cable.


I know I had this problem before, but for the life of me I cannot recall how I fixed it.


In short I dont want to use Nic1, I want to use the bond I created.


Can someone give me a pointer?

Link to comment
58 minutes ago, garethsnaim said:

Additional info on Nic one, the settings for it allow me to enter DNS. But the bond settings do not offer this. Evidently I need to make the Bond the main one, but unraid seems pretty wed to me using only Nic 1.

unRAID will always use eth0 (I assume that is your NIC 1).  If you want another interface assigned to eth0, change it in Network Settings by assigning desired MAC address to eth0.




And of course you have to stop Docker and VM Manager to make changes to interfaces such as DNS, IP addresses, etc.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.