Could it be that unraid disabled monitor output?

Recommended Posts

Related to this question: 



I have iGPU and external GPU, while booting monitor shows output. But then it disapears. 

I want to use iGPU for unraid (output to monitor (or in this case tinypilot)) and eGPU for plex docker.


Using latest RC.

Nvidia Plugin.


Everything else is working. Just want to get an output over VGA


edit: im currently on latest stable 6.9 (not RC1 till now)

Edited by nuhll
Link to comment
Posted (edited)

ive even changed boot to gui boot, still no luck,


no monitor output after boot complete (i see unraid starting, i see menu for GUI and so on)


Any help?????


Bios enabled everything regrading to gpu


I want to put a kvm at it so i can control it outside the "server room". But without display....?

Edited by nuhll
Link to comment

The behaviour sounds like a situation where the GPUs have been reserved. In this scenario, the boot sequence shows up to a point, but appears to stall.


Have you a clean unraid install, or have you ever set any VFIO reservations for passthrough? (if you have, and the n shifted or added devices, the assignments can change and th wrong devices can become reserved).



Edited by meep
Link to comment

So do you get as far as a login prompt?


What is igpu? Have you tried loading driver for igpu? 


My supermicro machine blanks monitor afterwhile and need to press keyboard to wake screen but after a while once at login prompt.

Link to comment
Posted (edited)

igpu drivers are now included but i also tried to load it via modprobe, doesnt changed anything


I did not see login promt, but i saw the things before (after bios, but before login)


Its intel onboard


isnt there some fancy linux command to check if its atleast tryin to output something?

Edited by nuhll
Link to comment
Posted (edited)

latest 6.9. RC1


crazy kernel panic...? maybe related to vga? im not sure

Mar 10 22:02:05 Unraid-Server kernel: Console: switching to colour dummy device 80x25

Mar 10 22:02:06 Unraid-Server kernel: vfio-pci 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=none,decodes=io+mem:owns=io+mem


besides the kernel panic everything seems to work (?)

Edited by nuhll
Link to comment

One of my machines has iGPU and Nvidia Card.


There was an issue getting a blank screen with GUI if ich777 intel_gpu_top was installed, which he has now fixed.


I have the done the following:


touch /boot/config/modprobe.d/i915.

install intel_gpu_top


Server boots into either text or gui console. Before the fix gui was just showing black screen with solid cursor in the top left.



Link to comment
Posted (edited)

I dont thionk this has anything to do with my problem. Because it just shows "no ouput" not a blank screen.


But i did it anyway:

root@Unraid-Server:~# touch /boot/config/modprobe.d/i915.
root@Unraid-Server:~# install intel_gpu_top
install: missing destination file operand after 'intel_gpu_top'
Try 'install --help' for more information.


Do i need to somehow tell unraid to use the iGPU instead of the normal GPU?

Edited by nuhll
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.