My Servers Early Access Plugin


459 posts in this topic Last Reply

Recommended Posts

Hi,

 

When I click my username in the Dashboard, it says "My Servers Error, Graphql is offline".

 

How can this be resolved?   Also, the Settings page shows I have remote access setup but I cannot access the server remotely. When I visit My Servers, it states "Access unavailable".

 

Any ideas?

 

Neil

Link to post
  • Replies 458
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hello Unraid Community!   Today we're excited to give you a sneak peak at something we've been working on for quite some time.  A new feature we like to call My Servers.   "My Serv

Would you mind running `unraid-api restart` in a terminal and let me know if that sorts it. I’ve added this to our bug tracker. 

Now available in CA  

Posted Images

49 minutes ago, rctneil said:

Hi,

 

When I click my username in the Dashboard, it says "My Servers Error, Graphql is offline".

 

How can this be resolved?   Also, the Settings page shows I have remote access setup but I cannot access the server remotely. When I visit My Servers, it states "Access unavailable".

 

Any ideas?

 

Neil

 

Please open a terminal window and type this:

unraid-api restart

 

When the API restarts it will hopefully make a connection and then from the My Servers Dashboard you should have options for "Local access" or "Remote access" instead of "Access unavailable"

 

Link to post
2 minutes ago, ljm42 said:

 

Please open a terminal window and type this:


unraid-api restart

 

When the API restarts it will hopefully make a connection and then from the My Servers Dashboard you should have options for "Local access" or "Remote access" instead of "Access unavailable"

 

 

Hi,

 

That results in: 

bash: unraid-api: command not found

 

Link to post
11 minutes ago, rctneil said:

 

Hi,

 

That results in: 


bash: unraid-api: command not found

 

 

Odd, the My Servers plugin did not fully install. Would you mind rebooting?

 

Link to post
48 minutes ago, ljm42 said:

 

Odd, the My Servers plugin did not fully install. Would you mind rebooting?

 

 

I tried rebooting but that didn't work. I removed and reinstalled the plugin and all looks great now!

Link to post
1 minute ago, rctneil said:

 

I tried rebooting but that didn't work. I removed and reinstalled the plugin and all looks great now!

 

Thanks, we'll keep an eye out for similar problems. This should not happen :) 

Link to post
Just now, ljm42 said:

 

Thanks, we'll keep an eye out for similar problems. This should not happen :) 

Fantastic.

 

I'm assuming that now remote access is enabled I can access my shares on my machine or any other machine?  How would I mount a share remotely though?

Link to post
1 minute ago, rctneil said:

Fantastic.

 

I'm assuming that now remote access is enabled I can access my shares on my machine or any other machine?  How would I mount a share remotely though?

 

Remote Access gives you access to the Unraid webgui. You can download individual files using the built-in file browser, but to mount shares you would want to use WireGuard VPN:

 

Link to post

Hello,

I just wanted to configure the unraid.net plugin.

But I realized, that I have to allow the remote access first (e.g. via https 10443).

So I went into "management access" in the settings tab.

Then I tried to change some of the values

e.g. "Use SSL/TLS", "HTTP port", "HTTPS port", "Local TLD" but nothing changed after clicking on "apply". Nothing happens until I refreshed the hole browser-tab. Now any changes have been discard.

Can you please support me?

Best regards

Johannes

Link to post
4 minutes ago, Johannes1234934 said:

I just wanted to configure the unraid.net plugin.

But I realized, that I have to allow the remote access first (e.g. via https 10443).

 

Please keep in mind that Remote Access is just one of the features of My Servers. It is not a requirement at all.

 

If you choose to enable Remote Access, then local SSL access is a requirement. This has been a feature of Unraid for many years and is possible with or without My Servers.

 

6 minutes ago, Johannes1234934 said:

So I went into "management access" in the settings tab.

Then I tried to change some of the values

e.g. "Use SSL/TLS", "HTTP port", "HTTPS port", "Local TLD" but nothing changed after clicking on "apply". Nothing happens until I refreshed the hole browser-tab. Now any changes have been discard.

 

Please provide a screenshot of the Management Access page after it reloads (so I can see what the default settings are).  Also, what url are you currently using to access the webgui?  Also, if you have multiple tabs open to the server please close all but one.

 

Link to post

 

7 minutes ago, Johannes1234934 said:

Thx for the reply.
Here the screenshot

 

Neat to see Unraid in a language other than English :) 

 

OK so you have provisioned a certificate, good

 

The internal https port is 443, that is good unless you already have a docker running on that port?

 

Do you have any other tabs open to the server? If so please close them all.

 

Then change "use SSL/TLS" to "auto" and press Apply. You should be redirected to a new url that looks like https://yourpersonalhash.unraid.net

 

If it still fails, please clear your cache and try again. Or try in an incognito window.

 

(sorry, I will be away from my computer for a few hours)

Link to post

I checked the tabs, only one open.
Furthermore I tried another browser and deleting the cache and the incognito tab, without any improvement.
I have a reverse proxy on port 443, but I can't change the unraid management-port to e.g. 10443, because I can't save the changes
 

24 minutes ago, ljm42 said:

(sorry, I will be away from my computer for a few hours)

no problem, I have time

 

Edited by Johannes1234934
Link to post
2 hours ago, Johannes1234934 said:

I have a reverse proxy on port 443, but I can't change the unraid management-port to e.g. 10443, because I can't save the changes

Are you currently accessing Unraid through this reverse proxy? If so use http://<computername> or http://<ip address> to make this change

 

Can you change the https port if that is the only setting you change? I.e. on the Settings -> Management Access page, try changing https port from 443 to 10443 and pressing Apply. Does that much work?

Link to post
8 hours ago, badnewsblair said:

I hate to continue this since it is not relevant to My Servers, but is there a method (perhaps terminal) to disable/disable SSL without the webgui since mine is inaccessible now?

 

I'm not sure why it is inaccessible, but you may be able to access the webgui via https://<ip address> if you ignore the browser warnings.

 

To manually revert:

* On your flash drive, remove any files from the config/ssl/certs folder

* Edit the config/ident.cfg file on the flash drive and ensure you see a line that says USE_SSL="auto" or "no"  (if it says "yes", change it to "auto" or "no")  (FYI - because you deleted the certs, "auto" is basically the same as "no")

* Reboot (you mentioned being able to use the terminal, you can type "reboot" from there)

Link to post
17 hours ago, Amigaz said:

Have ran into an issue. Installed this plugin yesterday to just use it locally. 

Now this morning I cannot access the web interface .. just get a "404", I don't know what has happened.

Is there a way to "remove" this plugin now so I get back access to my server again? thanks

 

The API seem to have contact and all my apps work perfectly

 

image.png.6f9998f1120e37f442f71c204e489eb0.png

 

Sorry, I was just reviewing this thread and realized nobody responded to you

 

A 404 is an interesting message, that means the server responded but said nothing is there. That is odd.

 

What happens if you click the "local access" link above? What url does it take you to, and what is the response?

 

Do you have the ability to SSH into the server? If so, please type "diagnostics" and then grab the zip file off your flash drive and upload it here.

Link to post
6 hours ago, ljm42 said:

Are you currently accessing Unraid through this reverse proxy? If so use http://<computername> or http://<ip address> to make this change

I use the internal IP-Adresss to make the changes. (but I also tried from remote, without any success)
 

 

6 hours ago, ljm42 said:

Can you change the https port if that is the only setting you change? I.e. on the Settings -> Management Access page, try changing https port from 443 to 10443 and pressing Apply. Does that much work?

I tried this, without success.

I also tried to change the ident.cfg in /boot/config/ without success.

Link to post

Took me all of 10mins to set up including looking here

 

root@Server:~# unraid-api restart
Sending process 23909 SIGKILL.
Starting unraid-api in "production" mode.
Daemonizing process.
Daemonized successfully!
root@Server:~# 

 

Everything seems to be up and running, might see if I can set up a subdomain on mydomain.com if I get some time later.

 

Thanks team 😄

Link to post

@limetech thanks so much for addressing some of the potential security concerns. I think that despite this, there still needs to be a BIG RED WARNING that port forwarding will expose your unRAID GUI to the general internet and also a BIG RED WARNING about the recommended complexity of your root password in this case. One way to facilitate this might be that you must enter your root password to turn on the remote webUI feature and/or have a password complexity meter and/or requirement met to do so.

 

The fact that most people will think that they can access their server from their forum account might make them assume that this is the only way to access their webUI, rather than directly via their external IP.

 

Having 2FA on the WebUI would be SUPER nice also 🙂

 

22 hours ago, limetech said:

Let's suppose we have these additional mitigations in place. If your server reboots for some reason while you are away (perhaps power failure/restore), here's what you would do to get things going again:

  1. login to forum: specify username, password, enter 2FA code from your phone.
  2. click server remote access link: specify password, enter different 2FA code from your phone (once implemented)
  3. enter encryption password, click Start to bring up array
  4. enter flash backup encryption password, re-enable automatic flash backup (once implemented)
  5. start any services which are not set to autostart

To me this seems fairly onerous but in the interest of maximum security, is probably what has to be done.

 

Yes, this is a little onerous, but probably what is required to keep a large volume of "my server has been hacked" posts happening around here...

 

Link to post

I have another problem right now:

When I go to my profile I got the following error:
actual server - not connected to mothership??

What does that mean?
I also get an error, that the Flash backup file doesn't work, why?
In the settings/managing access menu I see that the backup is active?

Best regards
johannes

grafik.png

grafik.png

grafik.png

Link to post
6 minutes ago, Johannes1234934 said:

actual server - not connected to mothership??

 

Please open a terminal window and type:

unraid-api restart

 

 

7 minutes ago, Johannes1234934 said:

I also get an error, that the Flash backup file doesn't work, why?
In the settings/managing access menu I see that the backup is active?

 

From the terminal window type:

cp /var/log/gitflash /boot

 

Then grab the gitflash file off your flash drive and send it to me in a PM

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.