Sonarr/Radarr won't connect to Jackett/Deluge when using a VPN


4 posts in this topic Last Reply

Recommended Posts

I've been using Binhex DelugeVPN with Sonarr, Radarr, Lidarr and Jackett all routing their internet through the Deluge docker for a couple months. A couple weeks ago, it stopped working. Sonarr, Radarr and Lidarr are no longer connecting to Jackett or Deluge. I don't remember changing any settings or if there was an update recently, I just noticed one day that nothing was being added to Deluge. I tried a slightly different route by using an openvpn docker and routing everything through that instead, but still nothing. If I disable the vpn and set each docker network type to 'Bridge' everything seems to connect as they should. For obvious reasons, I don't want to do it this way. Could anyone help me out on what could be going on?

I currently have openvpn setup with a nordvpn account. I can check my public IP as well as ping google, so I would assume it has proper internet connection. Each docker container that is using openvpn is connected by setting the network type to 'None' with the argument --net=container:openvpn. Those also have the same public IP as well as internet access. But for some reason something seems to be blocking the connection to each other docker container. I don't even know if this is an issue with the docker containers or if I need to do something different on my network

I hope I did a good enough job explaining what my issue is, any help is appreciated.

Link to post

Check the forum, binhex had to make a change to the deluge container  and you need to change your sonar/radar to local host. details are in the comments near the end  

 

 

 

Link to post
19 hours ago, Ericjr said:

Check the forum, binhex had to make a change to the deluge container  and you need to change your sonar/radar to local host. details are in the comments near the end  

 

 

 

That wasn't related to the issue I had. I was actually planning on switching over to running everything through a dedicated vpn docker instead of using the deluge vpn. The issue I was having was specifically related to sonarr and radarr being unable to connect the indexers to jackett. However, I just solved it by changing the url I get from jackett torznab to be 'localhost' instead of using my actual IP address. Thanks for your help though. I think it did, in some way, point me in the right direction.

Link to post
  • 4 weeks later...

To save some people digging through forum comments, this comment was the solution for me.


 

Quote

 

I had to add my Unraid server's IP in both Sonarr and Radarr under Settings > General > Proxy > "Addresses for the proxy to ignore

 

This is described in Q26 in the documentation here: https://github.com/binhex/documentation/blob/master/docker/faq/vpn.md

 

 

Hopefully this helps!

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.