[Support] Akaunting


Recommended Posts

Creating this Topic/Channel to Support Akaunting Docker Container.

 

AkauntingTM is a free, open source and online accounting software designed for small businesses and freelancers. It is built with modern technologies such as Laravel, VueJS, Bootstrap 4, RESTful API etc. Thanks to its modular structure, Akaunting provides an awesome App Store for users and developers.

 

Home - The house of Akaunting

Forum - Ask for support

Documentation - Learn how to use and develop

App Store - Extend your Akaunting

 

Akaunting uses Laravel, the best existing PHP framework, as the foundation framework and Module package for Apps.

 

 

Quote

Credits

 

Denis Duliçi

Cüneyt Şentürk

All Contributors

 

Edited by Yoda
Changed initial Topic details
Link to comment

Hi,

 

¿Anyone knows a working subdomain.conf for this app using the swag docker?

 

I have 8 more reverse proxies so I think something is weird with this app.

So far I've used this and isn't working

 

server {
    listen 443 ssl;
    listen [::]:443 ssl;

    server_name conta.*;

    include /config/nginx/ssl.conf;

    client_max_body_size 0;

    location / {

        include /config/nginx/proxy.conf;
        resolver 127.0.0.11 valid=30s;
        set $upstream_app akaunting;
        set $upstream_port 8083;
        set $upstream_proto http;
        proxy_pass $upstream_proto://$upstream_app:$upstream_port;

    }
}

 

Im using port 8083 and conta.* with Cloudflare (with proxy option), just as any other app I have. Also the docker is named "akaunting". I've also tried https instead of http.

 

Both swag and akaunting are working.

Link to comment

@Siroguh I have this working as Reverse Proxy using NginX proxy Manager. I did not try with Swag. I recently updated my Swag settings with NginX proxy manager (Easy to manager IMO). Below is my config file of NPM. mine is hosted on 8087. 

 

# ------------------------------------------------------------
# accounts.ABC.com
# ------------------------------------------------------------


server {
  set $forward_scheme http;
  set $server         "<IP>";
  set $port           8087;

  listen 8080;
listen [::]:8080;

listen 4443 ssl http2;
listen [::]:4443;


  server_name accounts.ABC.com;


  # Let's Encrypt SSL
  include conf.d/include/letsencrypt-acme-challenge.conf;
  include conf.d/include/ssl-ciphers.conf;
  ssl_certificate /etc/letsencrypt/live/npm-11/fullchain.pem;
  ssl_certificate_key /etc/letsencrypt/live/npm-11/privkey.pem;








  # HSTS (ngx_http_headers_module is required) (31536000 seconds = 1 year)
  add_header Strict-Transport-Security "max-age=31536000; preload" always;




  access_log /config/log/proxy_host-8.log proxy;







  location / {

    


    # Force SSL
    include conf.d/include/force-ssl.conf;




  # HSTS (ngx_http_headers_module is required) (31536000 seconds = 1 year)
  add_header Strict-Transport-Security "max-age=31536000; preload" always;




    

    # Proxy!
    include conf.d/include/proxy.conf;
  }


  # Custom
  include /data/nginx/custom/server_proxy[.]conf;
}

 

  • Like 1
Link to comment

Sorry, I am a beginner 

I downlead mysql (by bBungy's Repository )

Container Port 3307 (I use mariaDB, nextcloud by spaceinvaderone:x)

Host Path 1:/mnt/user/appdata/mysql

Container Variable: MYSQL_ROOT_PASSWORD: myrootpass

Container Variable: MYSQL_DATABASE: mydatabase

Container Variable: MYSQL_USER: me

Container Variable: MYSQL_PASSWORD: mypass

--------------------------------------------------------------------------------

akaunting

Web portal: 8087 

Setup Account: true

MySql Database IP:Port: 192.168.0.140:3307

Database Name: mydatabase

Database Username: me

Database Password: mypass

-------------------------------------------------------------------------------

I keep getting this message in the log can you please help me

 

Setting locale US_EN
Creating database tables
Connecting to database mydatabase@192.168.0.140:3307:3306
Error: Could not connect to the database! Please, make sure the details are correct.

 

Link to comment
  • 3 weeks later...

I solve it  with this

 

php artisan install --db-host="localhost"  --db-port="3306"  --db-name="akaunting"  --db-username="root"  --db-password=""  --db-prefix="ak3"  --company-name="My Company"  --company-email="myemailcompany@gmail" --admin-email="myemail@gmail.com"  --admin-password="mypass"  --locale="es-ES"

 

Parameters description
                           
    (--db-host=localhost : Database host}
    {--db-port=3306 : Port of the database host}
    {--db-name= : Name of the database}
    {--db-username=root : Username to use to access the database}
    {--db-password= : Password to use to access the database}
    {--db-prefix= : Table name prefix}
    {--company-name=My Company : Name of the company}
    {--company-email=my@company.com : Email of the company}
    {--admin-email= : Admin user email}
    {--admin-password= : Admin user password}
    {--locale=en-GB : Language used in the app}

Link to comment
  • 2 months later...
On 4/16/2021 at 7:41 AM, TatiCastell said:

I solve it  with this

 


php artisan install --db-host="localhost"  --db-port="3306"  --db-name="akaunting"  --db-username="root"  --db-password=""  --db-prefix="ak3"  --company-name="My Company"  --company-email="myemailcompany@gmail" --admin-email="myemail@gmail.com"  --admin-password="mypass"  --locale="es-ES"

 

Parameters description
                           
    (--db-host=localhost : Database host}
    {--db-port=3306 : Port of the database host}
    {--db-name= : Name of the database}
    {--db-username=root : Username to use to access the database}
    {--db-password= : Password to use to access the database}
    {--db-prefix= : Table name prefix}
    {--company-name=My Company : Name of the company}
    {--company-email=my@company.com : Email of the company}
    {--admin-email= : Admin user email}
    {--admin-password= : Admin user password}
    {--locale=en-GB : Language used in the app}

Could you provide more specific steps to getting this to work?

Link to comment

I've deleted and reinstalled akaunting and mariadb from scratch again. It will not open the page to do the setup.

 

I still get this message in the akaunting docker log:

Enabling module rewrite.
To activate the new configuration, you need to run:
service apache2 restart


The "--db-prefix" option does not exist.




The "--db-prefix" option does not exist.




The "--db-prefix" option does not exist.




The "--db-prefix" option does not exist.




The "--db-prefix" option does not exist.




The "--db-prefix" option does not exist.

 

 

 

And this in the Unraid server log:

Jul 15 11:11:22 Atlas nginx: 2021/07/15 11:11:22 [error] 6295#6295: *1282615 connect() to unix:/var/tmp/akaunting.sock failed (111: Connection refused) while connecting to upstream, client: MYCOMPUTERIP, server: , request: "GET /dockerterminal/akaunting/token HTTP/1.1", upstream: "http://unix:/var/tmp/akaunting.sock:/token", host: "SERVERIP", referrer: "http://SERVERIP/dockerterminal/akaunting/"

 

 

If I change Setup Account to False, all the errors go away in the logs and the akaunting web just shows "Whoops, looks like something went wrong."

Link to comment
  • 3 months later...

Installed and running, however my square plugin is deleted nightly and i have to reinstall it daily. Anyway to stop this minor inconvienece?

 

 

Also, for anyone looking to use reverse proxy, use this subdomain template.

Quote

 

server {
    listen 443 ssl http2;
    listen [::]:443 ssl http2;

    server_name akaunting.*;

    include /config/nginx/ssl.conf;

    client_max_body_size 0;

    location / {

        include /config/nginx/proxy.conf;
        resolver 127.0.0.11 valid=30s;
        set $upstream_app akaunting;
        set $upstream_port 80;
        set $upstream_proto http;
        proxy_pass $upstream_proto://$upstream_app:$upstream_port;

    }

}

 

 

Link to comment
  • 3 months later...

Can someone please help out a noob :)

 

I was using asus router before with a port forwarded to nginx and akaunting worked fine behind the nginx proxy manager. I recently have switched to pfsense, HAproxy, and ACME.

 

I got all my dockers to work except for akaunting. Would someone please help me with this on how to get this to work with HAproxy? I also posted my issue in more details here. HAProxy issue.

 

Thanks for your help.

Link to comment
  • 3 weeks later...

Can someone kindly help me with this? Even time I restart the docker container for akaunting, it creates a new admin use with the email set in the docker settings. Now I have 79 users when I go into my Admin users view. 

 

image.thumb.png.8029d9e0188f6b964f769344e9473888.png

 

If I set the following settings to false, it does not connect to the db I think anymore.

 

image.png.62bebe81580c6031da080d9949419449.png

Edited by war1000
Link to comment
  • 4 weeks later...

Hi I have a quick question!

I need to edit some of the source php files but can't since everything is in the docker image. Does someone know the file path inside the container so I can map everything to unraid's appdata folder?

 

Thanks for the help!

Link to comment
53 minutes ago, trurl said:

Have you tried going to command line inside container?

No I did not, as I am unsure how I can find the information I need in there... I just need the app files to be in appdata instead of the docker image for akaunting, anyone has done that before? Is it even possible using this container?

Link to comment
  • 3 weeks later...
On 3/13/2022 at 4:11 PM, war1000 said:

Can someone kindly help me with this? Even time I restart the docker container for akaunting, it creates a new admin use with the email set in the docker settings. Now I have 79 users when I go into my Admin users view. 

 

image.thumb.png.8029d9e0188f6b964f769344e9473888.png

 

If I set the following settings to false, it does not connect to the db I think anymore.

 

image.png.62bebe81580c6031da080d9949419449.png

 I have exactly the same problem, if setup is set to true, multiple users are created using the user details in the config, if setup is set to false, it does not connect to database. Any ideas?

 

Link to comment

This is what is in the log - it looks like the user does not exist:

192.168.0.22 - - [23/Apr/2022:15:48:26 +0100] "GET /auth/login HTTP/1.1" 200 3725 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/100.0.4896.127 Safari/537.36"
[2022-04-23 14:48:34] production.ERROR: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'akaunting.ak_users' doesn't exist (SQL: select * from `ak_users` where `email` = ************ and `ak_users`.`deleted_at` is null limit 1) {"exception":"[object] (Illuminate\\Database\\QueryException(code: 42S02): SQLSTATE[42S02]: Base table or view not found: 1146 Table 'akaunting.ak_users' doesn't exist (SQL: select * from `ak_users` where `email` = ****** and `ak_users`.`deleted_at` is null limit 1) at /var/www/html/vendor/laravel/framework/src/Illuminate/Database/Connection.php:712)
[stacktrace]
#0 /var/www/html/vendor/laravel/framework/src/Illuminate/Database/Connection.php(672): Illuminate\\Database\\Connection->runQueryCallback('select * from `...', Array, Object(Closure))
#1 /var/www/html/vend

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.