[SOLVED] Drive mounted read-only or completely full. Begin investigation here


3 posts in this topic Last Reply

Recommended Posts

Hi All,

I am still a new one on Unraid but now have an error and don't know why


bomieNl looked at this file and asked me to post it here for help. After a power outage I got this error and my Dockers and VMs are no longer working.
 

bomieNl saw this in the log but don't know why: BTRFS crashes.

Can someone help ?

nas-diagnostics-20210319-1741.zip

Link to post

Cache is failing to balance because it's completely full, you could try stopping the array, mounting cache manually with skip_balance, delete some data to free up some space then mount normally.

 

If you want to try that do this:

 

Stop array then type on the console
 

mkdir /x
mount -o skip_balance /dev/sdX1 /x

 

X=one of the cache devices, either one is fine

 

Then still on the console or using for example midnight commander browse to /x and delete some data, when done

 

umount /x

 

Start array and see if it can finish balancing.

 

 

 

Link to post
  • JorgeB changed the title to [SOLVED] Drive mounted read-only or completely full. Begin investigation here

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.