802.3ad LACP bonding issue


Recommended Posts

Hi,

 

I have one port eth0 that I'm not using (it's on the mainboard) and I have a 2port intel nic which I have plugged into a managed switch, where those two ports are bonded (switch has different modes such as src-dst-ip or src-dst-mac etc. ( I've tried both of those).

 

In unraid, I'm ignoring eth0 and setting eth1 and 2 to be bonded.  But when I try to set the bond to mode 4 unraid locks up (in fact any mode I select causes a long update) and ultimately reverts to mode 1 active backup.

 

Everything on the switch side seems fine (and I have 4 other bonds working fine).  Maybe it's because I have the unused eth0 and that is causing some confusion?

 

Thanks,

Link to comment
7 hours ago, bkandor said:

Maybe it's because I have the unused eth0 and that is causing some confusion?

 

I suspect this is your problem. Unraid expects eth0 to be used for its GUI. At the bottom of the page you can set which physical port is eth0 by selecting its MAC address. I'd move your unused port to eth2 and use eth0 and eth1 in the bond.

Link to comment
  • 2 weeks later...

Hi, I did do that and was successful getting protocol 4 bonding enabled.  Strangely though, even though it's enabled on both the switch and the unraid box, it isn't functioning the way my qnap or win server bonds are.  i.e. I can never see bond0 throughput go over 1000 mbps - which I can on other devices regularly.  

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.