[Support] lnxd - PhoenixMiner


Recommended Posts

Posted (edited)

I can't seem to get the power settings to change anything.

 

I am running a GTX3080 with additional phoenix parameters: -powlim -35 -cclock -200 -mclock +1200 -tt -80

 

logs show:

[96mEth speed: 86.820 MH/s, shares: 59/0/0, time: 0:48
[0mEth: New job #810a28b0 from eth-us-east.flexpool.io:4444; diff: 4000MH
[95mGPU1: 78C 90% 337W
 

From what I understand I should be around 230 watts with these settings so they don't seem like they are reducing my power levels at all.

 

edit: I don't think it's passing any of my command arguments through as I also added -tt -100 to set fan to run 100% and it doesn't do that either but seems to run based on temp curve.

 

Really hope someone will step in and help me with this!  Please

Edited by Ystebad
Link to comment
21 hours ago, Ystebad said:

I can't seem to get the power settings to change anything.

 

I am running a GTX3080 with additional phoenix parameters: -powlim -35 -cclock -200 -mclock +1200 -tt -80

 

logs show:

[96mEth speed: 86.820 MH/s, shares: 59/0/0, time: 0:48
[0mEth: New job #810a28b0 from eth-us-east.flexpool.io:4444; diff: 4000MH
[95mGPU1: 78C 90% 337W
 

From what I understand I should be around 230 watts with these settings so they don't seem like they are reducing my power levels at all.

 

 

Same issue here, makes this completely unusable...

  • Thanks 1
Link to comment
Posted (edited)
On 6/5/2021 at 7:37 PM, Ystebad said:

I can't seem to get the power settings to change anything.

 

I am running a GTX3080 with additional phoenix parameters: -powlim -35 -cclock -200 -mclock +1200 -tt -80

 

logs show:

[96mEth speed: 86.820 MH/s, shares: 59/0/0, time: 0:48
[0mEth: New job #810a28b0 from eth-us-east.flexpool.io:4444; diff: 4000MH
[95mGPU1: 78C 90% 337W
 

From what I understand I should be around 230 watts with these settings so they don't seem like they are reducing my power levels at all.

 

edit: I don't think it's passing any of my command arguments through as I also added -tt -100 to set fan to run 100% and it doesn't do that either but seems to run based on temp curve.

 

Really hope someone will step in and help me with this!  Please

 

The overclocking won't work in this container. Since the only way to overclock nvidia gpu in linux is using nvidia-settings which requires X server running. Which is not the case in this docker. And it's not trivial thing to setup (at least for me :D)

 

You may try following this guide:

 

 

 

 

 

Edited by zeus83
Link to comment

Got this to install no problem but getting 0.000 MH/s on the output log. Running a Reference 6800 on 20.45. 

 

Here's the log; any thoughts?

 

Quote

[97mAvailable GPUs for mining:
[92mGPU1: AMD Radeon RX 6800 (pcie 4), OpenCL 2.0, 16 GB VRAM, 60 CUs
[96mEth: the pool list contains 1 pool (1 from command-line)
Eth: primary pool: us2.ethermine.org:4444
[0mStarting GPU mining
[95mGPU1: fan PWM control mode 1, min 0, max 255
GPU1: set auto fan: 75C target temp (min fan 0, max fan 100)
[96mEth: Connecting to ethash pool us2.ethermine.org:4444 (proto: EthProxy)
[95mGPU1: 34C 0% 8W
GPUs power: 8.0 W
[92mEth: Connected to ethash pool us2.ethermine.org:4444 (172.65.226.101)
[0mEth: New job #6d245bf8 from us2.ethermine.org:4444; diff: 4295MH
GPU1: Starting up... (0)
GPU1: Generating ethash light cache for epoch #421
[97mListening for CDM remote manager at port 5450 in read-only mode
[0mEth: New job #c3ef1334 from us2.ethermine.org:4444; diff: 4295MH
[96mEth speed: 0.000 MH/s, shares: 0/0/0, time: 0:00
[96mEth speed: 0.000 MH/s, shares: 0/0/0, time: 0:00
[0mEth: New job #d6a638bc from us2.ethermine.org:4444; diff: 4295MH
Eth: New job #007e2517 from us2.ethermine.org:4444; diff: 4295MH
Eth: New job #94c8fde2 from us2.ethermine.org:4444; diff: 4295MH
Eth: New job #007e2517 from us2.ethermine.org:4444; diff: 4295MH
Eth: New job #94c8fde2 from us2.ethermine.org:4444; diff: 4295MH
Light cache generated in 9.5 s (7.2 MB/s)

 

EDIT - tried version 20.20 and onto a different pool and running into this now:

 

Quote

[97mAvailable GPUs for mining:
[92mGPU1: Unknown AMD GPU (pcie 4), OpenCL 2.0, 16 GB VRAM, 60 CUs
[96mEth: the pool list contains 1 pool (1 from command-line)
Eth: primary pool: usw-eth.hiveon.net:4444
[0mStarting GPU mining
[95mGPU1: fan PWM control mode 1, min 0, max 255
GPU1: set auto fan: 75C target temp (min fan 0, max fan 100)
[96mEth: Connecting to ethash pool usw-eth.hiveon.net:4444 (proto: EthProxy)
[95mGPU1: 34C 0% 8W
GPUs power: 8.0 W
[92mEth: Connected to ethash pool usw-eth.hiveon.net:4444 (174.138.160.146)
[0mEth: New job #4f2b25cc from usw-eth.hiveon.net:4444; diff: 5000MH
GPU1: Starting up... (0)
GPU1: Generating ethash light cache for epoch #421
[97mListening for CDM remote manager at port 5450 in read-only mode
[0mEth: New job #ec6b0475 from usw-eth.hiveon.net:4444; diff: 5000MH
Eth: New job #b7db5bd2 from usw-eth.hiveon.net:4444; diff: 5000MH
Eth: New job #4b06ef8d from usw-eth.hiveon.net:4444; diff: 5000MH
[96mEth speed: 0.000 MH/s, shares: 0/0/0, time: 0:00
[0mEth: New job #f6564658 from usw-eth.hiveon.net:4444; diff: 5000MH
Eth: New job #3cd5612d from usw-eth.hiveon.net:4444; diff: 5000MH
Light cache generated in 9.5 s (7.3 MB/s)
/home/docker/mine.sh: line 18: 15 Segmentation fault ./PhoenixMiner -pool $POOL -wal $WALLET.$PASSWORD -tt $TT -tstop $TSTOP -tstart $TSTART -cdm 1 -cdmport 5450 $ADDITIONAL

 

Edited by acropora
Link to comment
On 5/23/2021 at 8:08 AM, Richard Baguley said:

Trying this now, but it hasn't worked the first couple 'o times I did it: same  thread not responding error. I am trying a few variations on driver version to see if that helps.

 

One thing to note: I did see that, even if I don't change the driver version, it reinstalls the driver every time I run it. Is that a useful thing to note?

Richard - were you ever able to get your 6800 to work? I believe I'm having the same issue as you. 

Link to comment
  • 3 weeks later...
  • 2 weeks later...

If you use NVIDIA: Remove -amd from Additional PhoenixMiner Arguments.

 

I do not have "-amd" in my additional settings but every start of the container it tries to load the AMD drivers, what costs a lot of time. Any chance of avoiding that?

Link to comment
  • 3 weeks later...

I'm unsure what is going on but for the life of me I cannot get the PhoenixMiner Docker to work with my MSI RX560 Aero ITX 4GB OC. I'm running on asia1.ethermine.org:4444 and have followed all instructions and am only getting 0.024 MH/S.... Please help

Link to comment
3 hours ago, Dythnire said:

MSI RX560 Aero ITX 4GB OC. 

That would be because you're using a 4GB card. Phoenix Miner only mines ETH and the size of the DAG can't fit, so you get abysmal hashrates. 

 

My advice in this instance, download and setup a VM with either Nicehash OS, Hive OS or Simpleminer OS and assign the card to mine Ravencoin so you can still get a tiny bit. 

Link to comment
  • 2 weeks later...
On 6/16/2021 at 12:29 PM, acropora said:

Richard - were you ever able to get your 6800 to work? I believe I'm having the same issue as you. 

I have a 6800XT and having the same issue. 

i suspect its an issue with the driver or phoenixminer. 

what ive noticed is 1 cpu thread gets stuck at 100%, 

followed by this in the logfile

[93mGPU1 not responding
[91mThread(s) not responding. Restarting.

 

mining a nvidia 1060 using t-rex works fine

Link to comment

im wondering if Phoenix Miner 5.7b fixes the issue, given that the container is running 5.6d, and the change notes for 5.7b mention:

 

-Implemented full hardware control for AMD RX6900/6800/6700 cards under Linux. Note that with these cards under Linux you need to specify relative core voltage: e.g. -cclock -50 will set the core voltage to be 50 mV under the default value

-Fixed an issue causing crashing with some RX6900/6800/6700 cards under Linux (there is no need to run these cards with -clkernel 0 anymore)

 

 

Link to comment
  • 3 weeks later...

Not sure if this is still checked, but I was able to get the following to work:
AMD RX580 8GB

20.50 drivers (using AMD Driver Version entry on container settings)

 

---Checking for optional scripts---
---No optional script found, continuing---
---AMD driver not present---
---Installing AMD drivers, please wait!---
---Downloading driver from https://drivers.amd.com/drivers/linux/amdgpu-pro-20.50-1234664-ubuntu-20.04.tar.xz---
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
---Installing driver, this can take a very long time with no output. Please wait!---
---AMD Driver installation finished---
---Starting---

Project: PhoenixMiner 5.6d
Author: lnxd
Base: Ubuntu 20.04


Target: Unraid 6.9.0 - 6.9.2

Wallet: 0x033468F504c581E98AC13F3e7bBa51067D1b38C2
Pool: us1.ethermine.org:4444

Starting PhoenixMiner 5.6d as uid=0(root) gid=0(root) groups=0(root) with the following arguments:
-pool us1.ethermine.org:4444 -wal 0x033468F504c581E98AC13F3e7bBa51067D1b38C2.x -tt 75 -tstop 85 -tstart 80 -cdm 1 -cdmport 5450

Phoenix Miner 5.6d Linux/gcc - Release build
--------------------------------------------

[0mNo CUDA driver found
OpenCL driver version: 20.50-123x-orca
[97mAvailable GPUs for mining:
[92mGPU1: Radeon RX 580 Series (pcie 10), OpenCL 1.2, 8 GB VRAM, 36 CUs
[96mEth: the pool list contains 1 pool (1 from command-line)
Eth: primary pool: us1.ethermine.org:4444
[0mStarting GPU mining
[95mGPU1: fan PWM control mode 2, min 0, max 255
GPU1: set auto fan: 75C target temp (min fan 0, max fan 100)
[96mEth: Connecting to ethash pool us1.ethermine.org:4444 (proto: EthProxy)
[95mGPU1: 27C 34% 34W
GPUs power: 34.1 W
.........


[0mEth: New job #454c97dc from us1.ethermine.org:4444; diff: 4295MH
Eth: New job #ee9f69d9 from us1.ethermine.org:4444; diff: 4295MH
Eth: New job #cb31e43a from us1.ethermine.org:4444; diff: 4295MH
Eth: New job #c0324b83 from us1.ethermine.org:4444; diff: 4295MH
Eth: New job #8d8f9b18 from us1.ethermine.org:4444; diff: 4295MH
Eth: New job #c0324b83 from us1.ethermine.org:4444; diff: 4295MH
Eth: New job #8d8f9b18 from us1.ethermine.org:4444; diff: 4295MH
[96m
[97m*** 0:00 *** 8/30 18:17 **************************************
[96mEth: Mining ETH on us1.ethermine.org:4444 for 0:00
Eth speed: 21.864 MH/s, shares: 0/0/0, time: 0:00
 

I hope this is enough proof, please let me know if you need more info.

 

Regards,

Tymarand

Link to comment
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.