[SOLVED] Looking for the command to disable screen blanking

Recommended Posts

anyone know how to disable the console screen blanking out, I have already tried setterm --blank 0, cat /sys/module/kernel/parameters/consoleblank and its not 0, still saying 900.


The instructions I found were for 6.8.3 so something must have changes for 6.9.0

Edited by arch1mede
Link to comment
  • arch1mede changed the title to [SOLVED] Looking for the command to disable screen blanking
  • 1 month later...

Came here looking for the answer, had to confirm it but yes. NOPE. Apparently this kernel parameter is ignored. Similarly, you should ignore this post and scroll down to my next one, with an answer which seemingly works.









I'm about to tell you how to edit your kernel parameters, which requires messing with your boot configuration. Don't do this unless you REALLY get it. Back up your files first anyway, because if you mess this up it won't boot. You've been warned.


Open up /boot/syslinux/syslinux.cfg with the knowledge that you're safe because you have a backup. I use nano over ssh, ie nano /boot/syslinux/syslinux.cfg or equivalent, you know the deal.


Find your boot parameters. Here's mine, YMMV.;



You'll note I have security mitigations disabled, and that this has "no performance impact(tm)" on most hardware and that it's generally a stupid idea. Just as an example.

What you want to do, is carefully add the entry consoleblank=0 anywhere after initrd=/bzroot with a space around it. No run-on words. Save, exit. In Nano that's Ctrl+X followed by Y and Enter.




Reboot, and it shouldn't blank or break. If it did, thankfully you have that backup.


You did make that backup, right?





- I use PUTTY for Windows. There's nothing better if you Just Need SSH(TM)

- Since I keep seeing "Most users are okay hitting a key to bring the terminal up" -- WHAT IF IT CRASHED? What if you wanted to see the dieing gasp of a screen? That happened to me A LOT recently and having the console not blank would've been handy, so there ARE valid uses. Stop needing to justify everyone else's desires.

Edited by codefaux
Link to comment
1 hour ago, JorgeB said:

FYI you can easily edit the syslinux configuration by clicking on the flash drive in main (raw view must be selected on the top right):


Correct, I keep forgetting that because I honestly prefer the terminal. I'll try to remember to offer that in the future.


1 hour ago, JorgeB said:

not working

You are....not wrong. Huh. That's the first time I've seen a kernel parameter outright ignored in a while.


Okay, a different method, and I actually rebooted to test this one -- we add setterm -blank 0 to /boot/config/go and I'll let you all sort out how to get there and edit it yourselves.


You didn't forget that backup, right?

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.