Port22_Login_root_ScanBot - lots of thoughts?


12 posts in this topic Last Reply

Recommended Posts

Unfortunately, I am a new purchaser of UNRAIDd, experiencing a hand full of issues of a stripped down basic fresh install.

I have not proceeded this far to the point you appear to be at, to attempt the back up process. Why back up something that is still broke...

On 3/19/2021 at 4:56 AM, wuftymerguftyguff said:

I typically run my appdata, system and domains shares with cache set to prefer.

The outdated videos, tutorials and forums do not address the "prefer setting". Might have changed from ten years ago, since DOS 5.1.1? I myself was confused of which setting should this be set on?

The Prefer option, when first encountering this error upon fresh install setup, or the outdated documentation mentioning of Yes, No options?

The 6.9.1 install still has a bug in the file structure, SpaceInvader 0ne encountered in the videos...several years back. The same three directories > Appdatabackup are missing, now called CommunityApplicationsAppdataBackup. The same bug, has followed the new name change, also misses creating the file structure in both events...

My problem encountered is, >nothing is on the cache drive<, because the directories are missing from a fresh install...like it always has been when first encountered, years ago.

 

 

On 3/19/2021 at 4:56 AM, wuftymerguftyguff said:

letsencrypt binhex-krusader swag

These do look updated and promising, I'm sorry I am the one to have to be the apologist in behalf of LimeTech. I cant even get up to the starting line to dig into these yet. symlinks? Odd if by chance the links are for other apps or dockers that was moved back onto the array. so to speak are now broken not in cache anymore? [edit] then again might be links to webpages and certificates?<

In my case with the cache drive the directories do not exist and I have the opposite problem, nothing on the cache drive?

I have little knowledge of swag, but it might become useful to recreate my ISP certifications of there websites to redirect malware traffic "from my ISP" and back to "return to sender" into becoming my new black Rpi4 hole🤣  for the grief in hijacking my property ">the router<" changing my router IP address, dropping the firewall to download unauthorized software onto my property and locking me out of my property and changing the username and password on the >router<.

 

Are you web hosting? How important may the orphaned files be left in cache? I hear of incidences of growing garbage in cache that may or may not exist. As your observation of file size mismatching. The easy opt out might be to reformat the cache drive slap it back in and move on?

 

More rants, take cover...

A large repository of maybe, potential, perhaps, might contain something useful, if not out of date. Robj cat in the lime hat...Last visited May 18, 2017 oops a daisy.

 

https://forums.unraid.net/forum/55-general-support/   Anyone notice the last dates of the pinned "DATES" in General Support help??? 2015 really???

 

https://forums.unraid.net/profile/10290-squid/  ???  SQUID on the other hand appears to to be doing a huge amount of lifting in what is LimeTech job and responsibilities? Without you Sir, it is my opinion, LimeTech forums will become an empty hollow shell in unresponsiveness

 

http://lime-technology.com/forum/index.php?topic=48972

Try the Fix Common Problems plugin app, misses all the log errors in each of the dockers in the current state distributed for a fresh install.

* I therefor must change my aptitude to change this into a learning experience from why this stuff does not work, into how I(been)RAIDd works. Pihole DoT-DoH, cloudflare, hideme_privoxy, adguardhome, LanguageTool, mumble, P3R-Brave-Browser. Do not work on a UNRAID fresh install.

 

pihole, wireshark and adguardhome use the same port 53, 3000 ports for example.

docker: Error response from daemon: driver failed programming external connectivity on endpoint AdGuard-Home

Error starting userland proxy: listen tcp 0.0.0.0:3000: bind: address already in use. <(now)

*(My ISP has compounded the problem in hijacking my property >router< in an attempt to what I assume and my opinion, to install dd-wrt or openwrt on a router that lacks +4MB of [provisioning storage] and locked me out of my property 192.168.1.0. By changing my property, >the router< IP address and installing a new username / password Fu(%!n& morons)). Without a firewall, that was been removed from my router to install mediacom malware onto the router for ad forwarders and big-tech port bot scanners.

As a last ditch attempt, on my LAN side of the router, I have attempted to install pihole DoT DoH onto every device...Right now a RPi4 is looking like a viable option to redir3ct their jack hammering traffic, return to ISP sender, mediacomcable servers :ph34r: So, for now, I am blind to what the routers DNS info has been changed to...

 

Whereas wireshark works on 3000, adguard and pihole dot doh didnt work on 3000 before the wireshark repository pull request was downloaded to begin with.

Adding a 4000 port + parm in UNRAID for adguard didn't do anything as ports 53 and 3000 are still used after port 4000 has been added. No effective option within the current UNRAID user interface to change the port. (An useless attempt to begin with, I think). As I still am still blind to what my >router< DNS has been provisioned with... 8.8.4.4 or 1.1.1.1 I would prefer the ISP hub I'm connected to right now for locking me out of my property and with malice intent in changing my router IP user interface and all the malware downloaded onto my equipment. Rant over, man I got my hands full

 

 

Edited by Port22_Login_root_ScanBot
morem \ thoughts
Link to post
2 hours ago, Port22_Login_root_ScanBot said:

pihole, wireshark and adguardhome use the same port 53, 3000 ports for example.

Which is why you either change the port mapping if you're running them in bridge network mode, or run them on a separate IP address (network: custom:br0).  Quite normal for various apps to all use the same default ports.  It's why docker has been designed the way it has.

 

If any apps actually DO NOT WORK, then people have to let me know. 

2 hours ago, Port22_Login_root_ScanBot said:

Anyone notice the last dates of the pinned "DATES" in General Support help??? 2015 really???

Just glancing at the titles of the topics, and there's nothing particularly wrong with any of the pinned posts.  The only one with a last reply time of 2016 happens to be locked so that no one can reply to it because it doesn't need any further explaination.  Everything else you're probably looking at the creation date, not the last reply date.  And there's definitely nothing wrong with having a post from 2015 being pinned.

 

2 hours ago, Port22_Login_root_ScanBot said:

I myself was confused of which setting should this be set on?

It's why there's Help Text (press the ? top right) for almost everything in the UI

2 hours ago, Port22_Login_root_ScanBot said:

A large repository of maybe, potential, perhaps, might contain something useful, if not out of date. Robj cat in the lime hat...Last visited May 18, 2017 oops a daisy.

It's a forum.  Posts do not get deleted.  Very little has actually changed, but have rather become more refined and may look different, but the concept is still the same.  If you're searching for something, you do have to be cognizant of the date of the posts and decide for yourself after looking at the dates and the UI if it is completely wrong or simply doesn't look quite the same.  RobJ:  Life goes on and other priorities happen.  In other cases, life does not go on.  

 

2 hours ago, Port22_Login_root_ScanBot said:

The 6.9.1 install still has a bug in the file structure, SpaceInvader 0ne encountered in the videos...several years back. The same three directories > Appdatabackup are missing, now called CommunityApplicationsAppdataBackup. The same bug, has followed the new name change, also misses creating the file structure in both events...

This isn't a bug.  Its a name of a default folder used by a 3rd party app that has nothing to do with either the makers of the OS, or the maker of the video.

 

2 hours ago, Port22_Login_root_ScanBot said:

Try the Fix Common Problems plugin app, misses all the log errors in each of the dockers in the current state distributed for a fresh install.

FCP catches stuff which tends to trip up users.  It is not a debugging tool for why a particular random app does not work for you because of it's settings that is way out of the scope of what the plugin is designed to do.  And, you also have to bear in mind that most of the errors / warnings are the author's opinion of how Unraid should get set up.

 

2 hours ago, Port22_Login_root_ScanBot said:

SQUID on the other hand appears to to be doing a huge amount of lifting in what is LimeTech job and responsibilities? Without you Sir, it is my opinion, LimeTech forums will become an empty hollow shell in unresponsiveness

Seriously doubt that.  There are many other regular users here that help others with problems, much of which I have no clue about.  Not to mention the casual users that also pipe in.

 

 

Honestly, I'd suggest that you break down your little set up problems into smaller chunks and post about each of them in separate postings.  Seeing a wall of rants / questions isn't particularly inviting for any given member here to want to help you out.

Link to post
1 hour ago, Squid said:

Honestly, I'd suggest that you break down your little set up problems into smaller chunks and post about each of them in separate postings.  Seeing a wall of rants / questions isn't particularly inviting for any given member here to want to help you out.

Remember that 99% of the people on the forum are unpaid volunteers that want to help their fellow users in their free time. Most people will look at large post and probably not even bother to read it.

Link to post
Posted (edited)
On 3/21/2021 at 12:37 PM, wuftymerguftyguff said:

Well, as there were no replies, there wasn’t much to de distracted from!

At 6.9.1 does mover deal with symlinks in shares properly at all? Maybe it not just a docker thing?

 

I see perhaps you are curious in how UNRAID works, as well as I am, going forward.

 

On 3/19/2021 at 4:56 AM, wuftymerguftyguff said:

There are a few "files" remaining. The cache reports it has ~3.5G still in use.

 

I have had a poke around. and the issues seem to be related to files belonging to the following dockers

 

Unfortunately, I haven't reached the point in having a suspenseful MOVER function work correctly. In my case, it appears nothing is in my 30.4MB cache.

 

On 3/19/2021 at 4:56 AM, wuftymerguftyguff said:

root@cosmos:/mnt/cache/appdata/swag/keys# ls -l total 0 lrwxrwxrwx 1 nobody users 38 Mar 15 21:31 letsencrypt -> ../etc/letsencrypt/live/obfuscated-domain.co.uk

 

root@cosmos:/mnt/cache/appdata/swag/

Can you point me in the right direction in. How did you get to the location, on your machine,> root@cosmos:/...

/mnt/cache/appdata/... < this is as far as I can dig into UNRAID file structure /mnt/... I am certainly not, on my local machine, able to get into root.

Using your syntax of your local file structure, as in above "root@cosmos:/..." I do have the understanding, perhaps on my local machine, the next parent up from /mnt/... should be the "root@?/..." directory, ? should be different on my local machine than your setup. I have also come across "nobody users" on my local file structure.

 

Are you using midnight commander or binhex-krusader to look at a file? Into ascertaining the potential parameter error coding.

On 3/19/2021 at 4:56 AM, wuftymerguftyguff said:

root@cosmos:/mnt/cache/appdata/swag/keys# ls -l total 0 lrwxrwxrwx 1 nobody users 38 Mar 15 21:31 letsencrypt -> ../etc/letsencrypt/live/obfuscated-domain.co.uk

In your perfect example above, your personal objective in taking the time to do research, using a solid mythological scientific approach in proper research.

Asking for an objective opinion... and crickets.

 

It is my opinion, perhaps, that is what swag is doing and the service that swag uses...to retrieve validated encrypted certifications.

I vaguely remembering that particular line is within .../swag/letsencrypt/... documentation website. https://docs.linuxserver.io/general/swag 

Cert Provider (Let's Encrypt vs ZeroSSL)

As of January 2021, SWAG supports getting certs validated by either Let's Encrypt or ZeroSSL. Both services use the ACME protocol as the underlying method to validate ownership. Our Certbot client in the SWAG image is ACME compliant and therefore supports both services.

 

/live/obfuscated-domain.co.uk < is that anything to do with any websites you are hosting or the purpose for the need for encryption?

 

Apologies wuftymerguftyguff / cosmos, coding is not my expertise, my field is more compartmentalized in hardware.

 

At 6.9.1 does mover deal with symlinks in shares properly at all? Maybe it not just a docker thing?

 

 

Edited by Port22_Login_root_ScanBot
Link to post
Posted (edited)
1 hour ago, John_M said:

There is no doinst.sh file.

Sorry I didn't look first. As I am having a bit of difficulty in how to find something.

Thank you, I am quite green on how UNRAID works. I hope I am projecting the impression, I am willing to learn, rather then an unrealistic belief in why windows doesn't work out of the box.

Please, if you may, if I may ask. What would be the best approach in looking at the file structure, being Linux. In the context, that I might have to contribute in making an effort. In examining, my small adjustments at a time.

 

* My question is should I be using Midnight Commander or within the Tools tab > Unraid OS > Config File Editor in exploring my adjustment of the type of simplicity, software purity text Slackware uses. Scratching my head in seeing *.conf , *.cfg and *.xml 

 

 I am motivated in understanding how UNRAID works, does it matter if I use Midnight Commander or the Config File Editor.

Do I need to be concerned which one is used, for non-persistent changes on reboot reverting back. As I explore in making one step at time is adjustments? Thank you again.

Edited by Port22_Login_root_ScanBot
Link to post
57 minutes ago, Port22_Login_root_ScanBot said:

should I be using Midnight Commander or within the Tools tab > Unraid OS > Config File Editor

 

Unraid is intended to be configured via the GUI. Beginners should be careful of manually editing configuration files and even advanced users can achieve most thing via the GUI.

 

This is off topic. If you have specific questions you can start your own thread.

 

Link to post
1 hour ago, John_M said:

This is off topic. If you have specific questions you can start your own thread.

I have split it all into a separate thread.

Link to post
Posted (edited)

*1.) I have a reported error within Log as follows ;> Mar 21 22:14:47 Dell cache_dirs: ERROR: excluded directory 'VM\ backup' does not exist.

*>    1.) >Question, Is this the correct location to edit, (this simple test1), a potential backslash VM\ syntax error and replace with this corrective action VM/ ? <(is the solution for the potential missing directory "VM/backup" or "VM/ backup")?

 

I will try this edit from this GUI menu bar > Tools > Unraid OS > Config File Editor > Editing: /boot/config/plugins/dynamix.cache.dirs/dynamix.cache.dirs.cfg

 

options="-e "Appdatabackup" -e "CommunityApplicationsAppdataBackup" -e "VM\ backup" -e "appdata" -e "isos" -l off"

                                                                                                         

options="-e "CommunityApplicationsAppdataBackup"-e "appdata" -e "isos" -l off"

 

Next within Midnight commander locate this >  /boot/config/shares/VM backup.cfg

F8 to delete

Edited by Port22_Login_root_ScanBot
Link to post
On 3/21/2021 at 3:16 AM, Port22_Login_root_ScanBot said:

My problem encountered is, >nothing is on the cache drive<, because the directories are missing from a fresh install...like it always has been when first encountered, years ago.

SOLVE COAGULA 621MB is now reported within cache drive pool. I still need need to take a closer look at the file structure

Link to post
7 hours ago, Port22_Login_root_ScanBot said:

look at the file structure

flash drive is /boot

 

array disks, pools, user shares, Unassigned Device mounts are in /mnt

 

User shares are just the aggregated top level folders on disks and pools. In other words, another view of the disks. Folders can span disks, files cannot. Don't mix user shares with disks and pools when moving/copying because Linux doesn't know that the source and destination may be the same file.

 

If you create a user share, a top level folder named for the share is created on disks or pools as needed according to the settings for the share.

 

If you create a top level folder on disks or pools it is automatically a user share named for the folder. If you don't make settings for a user share it has default settings.

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.