wol der 2. NIC nutzen


21 posts in this topic Last Reply

Recommended Posts

Moin.

Ich möchte gerne meine onboard 1G NIC für WOL nutzen. Nextcloud soll bei Zugriff den Server aufwecken.

 

Die crux:

nextcloud ist über swag öffentlich per subdomain verfügbar.  80 und 443 sind auf die gesteckte Karte im Server geroutet. 

Die onboard Karte hat natürlich eine andere Mac und IP.

 

Switch ist ein Mikrotik CSS610. SWos.

 

Ideen?

Link to post

WoL hat ja nix mit der IP zu tun.

Solange die Karten im Switch auf L2 verbunden sind, also gleiches (V)LAN, kannst Du das WoL Paket an die MAC senden.

Alternativ, wenn das aus Nextcloud bzw dem Container nicht geht, gibt es da ja evtl. eine Möglichkeit über den Zugriff des WoL-Plugin im unraid.

Kann Nextcloud ein HTTP-Script ausführen?

Link to post
4 minutes ago, mgutt said:

Wie soll das gehen, wenn der Server schläft?

🤪 OH-Kay....valider Punkt...

 

2 hours ago, MartinG said:

Nextcloud soll bei Zugriff den Server aufwecken.

 

...aber ist dann Nextcloud nicht auch ausserhab des Servers oder macht @MartinG den gleichen Denkfehler? 

 

 

Edited by Ford Prefect
Link to post

Das Problem ist Doch daß das Wake Signal für die Lwl Verbindung gesendet wird, diese aber nicht erwacht.

 

In fritzbox kann ich ja auf PC starten klicken. Mache ich das bei der Server LWL Verbindung tut sich nix.

Mache ich das bei der 1g Verbindung dann wacht der Server auf.

 

Skripte in der fritzbox?

 

Link to post
1 minute ago, MartinG said:

Das Problem ist Doch daß das Wake Signal für die Lwl Verbindung gesendet wird, diese aber nicht erwacht.

...warum denn? Wenn 1G und 10G am selben Switch hängen, musst Du nur an die MAC des 1G senden....von dem Punkt/App/Nextcloud aus, dass auch an die LWL senden kann.

Irgendwie verstehe ich den Aufbau bei Dir dann nicht, wieso das ein Problem sein sollte. 🤔 Aber Ich nutze Nextcloud und SWAG auch nicht.

Wie gesagt, die IP ist nicht relevant, wichtig ist das die 10G und 1G im selben LAN Segment sind....wenn beide am CSS610 hängen und Du keine VLANs definiert hast, ist das schonmal so.

Wenn es die Fritte kann, geht es also technisch....warum kannst Du die MAC des 1G nicht von dort verwenden, wo das Signal an die LWL gesendet wird?

Link to post
2 minutes ago, Ford Prefect said:

Wenn es die Fritte kann, geht es also technisch

Die sendet nur an die Mac, die man erreichen will. Man könnte also nur eine zweite Portfreigabe einrichten und vor dem Aufruf von NC erstmal die andere Adresse aufrufen.

Link to post
2 minutes ago, mgutt said:

Die sendet nur an die Mac, die man erreichen will. Man könnte also nur eine zweite Portfreigabe einrichten und vor dem Aufruf von NC erstmal die andere Adresse aufrufen.

..oder im Unraid einen Bond aus 1G (eth0) und 10G (eth1) machen.

Im Bond ist die MAC immer die von eth0....kommt das Wol-Packet da an und weckt die eth0 auf? habe ich noch nicht probiert....

Link to post
1 hour ago, MartinG said:

Das Problem ist Doch daß das Wake Signal für die Lwl Verbindung gesendet wird, diese aber nicht erwacht.

 

In fritzbox kann ich ja auf PC starten klicken. Mache ich das bei der Server LWL Verbindung tut sich nix.

Mache ich das bei der 1g Verbindung dann wacht der Server auf.

 

Skripte in der fritzbox?

 

Hast du PCIE im Standby Aktiv und ACPI etc. kontrolliert? Ich weiß nicht wie es unter Linux ist aber unter Windows muss man zusätzliche PCIE Devices extra Konfigurieren das die im Standby adressierbar sind.

Edited by Smolo
Link to post
8 hours ago, MartinG said:

In fritzbox kann ich ja auf PC starten klicken. Mache ich das bei der Server LWL Verbindung tut sich nix.

Mache ich das bei der 1g Verbindung dann wacht der Server auf.

...damit ist der unRaid Server doch schonmal richtig konfiguriert, zumindest kein Thema in Bezug auf WoL, PCIE, ACPI usw...

 

Ich denke, das einfachste wäre es, in der Fritz dann - wie oben schon von @mgutt vorgeschlagen - eine 2te Portweiterleitung zu machen, also auf den 1G Port des unRaid.

Wobei Du ja für Nutzung von von aussen gar eigentlich keine 2te benötigst, wenn Dein I-Net kleiner-gleich 1GBit symetrisch ist ;-) ...der 10G Link bringt Dir da nix.

Link to post

...das macht es aber aufwendig, weil Du dazu ein 2tes IP-Netz brauchst, oder (vor allem mit einer Fritz als Router)?

Wenn der Server aufgeweckt ist, schadet es ja nix wenn der Traffic über den 10G geht....1G nur zum aufwecken...Du brauchst ja nur die MAC...gib ihm eine statische IP aus einem anderen (ungenutzten) Netz, wenn es ohne nicht geht, aber keine zweite default-Route.

 

Edith: ...obwohl das mit der Fritz wohl nicht geht, mit dem Port-Forward auf eine andere IP ausserhalb des Heimnetz, obwohl die ja Routen in weitere IP-Netze kann...habe ich noch nie probiert.

Edited by Ford Prefect
Link to post
On 3/29/2021 at 1:14 PM, Smolo said:

Hast du PCIE im Standby Aktiv und ACPI etc. kontrolliert?

Keinerlei Optionen vorhanden.,.

 

19 hours ago, Ford Prefect said:

...das macht es aber aufwendig, weil Du dazu ein 2tes IP-Netz brauchst

Na, ich würde schlussendlich einfach die 10G Verbindung zu Workstation als separate Verbindung nutzen...

eher ungern.

 

Im Mikrotik steht noch was von port mirroring oder wie das heißt.

mal sehen.

Link to post
13 minutes ago, MartinG said:

Im Mikrotik steht noch was von port mirroring oder wie das heißt.

mal sehen.

...dann kopiert er das, was auf Port A passiert auf B...nich gut, wenn die unterschiedliche Bandbreite haben ;-)

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.