unraid 6.9.0-rc2 showing 2 interfaces eth0 and eth1 but i only have one eth


Recommended Posts

i recently moved so server has been off for 14 days. for some reason unraid is showing eth0 and eth1 and i only have one eth port. i've deleted network.cfg a couple of times, and it works after one reboot, then fails on the next. and gives me two eth again. i don't have internet access unless i enable bonding..which doesn't make since as i have only one eth.

Link to comment
5 minutes ago, letrain said:

i recently moved so server has been off for 14 days. for some reason unraid is showing eth0 and eth1 and i only have one eth port. i've deleted network.cfg a couple of times, and it works after one reboot, then fails on the next. and gives me two eth again. i don't have internet access unless i enable bonding..which doesn't make since as i have only one eth.

You should attach your diagnostics to a new post (Tools --> Diagnostics from the GUI).

Link to comment

According to your diagnostics you have five Ethernet ports installed. Unraid is only using one of them, eth1, the rest are stubbed and presumably being used by your pfsense VM. Your problem is that Unraid expects to use eth0 for its GUI. You need to rearrange your NICs so that the 2.5gb NIC is eth0, not eth1. You can do that on the Settings -> Network Settings page of the GUI in the Interface Rules section.

 

Link to comment

You also have read errors on your cache:

 

Mar 30 07:57:21 Tower kernel: BTRFS info (device sdd1): bdev /dev/sdd1 errs: wr 0, rd 26, flush 0, corrupt 0, gen 0

 

which may explain your Docker problem. See this post for how to deal with it, how to reset the counters and how to monitor it in the future:

 

 

 

Link to comment
Posted (edited)
3 hours ago, John_M said:

According to your diagnostics you have five Ethernet ports installed. Unraid is only using one of them, eth1, the rest are stubbed and presumably being used by your pfsense VM. Your problem is that Unraid expects to use eth0 for its GUI. You need to rearrange your NICs so that the 2.5gb NIC is eth0, not eth1. You can do that on the Settings -> Network Settings page of the GUI in the Interface Rules section.

Rules section? i'm not seeing that. just both interfaces, and eth0 has no mac address...just a yes / no for mac address. if i change it to yes, it offers bonding modes...eth1 is the correct mac address for the 2.6gbps ethernet... i've had a server with two nics before i could switch them around by mac address. i still don't understand why i have eth0 and eth1...

Quote

 

 

Edited by letrain
Link to comment
5 minutes ago, letrain said:

Rules section? i'm not seeing that.

 

It's immediately above the Routing Table section:

 

1617211216_ScreenShot2021-03-30at22_26_32.png.67ae37c0abfaadc75466dcab4d1a065c.png

 

but since you're not seeing it you'll have to free up those other NICs temporarily so that Unraid can see them, then that section should appear. So go to Tools -> System Devices and un-stub them (you'll need to stop the VM that uses them first, of course). Then re-boot, navigate to the Settings -> Network Settings page again and reassign eth0 to the appropriate MAC address. Then you can go back and re-stub them, re-boot and start the VM.

 

Link to comment
2 minutes ago, John_M said:

 

It's immediately above the Routing Table section:

 

1617211216_ScreenShot2021-03-30at22_26_32.png.67ae37c0abfaadc75466dcab4d1a065c.png

 

but since you're not seeing it you'll have to free up those other NICs temporarily so that Unraid can see them, then that section should appear. So go to Tools -> System Devices and un-stub them (you'll need to stop the VM that uses them first, of course). Then re-boot, navigate to the Settings -> Network Settings page again and reassign eth0 to the appropriate MAC address. Then you can go back and re-stub them, re-boot and start the VM.

 

 

that sounds good. i will try that and report back.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.