UHD 750 - Rocket Lake IGP support.


Recommended Posts

Can someone tell us how is it working?

 

adding the 

options i915 force_probe=4c8a 
options i915 enable_guc=2

 Will provide full hw transcoding support? what works and what don't??

Edited by arturovf
spelling
Link to comment
  • 2 weeks later...

Hi,

 

I'm kind of a newbie in here and to further complicate things, I recently bought an Intel 11500 for my Unraid server. Can I enable the iGPU for Plex transcoding within the Stable version (6.9.2) or do I need to be on the beta version? If so, could anybody guide me on the process?

 

Thank you,

Link to comment
Posted (edited)
On 4/26/2021 at 1:47 PM, xXx said:

HDR No..

 

On 4/26/2021 at 1:37 PM, arturovf said:

Thank you @xXx, can you tell me Plex-wise what is working and what isn't? I mean I guess tonemapping is not yet working right?

Hardware accelerated HDR Tonemapping is working as of Plex version: 1.23.0.4497.

 

1872940816_ScreenShot2021-05-09at12_57_28PM.png.1879138c93ab1a1c07758d81e82e7f61.png

 

1716193791_ScreenShot2021-05-09at12_59_39PM.thumb.png.0468ad9e7d07ebec5aafc5d500fb659c.png

Weird graphics glitches still occur if using HDR Tonemapping below the 1080p HD High setting

 

I'm running an Intel i5 11400 with a UHD 730

 

On 5/5/2021 at 10:27 AM, ProXM1 said:

Hi,

 

I'm kind of a newbie in here and to further complicate things, I recently bought an Intel 11500 for my Unraid server. Can I enable the iGPU for Plex transcoding within the Stable version (6.9.2) or do I need to be on the beta version? If so, could anybody guide me on the process?

 

Thank you,

 

1. Create a file on your UNRAID flash drive under /boot/config/modprobe.d called i915.conf

2. paste the following code in the conf file you created

options i915 force_probe=4c8a
options i915 enable_guc=2

3. Reboot your server and you should be able to turn on Plex transcoding in your docker

 

No need to update your UNRAID version

Edited by lukerv4
added stme steps for the other user to get them up and running with their new CPU
  • Thanks 1
Link to comment

Many 4K movies now play with HDR tonemapping using HW transcoding. But unfortunately also many don't and show artifacts. I really hope it's a Linux kernel issue. Was just switching over to a full 4K library. For now tonemapping stays off. This is on a 11500.

  • Like 1
Link to comment

thnx a lot for this topic.

my intern graphics intel i5 11400 runs now for plex hw transcoding.

the only one what i found out is that the direct connected server monitor goes black. the command prompt is no more visible.

any solution for that?

Link to comment
Posted (edited)

 

On 5/10/2021 at 1:01 AM, lukerv4 said:

. Create a file on your UNRAID flash drive under /boot/config/modprobe.d called i915.conf

2. paste the following code in the conf file you created



options i915 force_probe=4c8a
options i915 enable_guc=2

3. Reboot your server and you should be able to turn on Plex transcoding in your docker

 

No need to update your UNRAID version

 

Hi i really need help. I'm using Intel i5-11500 and I've done as instructed but unraid will not boot and will get stuck at "switching to inteldrmfb from efi vga" and will just stuck there forever

 

image.png.f68b8d243124087c5887fb645c280120.png

 

 

 

Edited by fahmietalife
Link to comment
2 hours ago, fahmietalife said:

Update: i have to remove the thumbdrive and plug in to my laptop and manually remove i915.conf file, then i am able to boot to unraid. 

 

Appreciate someone that can advise me as i really need hardware transcoding to work. 

What do you get for your GPU on lspci,

 

i.e. 00:02.0 VGA compatible controller: Intel Corporation Device 9ba8 (rev 03

Link to comment
3 hours ago, SimonF said:

What do you get for your GPU on lspci,

 

i.e. 00:02.0 VGA compatible controller: Intel Corporation Device 9ba8 (rev 03

 

00:00.0 PCI bridge: Intel Corporation Device 4c53 (rev 01)
00:02.0 VGA compatible controller: Intel Corporation Device 4c8a (rev 04)
00:12.0 Signal processing controller: Intel Corporation Comet Lake PCH Thermal Controller
00:14.0 USB controller: Intel Corporation Comet Lake USB 3.1 xHCI Host Controller
00:14.2 RAM memory: Intel Corporation Comet Lake PCH Shared SRAM
00:14.3 Network controller: Intel Corporation Comet Lake PCH CNVi WiFi
00:16.0 Communication controller: Intel Corporation Comet Lake HECI Controller
00:17.0 RAID bus controller: Intel Corporation SATA Controller [RAID mode]
00:1b.0 PCI bridge: Intel Corporation Device 06c2 (rev f0)
00:1b.4 PCI bridge: Intel Corporation Comet Lake PCI Express Root Port #21 (rev f0)
00:1c.0 PCI bridge: Intel Corporation Device 06bc (rev f0)
00:1c.5 PCI bridge: Intel Corporation Comet Lake PCIe Port #6 (rev f0)
00:1d.0 PCI bridge: Intel Corporation Comet Lake PCI Express Root Port #9 (rev f0)
00:1d.4 PCI bridge: Intel Corporation Device 06b4 (rev f0)
00:1f.0 ISA bridge: Intel Corporation Device 0684
00:1f.3 Audio device: Intel Corporation Device f1c8
00:1f.4 SMBus: Intel Corporation Comet Lake PCH SMBus Controller
00:1f.5 Serial bus controller [0c80]: Intel Corporation Comet Lake PCH SPI Controller
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (11) I219-V
05:00.0 Ethernet controller: Intel Corporation Ethernet Controller I225-V (rev 02)
06:00.0 Non-Volatile memory controller: ADATA Technology Co., Ltd. XPG SX8200 Pro PCIe Gen3x4 M.2 2280 Solid State Drive (rev 03)

Link to comment
36 minutes ago, fahmietalife said:

 

00:00.0 PCI bridge: Intel Corporation Device 4c53 (rev 01)
00:02.0 VGA compatible controller: Intel Corporation Device 4c8a (rev 04)
00:12.0 Signal processing controller: Intel Corporation Comet Lake PCH Thermal Controller
00:14.0 USB controller: Intel Corporation Comet Lake USB 3.1 xHCI Host Controller
00:14.2 RAM memory: Intel Corporation Comet Lake PCH Shared SRAM
00:14.3 Network controller: Intel Corporation Comet Lake PCH CNVi WiFi
00:16.0 Communication controller: Intel Corporation Comet Lake HECI Controller
00:17.0 RAID bus controller: Intel Corporation SATA Controller [RAID mode]
00:1b.0 PCI bridge: Intel Corporation Device 06c2 (rev f0)
00:1b.4 PCI bridge: Intel Corporation Comet Lake PCI Express Root Port #21 (rev f0)
00:1c.0 PCI bridge: Intel Corporation Device 06bc (rev f0)
00:1c.5 PCI bridge: Intel Corporation Comet Lake PCIe Port #6 (rev f0)
00:1d.0 PCI bridge: Intel Corporation Comet Lake PCI Express Root Port #9 (rev f0)
00:1d.4 PCI bridge: Intel Corporation Device 06b4 (rev f0)
00:1f.0 ISA bridge: Intel Corporation Device 0684
00:1f.3 Audio device: Intel Corporation Device f1c8
00:1f.4 SMBus: Intel Corporation Comet Lake PCH SMBus Controller
00:1f.5 Serial bus controller [0c80]: Intel Corporation Comet Lake PCH SPI Controller
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (11) I219-V
05:00.0 Ethernet controller: Intel Corporation Ethernet Controller I225-V (rev 02)
06:00.0 Non-Volatile memory controller: ADATA Technology Co., Ltd. XPG SX8200 Pro PCIe Gen3x4 M.2 2280 Solid State Drive (rev 03)

did you try 

options i915 force_probe=4c8a in the file without options i915 enable_guc=2

 

 

 

Link to comment
29 minutes ago, fahmietalife said:

Yes i did that, still the same. 

Have you set any of the bios options for iGPU?

 

I dont have 11th Gen, this is the log I have for my CPU.

 

May 29 20:45:19 computenode kernel: fb0: switching to inteldrmfb from EFI VGA
May 29 20:45:19 computenode kernel: Console: switching to colour dummy device 80x25
May 29 20:45:19 computenode kernel: i915 0000:00:02.0: vgaarb: deactivate vga console
May 29 20:45:19 computenode kernel: i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=io+mem
May 29 20:45:19 computenode kernel: i915 0000:00:02.0: [drm] Finished loading DMC firmware i915/kbl_dmc_ver1_04.bin (v1.4)
May 29 20:45:19 computenode kernel: [drm] Initialized i915 1.6.0 20200917 for 0000:00:02.0 on minor 0
May 29 20:45:19 computenode kernel: ACPI: Video Device [GFX0] (multi-head: yes  rom: no  post: no)
May 29 20:45:19 computenode kernel: input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input4
May 29 20:45:19 computenode kernel: fbcon: i915drmfb (fb0) is primary device
May 29 20:45:19 computenode kernel: Console: switching to colour frame buffer device 480x135
May 29 20:45:19 computenode kernel: i915 0000:00:02.0: [drm] fb0: i915drmfb frame buffer device
May 29 20:45:19 computenode root: 
May 29 20:45:19 computenode root: ---Intel Kernel Module successfully enabled!---

 

This is loaded via the intel gpu top plug rather than the file.

 

You could try just dry run loading the i915 module from the command line.

 

modprobe -n i915

 

You will need to specify the options,

 

modprobe -n i915 force_probe=4c8a

 

try both options and look at the looks/command output.

 

 

 

 

Link to comment
7 hours ago, SimonF said:

Have you set any of the bios options for iGPU?

 

I dont have 11th Gen, this is the log I have for my CPU.

 


May 29 20:45:19 computenode kernel: fb0: switching to inteldrmfb from EFI VGA
May 29 20:45:19 computenode kernel: Console: switching to colour dummy device 80x25
May 29 20:45:19 computenode kernel: i915 0000:00:02.0: vgaarb: deactivate vga console
May 29 20:45:19 computenode kernel: i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=io+mem
May 29 20:45:19 computenode kernel: i915 0000:00:02.0: [drm] Finished loading DMC firmware i915/kbl_dmc_ver1_04.bin (v1.4)
May 29 20:45:19 computenode kernel: [drm] Initialized i915 1.6.0 20200917 for 0000:00:02.0 on minor 0
May 29 20:45:19 computenode kernel: ACPI: Video Device [GFX0] (multi-head: yes  rom: no  post: no)
May 29 20:45:19 computenode kernel: input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input4
May 29 20:45:19 computenode kernel: fbcon: i915drmfb (fb0) is primary device
May 29 20:45:19 computenode kernel: Console: switching to colour frame buffer device 480x135
May 29 20:45:19 computenode kernel: i915 0000:00:02.0: [drm] fb0: i915drmfb frame buffer device
May 29 20:45:19 computenode root: 
May 29 20:45:19 computenode root: ---Intel Kernel Module successfully enabled!---

 

This is loaded via the intel gpu top plug rather than the file.

 

You could try just dry run loading the i915 module from the command line.

 

modprobe -n i915

 

You will need to specify the options,

 

modprobe -n i915 force_probe=4c8a

 

try both options and look at the looks/command output.

 

 

 

 

I've look in my BIOS option (im using Gigabyte H470I AORUS PRO AX), there's only option to disable/enable iGPU and it's currently enable

 

root@unraid01:~# modprobe -n i915
root@unraid01:~# modprobe -n i915 force_probe=4c8a
root@unraid01:~# /dev/dri 
bash: /dev/dri: No such file or directory

Link to comment
3 hours ago, fahmietalife said:

I've look in my BIOS option (im using Gigabyte H470I AORUS PRO AX), there's only option to disable/enable iGPU and it's currently enable

 

root@unraid01:~# modprobe -n i915
root@unraid01:~# modprobe -n i915 force_probe=4c8a
root@unraid01:~# /dev/dri 
bash: /dev/dri: No such file or directory

-n is a dryrun so wont create any /dev/dri, but do you get any error output when you run the commands or syslog entries.

 

You can run without -n, but suggest you stop the array just in case you need to do a hard reset.

Link to comment
10 hours ago, SimonF said:

-n is a dryrun so wont create any /dev/dri, but do you get any error output when you run the commands or syslog entries.

 

You can run without -n, but suggest you stop the array just in case you need to do a hard reset.

I'm not getting any error output when i ran the command, same goes in syslog.

 

image.png.a0fb08ff162ccb15616526b3f08b5566.png

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.