Jump to content

[SOLVED] Why is Unraid claiming my unused NICs?


Recommended Posts

Unraid 6.9.0

Mobo: ASRock Z490 Taichi

 

I have 3 ethernet NICs, 2 on the mobo, 1 as an AIC. 2 of them are each in their own IOMMU groups (see partial IOMMU groups below, numbers 18 and 20). However, under Tools > System Devices I cannot select any of the NICs for use with a VM as the check boxes are greyed out and text appears on hover saying "In use by Unraid".

 

Is there any way to free these 2 ethernet NICs from being claimed by Unraid so I can pass them through?


# SNIP

 

IOMMU group 14:[8086:0685] 00:1f.0 ISA bridge: Intel Corporation Device 0685

               [8086:06c8] 00:1f.3 Audio device: Intel Corporation Comet Lake PCH cAVS

               [8086:06a3] 00:1f.4 SMBus: Intel Corporation Comet Lake PCH SMBus Controller

               [8086:06a4] 00:1f.5 Serial bus controller [0c80]: Intel Corporation Comet Lake PCH SPI Controller

               [8086:0d4d] 00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (11) I219-V

IOMMU group 15:[15b7:5002] 02:00.0 Non-Volatile memory controller: Sandisk Corp WD Black 2018/SN750 / PC SN720 NVMe SSD

IOMMU group 16:[1b21:3242] 03:00.0 USB controller: ASMedia Technology Inc. ASM3242 USB 3.2 Host Controller

IOMMU group 17:[1987:5016] 04:00.0 Non-Volatile memory controller: Phison Electronics Corporation E16 PCIe4 NVMe Controller (rev 01)

IOMMU group 18:[8086:10d3] 05:00.0 Ethernet controller: Intel Corporation 82574L Gigabit Network Connection

IOMMU group 19:[8086:2723] 06:00.0 Network controller: Intel Corporation Wi-Fi 6 AX200 (rev 1a)

IOMMU group 20:[10ec:8125] 07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller (rev 05)

# SNIP

Link to comment
32 minutes ago, MontgomeryDixon said:

I just tried disabling bonding and the web UI went down. How do I re-enable it without the web UI?

Edit the network.cfg file text file in the /config folder of your unRAID boot flash drive.

 

Before editing this file, you might just try renaming it and rebooting.  This will force the creation of a new network.cfg file with default settings.  Default uses DHCP.

Link to comment
  • JorgeB changed the title to [SOLVED] Why is Unraid claiming my unused NICs?
  • 1 month later...
  • 1 year later...
On 5/13/2021 at 8:25 AM, Northman said:

For all the people who also land here while googling for "in use by unraid":

I'm testing unRAID right now and had the same issue. Bonding was already disabled, but you also need to disable bridging.

I don't know how many days I've been trying to figure this out on 6.11 but this comment was the missing piece to get my PCIe available for VM passthrough. Thank you so much! 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...