var/log getting full (55%) after 11 days uptime


Recommended Posts

1 hour ago, Wolbaz said:

one core has been sitting at 100% all day. 

You have this issue.

 

Try the WSD options fix mentioned in the thread or disable WSD.

 

As to the issue in the thread title, the default log size is only 128M and is in RAM.  Try this command to see what is in the log to see if something in particular contains a lot of log files:

 

du -sm /var/log/*

Edited by Hoopster
Link to comment

Cpu usage is back to normal, thanks for that. Here's the command

 

root@Tower:~# du -sm /var/log/*
72      /var/log/atop
0       /var/log/btmp
0       /var/log/cron
0       /var/log/debug
1       /var/log/dmesg
0       /var/log/docker.log
0       /var/log/faillog
0       /var/log/lastlog
1       /var/log/libvirt
0       /var/log/maillog
0       /var/log/messages
0       /var/log/nfsd
1       /var/log/nginx
0       /var/log/packages
1       /var/log/pkgtools
0       /var/log/plugins
0       /var/log/removed_packages
0       /var/log/removed_scripts
0       /var/log/removed_uninstall_scripts
1       /var/log/samba
0       /var/log/scripts
0       /var/log/secure
0       /var/log/setup
0       /var/log/spooler
0       /var/log/swtpm
1       /var/log/syslog
1       /var/log/vfio-pci
1       /var/log/wtmp

Link to comment
Posted (edited)

from what I can gather I need to disable atop in the nerdpack, as well as anything else I don't need. As far as I can tell the nerd pack is all command line stuff that I probably don't need at all. 

Edited by Wolbaz
Link to comment
Posted (edited)

Welp disabled all the nerdpack junk, then I went back to dashboard and my memory shows "Usable size:
Warning: A non-numeric value encountered in /usr/local/emhttp/plugins/dynamix/include/Helpers.php on line 31
0.0 B"

 

Went over to fix common problems and the rescan button doesn't work. It pops up the normal window and it immediately closes without doing anything. Same with extended scan. Tried to download diagnostics file and it just gets stuck on downloading.

 

Clicking system log on the main page gives me "Undefined"

Edited by Wolbaz
Link to comment
21 minutes ago, jonathanm said:

Did you reboot after turning off the nerdpack items?

that fixed it, thanks! I was hesitant to do so so late on a work night. I didn't want something to break and then have to stay up late troubleshooting.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.