[Résolu] PiHole (Docker) avec une IP Spécifique


8 posts in this topic Last Reply

Recommended Posts

Bonjour,

J'ai tenté d'installer Pihole, mais j'ai une erreur. J'ai lu des sujets mais en anglais et je n'y comprends rien. :(

 

J'ai ceci à l'installation :

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='pihole-template' --net='bridge' -e TZ="Europe/Paris" -e HOST_OS="Unraid" -e 'DNS1'='8.8.8.8' -e 'DNS2'='8.8.4.4' -e 'TZ'='Europe/London' -e 'WEBPASSWORD'='admin' -e 'INTERFACE'='br0' -e 'ServerIP'='192.168.1.24' -e 'ServerIPv6'='' -e 'IPv6'='False' -e 'DNSMASQ_LISTENING'='all' -p '53:53/tcp' -p '53:53/udp' -p '67:67/udp' -p '80:80/tcp' -p '443:443/tcp' -v '/mnt/user/appdata/pihole/pihole/':'/etc/pihole/':'rw' -v '/mnt/user/appdata/pihole/dnsmasq.d/':'/etc/dnsmasq.d/':'rw' --cap-add=NET_ADMIN --dns 127.0.0.1 --dns 1.1.1.1 --restart=unless-stopped 'pihole/pihole:latest'
WARNING: Localhost DNS setting (--dns=127.0.0.1) may fail in containers.
afd808edd2bad56918a79b1f43d848935088fbe3776a63752ce2175d1e7b1982
/usr/bin/docker: Error response from daemon: driver failed programming external connectivity on endpoint pihole-template (416b6c3efab25c2aa641d00404301f0204012ce1c7367de530bfd1b82bce046f): Error starting userland proxy: listen tcp 0.0.0.0:80: bind: address already in use.

The command failed.

 

Je ne vois pas ce qui peut poser problème.

Si quelqu'un voit un truc pas net, ou a la solution c'est bienvenu !

Merci.

Edited by PicPoc
Résolu !
Link to post

En réfléchissant au problème avec les erreur de port c'est ce que je voulais faire mais nul endroit pour modifier dands la config.

Tu me diras commenttu as fais ! Merci ;)

Voici la capture demandé :

 

PiHole-1.png

 

Link to post

Ok dans ton menu Edit en haut a droite  (Version 6.9.1) tu as un toggle pour le Basic view. Tu switch en advanced view et la tu as une option pour fixé IP.  L'IP doit être

le même que sur ta ligne Key 6 (qui ne doit pas être celui de ton unraid).  De cette manière tu fixe l'ip sur lequel tes autre ordi ou téléphone vont faire leur requête DNS.

Link to post

Ah oui, je suis déjà passé par l'edit mais je ne vois rien ou mettre l' IP :

 

PiHole_2.thumb.png.9912782e407f6dbde78f1f46e4058865.png

 

C'est dans la partie "Extra Parameters" ?

Mais quoi rajouter ?

 

J'ai ceci actuellement :

--cap-add=NET_ADMIN --dns 127.0.0.1 --dns 1.1.1.1 --restart=unless-stopped

 

Vraiment je ne vois pas...

Link to post

J'ai cherché mais tu m'avais pas dit qu'il fallait changer le "Network Type" :P

 

Solution :

 

-Basculer en "Advanced View" et régler les valeurs :
 Network Type               : "Custom : br0"
 Fixed IP address (optional): 192.168.1.12 (J'ai utilisé cette IP pour essai)
 Key 3        (Variable: TZ): Europe/Paris
 Key 4         (WEBPASSWORD): MotDePasse
 Key 6 (Cont. Var. ServerIP): 192.168.1.12 (Bien mettre la même qu'au dessus)
-Valider la configuration avec "Apply"

 

Et tout devrait fonctionner.

Voilà pour ceux qui vont eviter de chercher longtemps comme moi.

Link to post

Bin ca ne l'était pas pour moi. :D

J'ajoute : ca servira pour tout ceux qui ne savaient pas et c'estvalable pour tout les Dockers.

Ce qui m'a permi de résoudre un autre problème en passant.

 

Merci aux participants et au forum !

Je renomme en "Resolu"

Link to post
  • PicPoc changed the title to [Résolu] PiHole (Docker) avec une IP Spécifique

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.