Unable to recover USB Backup - steps in forum aren't working


Recommended Posts

Hi there,

 

The other day I received an alert that my USB boot drive was near failure so I created a new backup and used the USB Creator App to fancy myself a new one as per the instructions.

 

I then rebooted the server with the new USB stick and got the following kernel panic, "end kernel panic - not syncing: VFS: unable to mount root fs on unknown-block(0,0)"

 

I tried rebooting with the same result, then went back to the original USB which resulted in the same kernel panic.

 

I then created a new USB (different stick) based on a backup from 3 days ago with the same result.

 

Because all i care about is the data, i created another brand new USB based on the instructions Files on the "Files on v6 boot drive - Unraid | Docs" only copying super.dat and disk.cfg but upon reboot the drives are there but it doesn't recognize btrfs configuration.

 

I've tried using a medley of usb sticks and even recreated the USB using the manual method.

 

Looking for suggestions please.

 

Link to comment
On 4/6/2021 at 10:22 PM, zetabax said:

created a new backup and used the USB Creator App

This one didn't boot?

 

On 4/6/2021 at 10:22 PM, zetabax said:

created another brand new USB based on the instructions Files on the "Files on v6 boot drive - Unraid | Docs" only copying super.dat and disk.cfg but upon reboot the drives are there

But this one did?

 

Were they the same versions of Unraid? Was it the same version you were using before?

 

Maybe a plugin problem. Try again using your backup but boot in SAFE mode.

Link to comment

Thanks for the reply. 

 

Yes, same versions.  This is proving to be extremely frustrating....  Now trying to manually recover the drives.  What is Unraid's value if its this difficult to recover? 

 

I might as well build my own NAS with Ubuntu and Cockpit 🤷‍♂️

Link to comment
16 minutes ago, zetabax said:

Thanks for the reply. 

Doesn't seem like you read all of it, or at least you didn't answer all my questions

 

11 hours ago, trurl said:

Maybe a plugin problem. Try again using your backup but boot in SAFE mode.

 

 

What exactly do you mean by this?

17 minutes ago, zetabax said:

Now trying to manually recover the drives.

 

Link to comment

Ok, so heres the latest.

 

I went back to basics and scanned the USB stick for errors which there were some.  Ran the fix disk error wizard and voila, no more kernel panics.

 

The new problem is the Web UI won't start and while I can ping and SSH the box, I can not access my data because (me in my infinite wisdom) never set the array to auto start.

 

Screen shot of my mount status below.

 

Would love some suggestions please!

 

 

image.thumb.png.b45576be85e3426704cd6a072ec97fd5.png

 

Link to comment
5 hours ago, SimonF said:

 

Have you booted into safe mode no gui from the syslinux menu?

 

What is the contents of your go file?

 

cat /boot/config/go

Thanks for getting back to me SimonF.

 

Yes, I tried safemode - same result (web UI unavailable)

 

Contents of the go file are as follows

 

image.thumb.png.cd53a11b7a1dc40d6d5cbe9566ee8b9d.png

Link to comment
2 hours ago, zetabax said:

WebUI is accessable in safemode but stops responding when when in normal mode.

Do you mean it works for a time in normal mode but then stops responding?

 

SAFE mode only keeps it from loading plugins, but it doesn't look like there are any plugins in config/plugins anyway. Do you have plugins installed when you boot in normal mode?

2 hours ago, zetabax said:

Should i delete the network.cfg file and reboot?

Or rename it so it isn't used and that should at least simplify things by booting up with default network settings.

Link to comment

Thanks all.  I went ahead and renamed the network.cfg file and as hoped, and Unraid created a new one.  I'm now able to access my shares files and am in the process of copying them over to my new unraid server.

 

 

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.