kernel panic 6.9.2 and ryzen


16 posts in this topic Last Reply

Recommended Posts

Hello all,

 

I've been fighting a few issues since I "upgraded" to a Ryzen based system from an old dual Xeon Dell T410.

New build is a Ryzen 3600, on a B450 chipset. It was getting unresponsive after a few days, and that seems to have gone away after disabling global C-states in the BIOS. The latest issue is I get a kernel panic after a week or so of uptime. I have syslog enabled, and was able to get it just before the panic. I also got a pic of the screen before I rebooted that tells the rest of the story after the syslog dropped. Looks like network related, maybe mac-vlan? Definitely a call trace happens, but not sure what can be done about it.

 

thanks for any help in advance!

 

Ross

 

IMG_20210420_170250.jpg

syslog 4-20-21.txt

Link to post
1 hour ago, rodan5150 said:

Looks like network related, maybe mac-vlan?

 

There are a lot of posts about macvlan call-traces related to docker containers with custom IP addresses, such as this one:

 

 

1 hour ago, rodan5150 said:

disabling global C-states in the BIOS

 

Don't do that. The only C-state that has ever been a problem with Ryzen processors is C6 and that only really affected the 1000-series. That said, it does no harm to find the BIOS setting that refers to Power Supply Idle Control and set it to Typical Current Idle instead of the default Low Current Idle.

 

Link to post
8 hours ago, John_M said:

 

There are a lot of posts about macvlan call-traces related to docker containers with custom IP addresses, such as this one:

 

 

 

Don't do that. The only C-state that has ever been a problem with Ryzen processors is C6 and that only really affected the 1000-series. That said, it does no harm to find the BIOS setting that refers to Power Supply Idle Control and set it to Typical Current Idle instead of the default Low Current Idle.

 

Awesome, thanks for letting me know. I will revert the global C-state setting, and dig around and see if I can find the idle current setting.

Link to post
5 hours ago, rodan5150 said:

see if I can find the idle current setting

 

I usually find it in the AMD CBS section of the menu but wherever you go to find the Global C-states setting, you might find it there too.

 

Link to post
On 4/21/2021 at 11:55 AM, John_M said:

 

I usually find it in the AMD CBS section of the menu but wherever you go to find the Global C-states setting, you might find it there too.

 

That's exactly where it was. I enabled the C-states option, and then set the idle current to typical instead of low. 

I've also created a Docker specific vlan, and moved all of the br0 over to br0.x so hopefully that will keep my call traces and kernel panics at bay. I will update if anything changes. So far so good, but it has only been about 18 hours or so. Longest it has gone in the past was 10ish days. So if I can hit 2 weeks+ I'll consider it a win.

Link to post
  • 5 weeks later...
7 hours ago, JorgeB said:

 

thanks for the Reply JorgeB. I'm going to give the second NIC assignment a shot. I had been trying to do all of this through a single 10Gbe connection. I've got several 1Gbe ports open on my main switch, so its not a huge deal to just assign the containers to a second NIC. With any luck, this will solve it.

Link to post

Hey did you figure it out by any chance? I'm having the exact same issue, same cpu + mobo with a kernel panick. Tried disabling c states and the idle setting, it worked for a couple weeks then started crashing again.

Link to post
19 hours ago, dauntouch said:

Tried disabling c states and the idle setting

 

Don't do both. Re-enable the Global C States. See above. The kernel panic is not caused by the CPU failing to wake up from the C6 state. If that happens the sever just freezes, but the Power Supply Idle Control setting fixes that.  As mentioned above (twice), the panic is likely related to docker networking.

Link to post
On 5/29/2021 at 12:06 AM, dauntouch said:

Hey did you figure it out by any chance? I'm having the exact same issue, same cpu + mobo with a kernel panick. Tried disabling c states and the idle setting, it worked for a couple weeks then started crashing again.


 

 

14 hours ago, John_M said:

 

Don't do both. Re-enable the Global C States. See above. The kernel panic is not caused by the CPU failing to wake up from the C6 state. If that happens the sever just freezes, but the Power Supply Idle Control setting fixes that.  As mentioned above (twice), the panic is likely related to docker networking.



Yeah, I reverted the change of the C-states back to default. Only thing I have set now is the power supply idle control.

So far, what has me "fixed" is I've move all of my docker containers that needed a custom network (static IP) over to a separate NIC (br2). I also disabled vlans in Unraid as well, since I wasn't using them anymore. No kernel panics or anything, yet anyway. It's been over a week now. Fingers are crossed!

Link to post
10 hours ago, dauntouch said:

I "fixed" it by downgrading to 6.8.3

I was close to doing this, but I figured I'd tough it out and give 6.9.x a shot. So far, the br2 network for my containers I want to have their own IP, has been working well. No call traces yet and certainly no kernel panics. Of course, it is barely over a week out since I made that change. If I can say this a month out, then I will consider it good to go.

Link to post
  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.