Cache Pool drive "Not installed" upon reboot - Unmountable: Too many missing/misplaced devices


Recommended Posts


1) Share was suddenly inaccessible - i/o error encountered while transferring files over

2) Rebooted the system, and the entire cache pool and both its droves seems unaccessible

3) Rebooted again, 1 cache drive seems connected to the pool (but Unmountable: Too many missing/misplaced devices), and the other cache drive is now in "unassigned devices"


- I've try remounting the unassigned drive as read only - the files and any freshly transferred files (just before the error) seems to be intact.

- I have yet to physically touch the system - no adjustment of cables, etc throughout the process.


I've read though this, but I'm still not very sure how I can restore things back to exactly where it was, until I take more time over the weekend. I really hope not to lose the data in the cache pool - years of maintaining my plex library, and some precious documents.


Any comments on what I should do next? Thanks so much! I've attached my current screenshot, as well as the diagnostics zip.


Link to comment

The UD device is very likely only mounting because the other device is also available, try this:


Stop the array, if Docker/VM services are using the cache pool disable them, unassign all cache devices, start array to make Unraid "forget" current cache config, stop array, reassign all cache devices (there can't be an "All existing data on this device will be OVERWRITTEN when array is Started" warning for any cache device), re-enable Docker/VMs if needed, start array.


It after doing this it doesn't mount post new diags after array start.

Link to comment

JorgeB, Tigerherz,


Thanks so much! It took me a while to figure out what it meant by "unassign all cache devices", since yesterday I was panicking and it was just a few hours before I had to take an examination 😆


It works now! I tried those steps - array down, disable dockers.

But i had to make sure to unassign all cache devices. I forgot exactly what happened, but after unassigning the remaining cache drive, the pool disappeared. I added a new pool, re-assigned the 2 drives, ensured that there was no "All existing data on this device will be OVERWRITTEN when array is Started" as mentioned, restarted array, and woohoo! All is well!


If i didn't remove and re-create a new pool, adding the drive back to the pool does give the OVERWRITTEN warning.


Side note: 4 months ago, my unraid system kept randomly rebooting by itself 2-3 times every day for about a week. Now, this suddenly happens... Time to migrate to new hardware!


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.