New User with unRAID needs you :)

Recommended Posts

Hi all, I'm from France and I'm a new user here and I need your thoughts and help about what I want to do with unRAID.

I tried to view the SPACEINVADER ONE videos, and read some topics but for me it's a bit confusing. So, I'm here.


Here is my hardware:

  • Motherboard: MSI B360 Gaming Plus
  • Bios updated to the last
  • CPU: Core i9 9900K (8 Cores / 16 Threads)
  • RAM: 64 GB (2666 MHz)
  • 4x SSD Samsung 870 QVO 2 TB
  • 1x NVMe Samsung 970 EVO Plus 2 TB
  • 1x EVGA RTX 2060 Super SC
  • 1x EVGA GTX 1060 SC 6 GB
  • 1x keyboard ZBoard ZMerc
  • 1x mouse R.A.T.8
  • 1x dongle USB to Ethernet (so I have 2 Ethernet connectors)
  • Case: Cooler Master CM 690 II Advanced, with all Fans connected (Noctua)
  • WaterCooling: Lepa AquaChanger 240 (original fans replaced by Noctua. Wow!)
  • And inside the case, I installed an adaptator to plug 2 USB (key or disk) directly on the motherboard
  • 1x NAS Synology DS620Slim with 6 Hard Drives 5 TB, Raid 6
  • 1x TV LG LED 48 inches, all HDMI, with a Gaming Profile inside


What I want to do:

  • install unRAID on a little USB Key (8 GB Sandisk, btw)
  • use my NVMe as a 'system' disk, to host my Windows Gaming VM (only the C:\ drive), a ESXi hypervisor (I'll explain it later), and some dockers (if I can understand all the capabilities of course (install a WoW WotLK Private Server for example, based on TrinityCore or AzerothCore / MACOS / Linux / Wiki for my personal purposes / etc.)
  • use the 4 SSDs for the datas (Games for Windows (i.e. G:\), ESXi VMs, and other VM disks/partitions) ; maybe 3 SSD usable if a parity is configured
  • This unRAID will host all my infrastucture (domain, shares, datas, etc.)
  • I will create some backups to keep on my NAS DS630Slim. Essentially my Documents, Pictures, etc. and maybe some VMs
  • I will create a little 'Pi' VM based on Debian, to host PiHole (very useful!) and create a VPN Tunnel. Actually it's a real Pi but the SD Card is not really robust for this because of constant writes (logs)


About the CPU (based on the chart found here)

  • I want to keep the 2 first cores for the Windows Gaming VM because they are the only 2 cores that can boost to 5 GHz (If I understood it correctly, of course. Maybe I will use the 3 first cores. I don't actually know)
  • I will keep the 2 last cores for the ESXi Hypervisor
  • I will keep 2 others cores for hosting a MACOS VM (yes, I want to try it! ^^)
  • And the last cores for some other VMs (maybe some cores will be shared)


About the RAM, I will use:

  • 8 GB for the Windows Gaming VM (more if necessary (12 GB for example))
  • 32 GB for ESXi and the VMs (less if I can configure the servers (Active Directory and DataCenter) to use only 3 or 4 GB of RAM)
  • 8 GB for MACOS VMs (maybe more, 12 GB for example)
  • and the remaining RAM for other VMs


About the Graphics Cards:

  • Obviously: EVGA RTX 2060 Super SC for Windows Gaming VM
  • Obviously: EVGA GTX 1060 SC for MACOS (for smooth using)


About the TV:

  • she's got 4 HDMI ports (2 based on 60 Hz (port 1 & 2) and 2 based on 120 Hz (port 3 & 4)), all are 4K
  • I will use the Port 1 for the unRAID UI Console (based on the Intel Graphics 630 of the CPU)
  • I will use the Port 2 (or 3) for MACOS, with the GTX 1060
  • I will use the Port 3 (or 4) for Windows Gaming VM, with the RTX 2060 (maybe later a RTX 3060 Ti)


And finally, about ESXi:

  • I actually got at home a HPe ProLiant ML310e Gen8 v2, with a 4 cores CPU (no threads) and 32 GB of RAM. I installed some Windows Server 2019 (2x AD (1 with GUI, and 1 'core' / 1 DataCenter 'core' / 1 Remote Desktop Server and 1 Workstation (for testing)). But I don't use it because it's noisy and it uses a lot of power consumption
  • The Windows Servers are licensed and are working very smoothly. So I don't want to reinstall all of them because of the licenses and all the configurations I made on them
  • The ESXi Hypervisor installed is based on the latest Custom HP 6.5 U3 ISO
  • This HP server use 4 SSD Samsung 500 GB, Raid 5
  • I plan to migrate all my VMs to the the new ESXi hosted on unRAID (maybe a 6.5U3 Standard, or the latest 7.0b), and reuse the HP server for simple tests, when I want to
  • And all my virtual machines will then be functional and usable! I would be happy. My domain is configured, and I will put the Windows Gaming VM inside this domain, with shares restrictions and Internet access restrictions, etc.


I tried with 6.8.3 but it was not usable. The Windows was slow and the Graphics Card was not recognized. So, recently, I tried with the new version, 6.9.2 and Windows was usable. The Graphics Card was installed and I was on screen 4k. But I was unable to play. All the games were  crashing or freezing, or I had only 50% of its power capacity, and then the GC was lost... so I had a very bad screen (purple and blinking, sometimes splitted so I was able to see my screen twice). The games launch was more longer as on a "real" computer install, and I don't know why. So, because of all of this, I uninstalled all unRAID and reinstalled Windows as on a new computer. And it's running perfectly. But it is not really what I want to do with this computer.


So, I watched the SpaceInvader One videos to try to understand how to do with unRAID, but he is very difficult to understand because he chewes lots of words, and sometimes there's no sub, so for me it's a bit difficult. I really want to try this install but unfortunally it's not working. I don't have logs too (I know you need them but I reinstalled Windows as on a new computer. So...)


What I need today is what you think I can do, and how I can create the array and the pool(s). I tried to understand the utility of the pools via the latest SIO video but it's a bit complicated. Do not take it badly dude, huh? :) (yes, i'm clicking on 'refresh' to see his latest video and sometimes it's a long wait ^^)


So, what do you think about this? Is this a viable project or not? Are you OK to help me?


Thanks very much, and see you later !



Edited by cbeitel
Link to comment

Hi Itimpi, and thanks for your feedback.

I understand what you say, but I saw a guy that did this working. So I think it would be working if I try. If not, so I'll stop trying.


But for the rest of my request, is it a possible project for you? And can you tell me how you will configure the system and unRAID, please? (if it were your system)


Thanks a lot



Link to comment
1 hour ago, cbeitel said:

But for the rest of my request, is it a possible project for you? And can you tell me how you will configure the system and unRAID, please? (if it were your system)

No idea really as it is not something I would try.


One thing I did notice from what you wanted to do - core 0 (and any associated hyper thread core) will always be used when running KVM on unRaid as the main core for handling I/O to VMs.

Link to comment
17 minutes ago, itimpi said:

One thing I did notice from what you wanted to do - core 0 (and any associated hyper thread core) will always be used when running KVM on unRaid as the main core for handling I/O to VMs.

What do you mean about this?

Would you say that if I only affect the 2 first cores to a VM, all the threads are? (for me, and the VM, it seems that the OS will see 2 "cores" ?)

Link to comment
2 minutes ago, cbeitel said:

What do you mean about this?

Would you say that if I only affect the 2 first cores to a VM, all the threads are? (for me, and the VM, it seems that the OS will see 2 "cores" ?)

Not quite - I am saying that affects core 0 in the host, which you wanted to be reserved for your VM.

Link to comment
15 hours ago, itimpi said:

I am saying that affects core 0 in the host, which you wanted to be reserved for your VM.

Ho! So, if I understand it, the core 0 is used by unRAID? SO I can't affect this core 0 to a VM ? And maybe it's because of this that my Windows VM is "slow"?

Is there a way to affect an another core to unRAID ?

Link to comment

Hi @cbeitel i have read you PM but thought i would reply here in the thread.


So you have an esxi running with vms on it.

You want to set up a vm on Unraid running esxi and have all the vms the orfiginal esxi running as nested virtualized vms so you dont have to reset up everything.

This will be very inefficient to do this. 

You should migrate the esxi vms to Unraid without using a virtual esxi on Unraid. The vdisks will work as is on Unraid so you need only to copy them to Unraid then set up a vm pointing to the vdisks copied from the esxi.

Make sure to choose similar config to the esxi vms. ie if you are using a legacy boot for the vm on esxi then choose seabios on Unraid. If using uefi then choose ovmf.


I know you are worried as the windows vms are activated. So to be sure it goes smoothly you will need to get the UUID from the vm and make it the same in Unraid. You can get that from esxi or just boot the vm on esxi and open a command prompt and type

wmic csproduct get UUID

This will give you the uuid.


Then in Unraid you will need to edit the vm templates xml to change the uuid to match the orginal.



so you would just change the line 4 here.



So your windows gaming VM. My advice is to set up this vm not using the default settings in the template.

Choose q35 chipset and not i440fx

make sure to use a vbios for your GPU you can try my vbios dump script to get one or edit one from techpowerup.


Also make sure to put all parts of the gpu on the same bus/slot (ie the graphics sound and usb if the gpu has that)



Link to comment

Hi @SpaceInvaderOne and thanks a lot for your reply. I'm very happy that you took time for me :)


I will try what you explained to me, and give you a feedback soon. I wasn't aware that unRAID was capable of using the vDisks of another hypervisors, so I will try it too. Thanks for all of your tips and links to your videos (I didn't viewed them)


Have a nice day and see you soon


Thanks, C.

Edited by cbeitel
  • Like 1
Link to comment
  • 2 weeks later...



So, here I am, with my new installation on unRAID.


It is very fastidious to try to "play" with... sincerely


As I gave informations about my config, I 've done this:

- 1x SSD 2 TB as a cache drive

- 1x SSD 2 TB as parity

- 1x NVMe & the last 2 other SSD 2 TB in the array


The parity config took around 3h45. I installed the Community Apps then the User Scripts.

I used @SpaceInvaderOne video to try to export the vbios but It did never work. Here is the result:


Script location: /tmp/user.scripts/tmpScripts/vBios Dump/script
Note that closing this window will abort the execution of this script
You have selected this device to dump the vbios from
01:00.0 VGA compatible controller: NVIDIA Corporation TU106 [GeForce RTX 2060 SUPER] (rev a1)

This does look like a valid GPU to me. Continuing .........

Checking if location to put vbios file exists
Vbios folder already exists

I will try and dump the vbios without disconnecting and reconnecting the GPU
This normally only works if the GPU is NOT the Primary or the only GPU
I will check the vbios at the end. If it seems wrong I will then retry after disconnecting the GPU

Defining temp vm with gpu attached
Domain dumpvbios defined from /tmp/dumpvbios.xml

Starting the temp vm to allow dump
Domain dumpvbios started

Waiting for a few seconds .....

Stopping the temp vm
Domain dumpvbios destroyed

Removing the temp vm
Domain dumpvbios has been undefined

Okay dumping vbios file named EVGA_GeForce_RTX_2060_Super_SC_Ultra_Gaming.rom to the location /mnt/user/isos/vbios/
cat: rom: Input/output error


Um.... somethings gone wrong and I couldn't dump the vbios for some reason
Sometimes when this happens all we need to do to fix this is 'stub' or 'bind to the vfio' the gpu and reboot the server


This can be done in Unraid 6.8.3 with the use of the vfio config plugin or if you are on Unraid 6.9 or above it can be done
directly from the gui in Tools/System Devices .....So please do this and run the script again

And there's no vBios on the TechPowerUp Website for my Graphics Card.


So I tried to create a Win10 VM, just to try extraction through GPU-Z, but the file is about 1MB. So I don't know if the size is correct. But, when I installed the nVidia Drivers (466.11), the VM start to get very slow. 1 click, 2 Seconds to respond. Here is the XML file:

<?xml version='1.0' encoding='UTF-8'?>
<domain type='kvm'>
  <name>Windows 10</name>
    <vmtemplate xmlns="unraid" name="Windows 10" icon="windows.png" os="windows10"/>
  <memory unit='KiB'>4194304</memory>
  <currentMemory unit='KiB'>4194304</currentMemory>
  <vcpu placement='static'>4</vcpu>
    <vcpupin vcpu='0' cpuset='0'/>
    <vcpupin vcpu='1' cpuset='8'/>
    <vcpupin vcpu='2' cpuset='1'/>
    <vcpupin vcpu='3' cpuset='9'/>
    <type arch='x86_64' machine='pc-q35-5.1'>hvm</type>
    <loader readonly='yes' type='pflash'>/usr/share/qemu/ovmf-x64/OVMF_CODE-pure-efi.fd</loader>
  <cpu mode='host-passthrough' check='none' migratable='on'>
    <topology sockets='1' dies='1' cores='2' threads='2'/>
    <cache mode='passthrough'/>
  <clock offset='localtime'>
    <timer name='rtc' tickpolicy='catchup'/>
    <timer name='pit' tickpolicy='delay'/>
    <timer name='hpet' present='no'/>
    <disk type='file' device='disk'>
      <driver name='qemu' type='raw' cache='writeback'/>
      <source file='/mnt/user/domains/Windows 10/vdisk1.img'/>
      <target dev='hdc' bus='virtio'/>
      <boot order='1'/>
      <address type='pci' domain='0x0000' bus='0x03' slot='0x00' function='0x0'/>
    <disk type='file' device='cdrom'>
      <driver name='qemu' type='raw'/>
      <source file='/mnt/user/isos/Win10_20H2_v2_EnglishInternational_x64.iso'/>
      <target dev='hda' bus='sata'/>
      <boot order='2'/>
      <address type='drive' controller='0' bus='0' target='0' unit='0'/>
    <disk type='file' device='cdrom'>
      <driver name='qemu' type='raw'/>
      <source file='/mnt/user/isos/virtio-win-0.1.190-1.iso'/>
      <target dev='hdb' bus='sata'/>
      <address type='drive' controller='0' bus='0' target='0' unit='1'/>
    <controller type='usb' index='0' model='ich9-ehci1'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x7'/>
    <controller type='usb' index='0' model='ich9-uhci1'>
      <master startport='0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x0' multifunction='on'/>
    <controller type='usb' index='0' model='ich9-uhci2'>
      <master startport='2'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x1'/>
    <controller type='usb' index='0' model='ich9-uhci3'>
      <master startport='4'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x2'/>
    <controller type='pci' index='0' model='pcie-root'/>
    <controller type='pci' index='1' model='pcie-root-port'>
      <model name='pcie-root-port'/>
      <target chassis='1' port='0x8'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x0' multifunction='on'/>
    <controller type='pci' index='2' model='pcie-root-port'>
      <model name='pcie-root-port'/>
      <target chassis='2' port='0x9'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x1'/>
    <controller type='pci' index='3' model='pcie-root-port'>
      <model name='pcie-root-port'/>
      <target chassis='3' port='0xa'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x2'/>
    <controller type='pci' index='4' model='pcie-root-port'>
      <model name='pcie-root-port'/>
      <target chassis='4' port='0xb'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x3'/>
    <controller type='pci' index='5' model='pcie-root-port'>
      <model name='pcie-root-port'/>
      <target chassis='5' port='0xc'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x4'/>
    <controller type='pci' index='6' model='pcie-root-port'>
      <model name='pcie-root-port'/>
      <target chassis='6' port='0xd'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x5'/>
    <controller type='pci' index='7' model='pcie-root-port'>
      <model name='pcie-root-port'/>
      <target chassis='7' port='0xe'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x6'/>
    <controller type='virtio-serial' index='0'>
      <address type='pci' domain='0x0000' bus='0x02' slot='0x00' function='0x0'/>
    <controller type='sata' index='0'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x1f' function='0x2'/>
    <interface type='bridge'>
      <mac address='52:54:00:29:a4:a9'/>
      <source bridge='br0'/>
      <model type='virtio-net'/>
      <address type='pci' domain='0x0000' bus='0x01' slot='0x00' function='0x0'/>
    <serial type='pty'>
      <target type='isa-serial' port='0'>
        <model name='isa-serial'/>
    <console type='pty'>
      <target type='serial' port='0'/>
    <channel type='unix'>
      <target type='virtio' name='org.qemu.guest_agent.0'/>
      <address type='virtio-serial' controller='0' bus='0' port='1'/>
    <input type='mouse' bus='ps2'/>
    <input type='keyboard' bus='ps2'/>
    <hostdev mode='subsystem' type='pci' managed='yes'>
      <driver name='vfio'/>
        <address domain='0x0000' bus='0x01' slot='0x00' function='0x0'/>
      <rom file='/mnt/user/isos/vbios/EVGA GeForce RTX 2060 Super SC Ultra Gaming (90.06.44.C0.1B - 2019.07.02).rom'/>
      <address type='pci' domain='0x0000' bus='0x04' slot='0x00' function='0x0'/>
    <hostdev mode='subsystem' type='pci' managed='yes'>
      <driver name='vfio'/>
        <address domain='0x0000' bus='0x01' slot='0x00' function='0x1'/>
      <address type='pci' domain='0x0000' bus='0x05' slot='0x00' function='0x1' multifunction='on'/>
    <hostdev mode='subsystem' type='pci' managed='yes'>
      <driver name='vfio'/>
        <address domain='0x0000' bus='0x01' slot='0x00' function='0x2'/>
      <address type='pci' domain='0x0000' bus='0x05' slot='0x00' function='0x2'/>
    <hostdev mode='subsystem' type='pci' managed='yes'>
      <driver name='vfio'/>
        <address domain='0x0000' bus='0x01' slot='0x00' function='0x3'/>
      <address type='pci' domain='0x0000' bus='0x05' slot='0x00' function='0x3'/>
    <hostdev mode='subsystem' type='usb' managed='no'>
        <vendor id='0x0738'/>
        <product id='0x1733'/>
      <address type='usb' bus='0' port='1'/>
    <hostdev mode='subsystem' type='usb' managed='no'>
        <vendor id='0x1038'/>
        <product id='0x0210'/>
      <address type='usb' bus='0' port='2'/>
    <memballoon model='none'/>


Each "Subsystem" I found (4, exactly), I modified each 'address' line to correspond - for me! - to be my Graphics Card, and as shown on the video that SpaceInvaderOne gave earlier.


I installed the VirtIO drivers, but still no change. So I don't know what to do. There's too much lag.


Any ideas? Advices?


Thanks a lot

Edited by cbeitel
Link to comment

Hi! Thanks for your reply.


I tried the plugin 'Tips & Tweaks' and effectively the CPU Governor was set to Power Saving

So I changed to Performance and rebooted unRAID but, no changes...


So, I've done these changes:

1. under CPU Pinning I isolated the first Core (0-8) as it was told me that this one was used bu unRAID

2. created a new VM from scratch, with i440fx & OVMF. I've added 3 cores (1-9 / 2-10 / 3-11) and 8 GB of RAM and I installed it without any passthrough (i watched a 3 years old SpaceInvaderOner video (in 2 parts) about installing a Windows 10 Gaming VM), then installed all the drivers and finally do the passthrough

3. in Win10, I updated the system and Windows Update installed the nVidia 456.71 Driver (the first one officialy available for passthrough). And the VM seems responsive. It's a good starting test.

4. Now I will try some games I regularly play of, and give here some news by editing this topic. I cross my fingers to expect getting the perfs as on a bare PC.


See you later. C.

Edited by cbeitel
Link to comment
  • 2 weeks later...

Hi all!

Thanks @surferjsmc for the advice. I updated the nVidia drivers with the one I found, such as 466.11.


So, my unRAID is NOT working as I would like to. After some hours, the entire system was lagging and was not usable. I Had to reboot unRAID to gain some smooth. But yet again, after some hours, it was lagging. It's not a 'stable' system for me and I don't want to reboot it every 2 hours. It's useless... and when I was under the Win10 VM, I had a big loss of FPS: under a bare computer, i could play with 120 FPS on WoW and 70 FPS on TD2. But in the Win10 VM, i could play only with 80/90 FPS on WoW and only 40/35 FPS on TD2. And I didn't know why!


So, I changed my mind and made some changes about the configuration :

- motherboard: still the same (MSI B360 Gaming Plus)

- RAM: still the same (64 GB)

- CPU: changed to a Core i5 8600 (6 cores / 6 threads)

- SSDs: still the same (4x Samsung QVO 2 TB)

- NVMe: changed to a KINGSTON_SA1000M8240G (SATA NVMe)

- Graphics Card: changed from the EVGA RTX 2060 Super SC Ultra Gaming to the EVGA GTX 1060 SC Gaming 6 GB

- unRAID on USB Stick Lexar 16 GB 3.0

-> unRAID only for standard VMs, such as Linux (desktop, Internet, etc.) and Windows (create some private game servers only (to play at home)), and at last MacOS with the GTX PassThrough'ed'.


The re-installation was simple and unRAID seems to be OK. The VT/d is enabled and the array is configured to use one SSD as Parity.

But, I still have some problems. I was unable to extract the vBios with the @SpaceInvaderOne script. I always had an error like "input/output error". The script asked me to be sure that the GC was configured in VFIO (it is!) and the server reboot (it was, twice!) and still no possible extraction. So, fortunately, I kept a ROM file obtained with GPU-Z when I was under Windows 10. Phew! I think I will use it for MacOS... and that's my second problem: I can't install it on unRAID!

I installed the macinabox (and followed the SPO YT Vid!) and... no way... when I launch the WebGUI of the 'macinabox Docker', it says:



The libvirtd service does not appear to be installed. Install and run the libvirtd service to manage virtualization on this host.

Could not detect a default hypervisor. Make sure the appropriate QEMU/KVM virtualization packages are installed to manage virtualization on this host.

A virtualization connection can be manually added via File->Add Connection


Note that I followed the instructions to create a new connection but it's not working. It says:


Unable to connect to libvirt qemu:///system.

Verify that the 'libvirtd' daemon is running.

Libvirt URI is: qemu:///system

Traceback (most recent call last):
  File "/usr/local/share/virt-manager/virtManager/", line 922, in _do_open, data)
  File "/usr/local/share/virt-manager/virtinst/", line 153, in open
    conn = libvirt.openAuth(self._open_uri,
  File "/usr/lib/python3.8/site-packages/", line 104, in openAuth
    if ret is None:raise libvirtError('virConnectOpenAuth() failed')
libvirt.libvirtError: Failed to connect socket to '/var/run/libvirt/libvirt-sock': No such file or directory

It is strange because the directory /var/run/libvirt/ and the file are here!


I followed some tutos to try to resolve my problems about libvirt/libvirtd, but nothing worked. And unRAID, although based on Debian, can't launch the SYSTEMCTL command because it is not a valid command. And no posts are available about 'service' or 'systemctl' and how to get rid of.


So, today, I start to wonder if these are unRAID issues, compatibility problems with my hardware, or if I am simply unlucky but I'm going to loose patience about this system. For me, it's not as stable as it was said to be. I can't use it as I would like to. So, many help needed please!



And if you ask about the other hardware I used before: the Core i9 9900K is now mounted on a new motherboard MSI MPG Z390 Gaming Plus with only 16 GB 2400 MHz, running Windows 10 21H1 updated and with the 466.11 nVidia Drivers and all is going fine and smooth... I will keep this configuration for Gaming and Multimedia only.



Thanks a lot for your help.

Edited by cbeitel
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.