I lost my VM GPU after installing 2nd GPU


4 posts in this topic Last Reply

Recommended Posts

Hi All,

My System Devices List no longer shows my Nividia 1030 card after I installed a 710 Nvidia card for the purpose of seeing my UnRaid OS in GUI mode on the same monitor connected to the UnRaid OS server machine.  My 1030 card was perfectly running my Ubuntu VM after I set it up using the SpaceInvader One  Vbios Dump script.

 

The screen capture below shows the 1030 card errors I get in my VFIO PCI log. The ERROR reads: "Vendor:Device #### not found at ####. Unable to bind device."  One error is for the GPU and the other error is for the Audio on the GPU.  In short, the 710 card has bumped out my 1030 card from my UnRaid OS.  What is the correct way to install a 710 Card when there is already a 1030 Card installed on the motherboard to support an Ubuntu VM setup as a passthrough?

 

image.png.df8f91bd67d72ccabb63dd7da0e6dae6.png

 

System Info:

SuperMicro X10SRH-CF Motherboard

128GB ECC RAM

Intel Xeon E5-2640 v3 CPU

UnRaid OS v6.9.2

Nvidia GT1030 GPU passthrough for my Ubuntu VM

Nvidia 710 GPU for my UnRaid OS in GUI Mode

Noctua Fans

Seagate 18TB Hard Drives

Edited by slipstream
Link to post

Can somebody in the community please post the UnRaid OS command I need to type into the terminal  so I can see a list of the graphic cards I have installed on the motherboard.  I need a way of confirming why my UnRaid OS is ignoring my 1030 card which is connected to the 16x PCI-E GPU slot on the motherboard.

 

System Info:

SuperMicro X10SRH-CF Motherboard

128GB ECC RAM

Intel Xeon E5-2640 v3 CPU

UnRaid OS v6.9.2

Nvidia GT1030 GPU passthrough for my Ubuntu VM

Nvidia 710 GPU for my UnRaid OS in GUI Mode

Noctua Fans

Seagate 18TB Hard Drives

Link to post

If the card isn't showing in System Devices, then Unraid can't see it (and the 

lspci

command would show the same thing.

 

Since it's not being passed to the OS, you need to investigate why in the BIOS (like is the slot getting disabled because of another device installed?)  On the other hand if it does show in System Devices, then it's possible the mobo / BIOS changed the IOMMU grouping for it.

Link to post
Posted (edited)

Thanks Squid for the post.  You are correct. Using the lspci command gave me a list that matches the System Devices list which includes no 1030 card.  As a troubleshooting test I removed the 710 card and after bootup my System Devices correctly shows my 1030 card as shown in screen capture below:

 

image.thumb.png.f7a6b3325db9e1ca0d92a8a3c13baeba.png

However, my 1030 card does not successfully boot the UnRaid OS to GUI mode. it freezes after the last three lines of code appear shown below:

 

overlayfs: upper fs does not support xattr, falling back to index=off and metacopy=off.

overlayfs: upper fs does not support xattr, falling back to index=off and metacopy=off.

vfio-pci 0000:41:00.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem

 

In contrast, if I plug in my 710 card my UnRaid OS boots straight into GUI mode without freezing with the three lines shown above.

 

Is it a good idea to delete the  /config/vfio-pci.cfg file on the flashdrive?  I am guessing maybe the SpaceInvader One VFIO Dump Script I applied has messed up my VFIO-PCI file and maybe if I delete this file it will magically rebuild itself to correctly show two Nvidia cards in my System Devices list.   Is this a good idea or bad idea?

 

As for the motherboard BIOS i have the parameters set in the same way they were before I introduced the 710 card.

 

Any opinion welcome.  Thank you for your time.

 

 

 

Edited by slipstream
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.