[solved] GPU driver problem

Recommended Posts

Posted (edited)

Gpu: AMD FirePro W7000


Hi guys, 


I have a strange problem with my Win 10 VM. It is running fine, but after I have installed the GPU driver it won't boot again. It just got stuck in Windows loading screen. (with no entry in eventvwr)

Windows does start in safe mode.

After removing the driver it is working again.


So I assume that there is something wrong with the driver, but I have no clue what since I tried a few different AMD driver versions. 

The GPU is many years old, maybe I should try installing an older driver? 





Edited by Dorsch
Link to comment
  • 2 months later...

These are the VM logs:

-overcommit mem-lock=off \
-smp 8,sockets=1,dies=1,cores=4,threads=2 \
-uuid 08a281b1-851d-458e-5a2f-999d80ed1f5f \
-display none \
-no-user-config \
-nodefaults \
-chardev socket,id=charmonitor,fd=31,server,nowait \
-mon chardev=charmonitor,id=monitor,mode=control \
-rtc base=localtime \
-no-hpet \
-no-shutdown \
-boot strict=on \
-device ich9-usb-ehci1,id=usb,bus=pci.0,addr=0x7.0x7 \
-device ich9-usb-uhci1,masterbus=usb.0,firstport=0,bus=pci.0,multifunction=on,addr=0x7 \
-device ich9-usb-uhci2,masterbus=usb.0,firstport=2,bus=pci.0,addr=0x7.0x1 \
-device ich9-usb-uhci3,masterbus=usb.0,firstport=4,bus=pci.0,addr=0x7.0x2 \
-device ahci,id=sata0,bus=pci.0,addr=0x3 \
-device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x4 \
-blockdev '{"driver":"file","filename":"/mnt/disk1/domains/Clover NVME/spaces_win_clover.img","node-name":"libvirt-1-storage","cache":{"direct":false,"no-flush":false},"auto-read-only":true,"discard":"unmap"}' \
-blockdev '{"node-name":"libvirt-1-format","read-only":false,"cache":{"direct":false,"no-flush":false},"driver":"raw","file":"libvirt-1-storage"}' \
-device ide-hd,bus=sata0.2,drive=libvirt-1-format,id=sata0-0-2,bootindex=1,write-cache=on \
-netdev tap,fd=33,id=hostnet0 \
-device virtio-net,netdev=hostnet0,id=net0,mac=52:54:00:c6:79:e4,bus=pci.0,addr=0x2 \
-chardev pty,id=charserial0 \
-device isa-serial,chardev=charserial0,id=serial0 \
-chardev socket,id=charchannel0,fd=34,server,nowait \
-device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=org.qemu.guest_agent.0 \
-device usb-tablet,id=input0,bus=usb.0,port=1 \
-device 'vfio-pci,host=0000:04:00.0,id=hostdev0,bus=pci.0,multifunction=on,addr=0x5,romfile=/mnt/disk1/isos/vbios/W7000 UEFI.rom' \
-device vfio-pci,host=0000:04:00.1,id=hostdev1,bus=pci.0,addr=0x5.0x1 \
-device vfio-pci,host=0000:01:00.0,id=hostdev2,bus=pci.0,addr=0x8 \
-device usb-host,hostbus=3,hostaddr=2,id=hostdev3,bus=usb.0,port=2 \
-device usb-host,hostbus=1,hostaddr=3,id=hostdev4,bus=usb.0,port=3 \
-device usb-host,hostbus=2,hostaddr=4,id=hostdev5,bus=usb.0,port=4 \
-sandbox on,obsolete=deny,elevateprivileges=deny,spawn=deny,resourcecontrol=deny \
-msg timestamp=on
2021-07-16 18:16:00.036+0000: Domain id=6 is tainted: high-privileges
2021-07-16 18:16:00.036+0000: Domain id=6 is tainted: host-cpu
char device redirected to /dev/pts/0 (label charserial0)
2021-07-16T18:16:29.018191Z qemu-system-x86_64: warning: guest updated active QH



No, I haven't bound it to VFIO, should I?

There is a green circle next to the checkbox which says "Kernel driver in use: vfio-pci"


To clarify: 

It does boot when AMD drivers are not installed in the Windows VM

It doesn't boot after the drivers have been installed


Do I need to configure anything else for "headless" unraid? 




Link to comment
22 hours ago, Dorsch said:

No, I haven't bound it to VFIO, should I?

If you don't bind it, unRAID will use it for it's terminal output. Did you connect a monitor to the GPU to test this? As long as unRAID ist using the GPU, you can't use it in the VM. So your main target should be to boot unRAID gpu-less.

  • Thanks 1
Link to comment

Okay, I will test it.

I had a monitor connected and it switched from unraid terminal output to the VM output after I have started the VM

(that is also what I would expect Unraid to do)


and then check the vfio entry for gpu in the VM form? Or is this not neccessary?

Link to comment

Seems to be working now. I have bound the GPU to VFIO and have restarted Unraid with no effect. 

After further research I read about similar problems with AMD GPUs and that it might be a solution to switch machine to Q35 and that worked. 


Everything is now fine I guess - many thanks mgutt

Link to comment
  • Dorsch changed the title to [solved] GPU driver problem

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.