Install Boot Loop - Ubuntu VM Nvme Passthrough

Recommended Posts

Hi there, 


I'm fairly new to Unraid, Im trying to create a Ubuntu VM on a separate NVME  detached from the array.


I have passed through the NVME drive to the VM and successfully installed Ubuntu however once it's installed I can't seem to boot from it. It constantly cycles back to the install. 

Once I remove the installation media from the VM settings (expecting the boot laser to kick in), I just get 'no bootable media' or just a shell prompt.  I have tried using SeaBios, reinstalling a number of times with no joy.


Anyone have any ideas?





Edited by Ainsley
Link to comment

Since you don't have a primary vDisk specified, did you configure a boot disk anywhere? I'm not sure whether you need to enter the OVMF Setup and select the NVMe device as the boot disk or specify it in the XML, but it needs to be configured somewhere.


Edited by John_M
Link to comment

It isn't something I do, myself, as I don't need the extra speed and I don't want to dedicate a whole SSD to one VM but have you tried entering the OVMF Setup and trying to select it there, as I suggested? I believe any edits you make there will be stored in the emulated nvram associated with the VM. If that doesn't work then you will need to edit your XML. Perhaps this thread will point you in the right direction.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.