Can't split pcie usb card to its own IOMMU group

Recommended Posts

Hi everyone, 


I am trying to pass through a PCIe USB card to my VM, and I am following Spaceinvader One's guide, which is super helpful. The problem now is I can't split the PCIe USB card to its own IOMMU group, and checkbox in front of it is gray out so I can't bind vfio at boot.


What I have tried so far:
+ In the VM setting, I tried all three PCIe ACS override modes (downstream, multi-function, both), and none of the modes will split my PCIe USB card to its own IOMMU group.
+ I try all different available PCIe slot on my motherboard, all the same thing.
+ The card itself is good. If I plug a mouse receiver/USB disk into my PCIe card, the unraid will pick up correctly. 


Here is some screenshot:




Here is my diagnostics:


Here card link from amazon (in review someone has successfully made it card within unraid):


The video tutorial I am following:


Edited by JeffSuperb
typo & reformat
Link to comment

Sometimes it's impossible to have things in separate iommu groups, this depends on the motherboard/cpu.

If you can't get the card to be in its iommu group even with the acs override I would suggest to try to change the pci slot and try again with acs.


Nevermind...I just read that you tried all the slots :(

Edited by ghost82
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.