PCIe ACS erzwingen: IOMMU Gruppen lassen sich nicht trennen/auflösen


31 posts in this topic Last Reply

Recommended Posts

Hmmm,

 

sorry, dass ich mich so spät zurückmelde, aber habe gerade beruflich viel um die Ohren und dann nur noch gelegentlich Zeit und Muße zu testen....

 

Das Thema "IOMMU-groups splitten" habe ich, glaube ich, mittlerweile einigermaßen durchstiegen oder doch nicht? Momentan sind die Geräte in einer IOMMU-Gruppe, die sich einen PCIe-Controller teilen (RTFM). Offenbar muss ich mit meinem MB noch auf ein Update hoffen, dass ich die IOMMU-Gruppen weiter aufteilen kann?

Schade, dass die Soundkarte der iGPU in einer anderen, von Unraid blockierten, IOMMU-Gruppe gebunden ist.

 

Was ich gar nicht verstehe:

Ich bekomme die Unraid-GUI nicht auf dem angeschlossenen Monitor angezeigt (iGPU über MB an HDMI), ein Freund mit gleicher! Hardware schon!!

Ein Freund hat die gleiche Hardware (ASUS ROG STRIX B460-H GAMING + Intel Core i7 10700K LGA 1200 16MB Cache 3,8GHz retail + 64 GB RAM + gleicher USB-Stick) und denselben BIOS-Stand (1602). Wir haben Punkt für Punkt die BIOS-Einstellungen abgeglichen, alles identisch. Ich habe zur Fehlereinkreisung ALLE Geräte abgesteckt (SATA, NVME, PCIe-Karten). Er nutzt noch Unraid 6.8.X, ich bin mit 6.9.1 gestartet (jetzt 6.9.2).

 

Wenn ich Unraid ohne Gui-Modus starte ("Unraid OS"), kann ich über das Netz die GUI erreichen und an dem angeschlossenen Monitor erscheint ein Shell-Login. --> gut!

Wenn ich Unraid mit Gui-Modus starte "Unraid OS mit GUI" erscheint an dem angeschlossenen Monitor ein blinkender Cursor in der oberen linken Ecke, keine GUI. --> ungut!

Über ALT+F1-6 erreiche ich dann doch einen Shell-Login, ALT+F>6 blinkender Cursor in der oberen linken Ecke.

Jetzt kommt's: Mein genannter Freund (gleiche Hardware) bootet "Unraid OS mit GUI" auf seiner Kiste und hat die Unraid-Gui auf dem angeschlossenen Bildschirm!??

Weil uns nichts anderes mehr einfiel, haben wir meinen Rechner über seinen USB-Stick gebootet, aber leider auch ohne Erfolg.

 

Ich bin ratlos. Bei gleicher Hardware unterschiedliche Ergebnisse?

Für mich ist die (baremetall) GUI-Anzeige wichtig, ich möchte einen bestehenden PC ersetzen, nicht noch einen dazu stellen. Mein Ziel bleibt, die Unraid GUI über die iGPU an einen am MB angeschlossenen Monitor auszugeben und vorgesehene VMs über eine RTX2070 bzw. GT710-4H-SL-2GD5 mit je eigenem Monitor zu bespielen.

 

Hat jemand von euch vielleicht dankenswerterweise noch eine Idee, wo ich ansetzen könnte, oder sollte ich mir ein anderes MB zulegen?  Ahhhrrrrgggg!

 

 

Danke vielmals!!

 

 

Link to post

@ jj1987:

Quote

Hast du denn den iGPU-Treiber in Unraid installiert/geladen?

Das Problem hatte ich nämlich anfangs mit meinem Ryzen auch. Erst nachdem die Treiber installiert waren, funktionierte auch der GUI-Modus (ich Nachhinein ja auch irgendwo logisch)

Sorry, aber wie geht das? Wo ist der "Knopf"?

 

Danke!

Link to post

In den Apps findest du das Plugin Intel GPU Top. Das installieren und du hast den Treiber drauf. Dann im GUI Modus neu starten.

 

Alternativ im Ordner modprobe.d auf dem Stick eine leere Datei mit dem Namen i915.conf erstellen. Dann installiert Unraid den Intel Treiber beim Booten.

Link to post
19 minutes ago, mgutt said:

In den Apps findest du das Plugin Intel GPU Top. Das installieren und du hast den Treiber drauf. Dann im GUI Modus neu starten.

 

Alternativ im Ordner modprobe.d auf dem Stick eine leere Datei mit dem Namen i915.conf erstellen. Dann installiert Unraid den Intel Treiber beim Booten.

Yeahhhhh! 🙏🙏🙏

You made my day!

Jetzt ist unRAID für mich nutzbar. danke!!!

Ich habe den Eindruck, das wäre einen Eintrag in den FAQs wert! In meiner Wahrnehmung gibt es viele Nutzer, die an diesem Punkt verzweifeln.

 

Beste Grüße

Nebrius

 

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.