all docker containers lists version “not available” under update


47 posts in this topic Last Reply

Recommended Posts

Posted (edited)
30 minutes ago, cinereus said:

Thanks all, this fixed it. What will cause a proper fix to be made so I can remove the line from my gofile? Do I have the upgrade the unraid version entirely?

 

Look at @HyperV's post above:

The problem is that the format changed slightly in the docker repository, v.6.9.2 has adjusted to it, but if you are using older versions you will have to manually fix the file (and keep the bit in the go file).

Edited by servidude
Link to post
47 minutes ago, cinereus said:

So until I upgrade to 6.9.2 or higher? 

Yes, you will probably have to remove this part from the go-file once you update.

Link to post
On 5/14/2021 at 12:30 PM, HyperV said:

I had exactly the same issue and could not find any solutions on the forum or the internet. So I did some digging myself and found the cause of the issue. The docker update check script gets the remote digest of the latest tag from the docker repository via a header called 'Docker-Content-Digest'. The script checks for this header with a case-sensitive regex pattern. Manually querying the docker hub registry gives me a header called 'docker-content-digest' (mind the casing). The docker hub registry must have recently changed the casing of this header, because it broke for me in the last 24 hours. I'm running on Unraid 6.8.3 still, so I'm not 100% sure if this issue also exists in 6.9.x.

If you feel up to it, you could quite easily fix this yourself until there is a real fix. I'll describe the steps below:

Open file: /usr/local/emhttp/plugins/dynamix.docker.manager/include/DockerClient.php

Go to line 457.

There you should look for the text:


@Docker-Content-Digest:\s*(.*)@

and replace it with:


@Docker-Content-Digest:\s*(.*)@i


Save the file.

This will make the header check case-insensitive and should make it work again.

Thank you HyperV for the fix .. I had the same issue where all were 'not available' after a simple restart ... changed DNS/forced updates etc but no win .... this worked a treat

 

If it help anybody else, in nano (editor) you can goto line 457 to add the magic 'i' above by typing adding the line to the command ... for example in a terminal window type

 

nano +457 /usr/local/emhttp/plugins/dynamix.docker.manager/include/DockerClient.php

 

Thanks once again HyperV

Link to post

I tried the manual fix...  But it isn't working.  I still get the "not available"..

Is there some sort of service I have to restart?

                preg_match('@Docker-Content-Digest:\s*(.*)@i', $reply, $matches);

 

That's what's in my file...

Link to post
On 5/14/2021 at 7:30 AM, HyperV said:

I had exactly the same issue and could not find any solutions on the forum or the internet. So I did some digging myself and found the cause of the issue. The docker update check script gets the remote digest of the latest tag from the docker repository via a header called 'Docker-Content-Digest'. The script checks for this header with a case-sensitive regex pattern. Manually querying the docker hub registry gives me a header called 'docker-content-digest' (mind the casing). The docker hub registry must have recently changed the casing of this header, because it broke for me in the last 24 hours. I'm running on Unraid 6.8.3 still, so I'm not 100% sure if this issue also exists in 6.9.x.

If you feel up to it, you could quite easily fix this yourself until there is a real fix. I'll describe the steps below:

Open file: /usr/local/emhttp/plugins/dynamix.docker.manager/include/DockerClient.php

Go to line 457.

There you should look for the text:


@Docker-Content-Digest:\s*(.*)@

and replace it with:


@Docker-Content-Digest:\s*(.*)@i


Save the file.

This will make the header check case-insensitive and should make it work again.

 

Thanks, @HyperV!

 

Sorry for being such a newb, but I don't see an emhttp dir in my /usr/local/ directory.

I'm using Krusader. Perhaps I should be in the console instead?

 

Link to post
26 minutes ago, kennelfort said:

Sorry for being such a newb, but I don't see an emhttp dir in my /usr/local/ directory.

I'm using Krusader. Perhaps I should be in the console instead?

Probably.

I guess that in Krusader your are looking at the /usr/local/ of the Krusader docker itself, unless you specified a path to the Unraid linux.

Link to post
1 minute ago, ChatNoir said:

Probably.

I guess that in Krusader your are looking at the /usr/local/ of the Krusader docker itself, unless you specified a path to the Unraid linux.

Ok, Thanks!

Link to post
1 hour ago, kennelfort said:

 

Thanks, @HyperV!

 

Sorry for being such a newb, but I don't see an emhttp dir in my /usr/local/ directory.

I'm using Krusader. Perhaps I should be in the console instead?

 

Don't use Krusader just use terminal. 

Link to post
21 minutes ago, sage2050 said:

I applied hyperv's fix but im still getting "not available" on all my dockers. Do I need to do anything after I edit the file?

I had the same thing yesterday..  But when I checked it this AM..  It was now working...  So it just took some time for me..  I don't know why..  Maybe someone with more knowledge can explain it or show how to get the fix to work immediately ..

 

 

Link to post
On 5/14/2021 at 1:30 PM, HyperV said:

I had exactly the same issue and could not find any solutions on the forum or the internet. So I did some digging myself and found the cause of the issue. The docker update check script gets the remote digest of the latest tag from the docker repository via a header called 'Docker-Content-Digest'. The script checks for this header with a case-sensitive regex pattern. Manually querying the docker hub registry gives me a header called 'docker-content-digest' (mind the casing). The docker hub registry must have recently changed the casing of this header, because it broke for me in the last 24 hours. I'm running on Unraid 6.8.3 still, so I'm not 100% sure if this issue also exists in 6.9.x.

If you feel up to it, you could quite easily fix this yourself until there is a real fix. I'll describe the steps below:

Open file: /usr/local/emhttp/plugins/dynamix.docker.manager/include/DockerClient.php

Go to line 457.

There you should look for the text:


@Docker-Content-Digest:\s*(.*)@

and replace it with:


@Docker-Content-Digest:\s*(.*)@i


Save the file.

This will make the header check case-insensitive and should make it work again.

You are a Lifesaver! Was looking for a Solution for days!

Link to post
On 5/14/2021 at 6:30 AM, HyperV said:

I had exactly the same issue and could not find any solutions on the forum or the internet. So I did some digging myself and found the cause of the issue. The docker update check script gets the remote digest of the latest tag from the docker repository via a header called 'Docker-Content-Digest'. The script checks for this header with a case-sensitive regex pattern. Manually querying the docker hub registry gives me a header called 'docker-content-digest' (mind the casing). The docker hub registry must have recently changed the casing of this header, because it broke for me in the last 24 hours. I'm running on Unraid 6.8.3 still, so I'm not 100% sure if this issue also exists in 6.9.x.

If you feel up to it, you could quite easily fix this yourself until there is a real fix. I'll describe the steps below:

Open file: /usr/local/emhttp/plugins/dynamix.docker.manager/include/DockerClient.php

Go to line 457.

There you should look for the text:


@Docker-Content-Digest:\s*(.*)@

and replace it with:


@Docker-Content-Digest:\s*(.*)@i


Save the file.

This will make the header check case-insensitive and should make it work again.

 

Thanks, this fixed it for me! The next time I reboot (eventually) will be to install v6.9.2, or whatever is available at the time, so that will be my "permanent" fix. This got it going for now though.

 

Link to post

Thank you @HyperV!! After a couple days of frustration thinking it's always DNS I found your fix here with the good ol' search button and it worked like a champ. I cannot upgrade to 6.9.2 because of macvlan crashes in the docker implementation :( 

Link to post
On 5/14/2021 at 4:30 AM, HyperV said:

I had exactly the same issue and could not find any solutions on the forum or the internet. So I did some digging myself and found the cause of the issue. The docker update check script gets the remote digest of the latest tag from the docker repository via a header called 'Docker-Content-Digest'. The script checks for this header with a case-sensitive regex pattern. Manually querying the docker hub registry gives me a header called 'docker-content-digest' (mind the casing). The docker hub registry must have recently changed the casing of this header, because it broke for me in the last 24 hours. I'm running on Unraid 6.8.3 still, so I'm not 100% sure if this issue also exists in 6.9.x.

If you feel up to it, you could quite easily fix this yourself until there is a real fix. I'll describe the steps below:

Open file: /usr/local/emhttp/plugins/dynamix.docker.manager/include/DockerClient.php

Go to line 457.

There you should look for the text:


@Docker-Content-Digest:\s*(.*)@

and replace it with:


@Docker-Content-Digest:\s*(.*)@i


Save the file.

This will make the header check case-insensitive and should make it work again.

Registered a forum account here just to say Thank you! I was bouncing between all sorts of threads thinking it was a Pi-hole or DNS issue, but this fixed it immediately. 

Link to post
Posted (edited)

Can anyone that has upgraded to 6.9.2 confirm that upgrading alone is supposed to fix the problem? I just upgraded and the problem persists.

 

EDIT:  Fixed.  In case anyone else comes along and has the same question / issue that I did, hit the "Check for Update" button on your docker tab. (Not sure if it matters if the dockers are running or not, mine were when I hit it)

Edited by cambion
Link to post
On 5/21/2021 at 7:35 PM, cambion said:

Can anyone that has upgraded to 6.9.2 confirm that upgrading alone is supposed to fix the problem? I just upgraded and the problem persists.

 

EDIT:  Fixed.  In case anyone else comes along and has the same question / issue that I did, hit the "Check for Update" button on your docker tab. (Not sure if it matters if the dockers are running or not, mine were when I hit it)

I had the same question.  Appreciate the tip

Link to post

Okay, I made this change last week and it fixed the problem, but here we are the week after and it appears my edit (as well as the original file I saved as a backup) are gone.

 

So, I guess I'm soliciting advice for the "best way" to get dynamix docker manager to not update it's config?  Change everything in .../include to read-only, perhaps?

 

I'm still on 6.8.3 and currently have no plans to upgrade to 6.9, although I might consider it after .10 comes out and I see how the upgrade goes for others.

 

TIA

Mike

Link to post
38 minutes ago, kcgodwins said:

Okay, I made this change last week and it fixed the problem, but here we are the week after and it appears my edit (as well as the original file I saved as a backup) are gone.

Let me guess, you didn't do the "go" file edit, and you rebooted?

Link to post
Posted (edited)
32 minutes ago, jonathanm said:

Let me guess, you didn't do the "go" file edit, and you rebooted?

Didn't see that part; I'll do that as well.

 

Thanks

Edited by kcgodwins
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.