Constant reading from array disk (without any visible reason)

Recommended Posts



I have tried to solve this problem few days now without any luck.

Problem is that something reads from array (disk 1) constantly but I can't figure out which and why.

Speed is about 400-600 kb/s and total reads count is + 4 000 000 in less than day.

I think that problem is somehow VM or server load related.


I have 2 ubuntu VM's which are installed to cache drive and anything from config won't point to array disks.

I have installed file activity plugin but it won't show any file usage during reads.

I also have tried to stop all dockers without luck.


Any idea what can cause this or how to troubleshoot?

Link to comment

dynamix.cache.dirs.plg - 2020.08.03


This will constantly read from the drives in order to try and keep the drives spun down by keeping the contents in memory, but this shouldn't actually be your issue.


What you want to do is stop all your containers one at a time to see when the reading stops.


Link to comment

I uninstalled that plugin and reads from disk1 has been dropped from millions to ~ 17 000 in last 10 hour window. That might actually was the problem.


Still unclear to me why that reading happened only at one disk in array and constantly. I haven't use spin down feature at long time. All my disk spin 24/7 nowadays.

That same disk1 is only one which have reads (17 000) during past 10 hours. All other disks sit at 0 reads and writes. So there might be still some issue but situation is way better than earlier! Thanks to you Squid!



Edited by VoNpo
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.