[Support] Machinaris - Chia cryptocurrency farming + Plotman plotting + Unraid WebUI


Recommended Posts

Btw there's a typo in the wiki:

If you have an existing private key mnemonic, place in a text file here /mnt/user/appdata/machinaris/mnenomic.txt as a single line with spaces between the words. If you don't have an existing private key, don't worry! You'll be able to generate a new key on first run.

 

Should be:

If you have an existing private key mnemonic, place in a text file here /mnt/user/appdata/machinaris/mnemomic.txt as a single line with spaces between the words. If you don't have an existing private key, don't worry! You'll be able to generate a new key on first run.

Edited by badi95
Link to comment

so my problem doesn't go

 

i delet the database and resync it tooks 5 days... 

But nothing changed, my Windows pc connect right to the pool, but the unraid docker container not.

Next step was I connect to pool in unraid docker container, yes this work, but now I had on windows client two pooladress

and on the first are all plots and on the new 0 plotts

 

Next I changed on windows the first (old) to self plotting, its done, but all pool plots are at this.

 

I don't know what must I do that unraid docker is the only one and realy farming works with all my pool plotts that I made

 

Link to comment
On 7/17/2021 at 4:37 PM, Spazhead said:

open unriad terminal wondow, type the following

 

mkdir /mnt/ram

mount -t tmpfs -o size=115G tmpfs /mnt/ram/

 

add path into your machinaris setup

1695345998_ScreenShot2021-07-17at10_33_59AM.thumb.png.02946a05e0f4573ab4405a1c72ffe6f8.png

 

inside machinaris plotting config

 

293656087_ScreenShot2021-07-17at10_36_43AM.png.2d3b0612de0d495925beec1ccb295031.png

 

Thanks this worked! However, I have now been running with this for 3-4 days and I am getting "out of memory" crashed in unRAID. Even after a fresh reboot I will get errors once I start plotting again. Any ideas?

Link to comment
1 minute ago, gperpetuo said:

Hi!

Is it possible to see "Launcher Id" on Machinaris so that I can add it to the pool ap on my phone? (space pool ap)

 

Yes, under Settings --> <server name> - chia will says "Launcher ID: xxx"

Edited by mrbusiness
Link to comment
14 hours ago, mrbusiness said:

 

Thanks this worked! However, I have now been running with this for 3-4 days and I am getting "out of memory" crashed in unRAID. Even after a fresh reboot I will get errors once I start plotting again. Any ideas?

 

well i don;t know how much memory you have, but try the minimum 110G, and make sure nothing else is running, VM/Dockers etc

that use memory up.

 

Link to comment

I'm still not clear on Solo plotting vs self pool. Please correct me if I am wrong: solo plotting is the old way. No portable plot. farmer_pk and pool_pk are uncommented. pool_contract_address is commented.

 

2. Self pooling plots are portable.
Not a part of any pool, but can join one with these plots. farmer_pk and pool_contract_address uncommented. Pool_pk commented....

 

Is this accurate?

Link to comment
44 minutes ago, DoeBoye said:

I'm still not clear on Solo plotting vs self pool. Please correct me if I am wrong: solo plotting is the old way. No portable plot. farmer_pk and pool_pk are uncommented. pool_contract_address is commented.

 

2. Self pooling plots are portable.
Not a part of any pool, but can join one with these plots. farmer_pk and pool_contract_address uncommented. Pool_pk commented....

 

Is this accurate?

 

Absolutely!  You really want to be creating the new portable plots now, not the original solo plots anymore. As you say, with portable plots (new pool_contract_address, not the old pool_pk) you can either:

  • Self pool. When you win a block, you will earn all the XCH rewards OR
  • Join a pool and get consistent XCH farming rewards. The average returns are the same,
    but it is much less volatile. You can easily switch pools without having to re-plot.

With portable plots you can switch between both selections, if you change your mind, above using the same plots.

  • Thanks 1
Link to comment
On 7/17/2021 at 4:37 PM, Spazhead said:

open unriad terminal wondow, type the following

 

mkdir /mnt/ram

mount -t tmpfs -o size=115G tmpfs /mnt/ram/

 

add path into your machinaris setup

1695345998_ScreenShot2021-07-17at10_33_59AM.thumb.png.02946a05e0f4573ab4405a1c72ffe6f8.png

 

inside machinaris plotting config

 

293656087_ScreenShot2021-07-17at10_36_43AM.png.2d3b0612de0d495925beec1ccb295031.png

Is it normal for the plugin Fixcommonproblems to put an error on this? or did i do something?

 

Skjermbilde 2021-07-24 133222.png

Link to comment
14 hours ago, Malixk said:

Is it normal for the plugin Fixcommonproblems to put an error on this? or did i do something?

 

Skjermbilde 2021-07-24 133222.png

This is what I used:

 

mkdir /tmp/ramdisk
mount -t tmpfs -o size=115G tmpfs /tmp/ramdisk

 

If Machinaris is running before you create the ram disk, you need to restart the Machinaris container, to make sure it picks it up correctly.

 

You can console into the container and type "df -h" to verify paths, drive size, and how much room is available.

 

Filesystem      Size  Used Avail Use% Mounted on

tmpfs           120G     0  120G   0% /plotting2

 

 

Edited by hogfixer
added stuff
  • Like 1
Link to comment
10 hours ago, hogfixer said:

This is what I used:

 

mkdir /tmp/ramdisk
mount -t tmpfs -o size=115G tmpfs /tmp/ramdisk

 

If Machinaris is running before you create the ram disk, you need to restart the Machinaris container, to make sure it picks it up correctly.

 

You can console into the container and type "df -h" to verify paths, drive size, and how much room is available.

 

Filesystem      Size  Used Avail Use% Mounted on

tmpfs           120G     0  120G   0% /plotting2

 

 

everything is gold. just that error. any differences between mnt and tmp, other then location? Thanks.

 

Also as a fot note, just moved my nvme (temp) to Unassigned Devices from pool devices, holy moly i went from 200+ min too 80 min. what the balls.

Link to comment
On 7/14/2021 at 3:27 PM, guy.davis said:

 

Yes, full sync from an initial state can take a while.  Check the status on the Network | Connections page.  Also, you can try adding an introducer there too from this list.

Think i missed this.. im still waiting for sync although i have had to power down for maintenance a couple of times.  how can i add these?  at the moment I am at Current Blockchain Status: Syncing 570076/628847.  what i have noticed is this time and date  Time: Wed Jul 14 2021 11:53:33 BST  is this normal is there where i have synced to?

Link to comment
5 hours ago, SohailS said:

Think i missed this.. im still waiting for sync although i have had to power down for maintenance a couple of times.  how can i add these?  at the moment I am at Current Blockchain Status: Syncing 570076/628847.  what i have noticed is this time and date  Time: Wed Jul 14 2021 11:53:33 BST  is this normal is there where i have synced to?

 

Network | Connections page.  Notice the 'Add Connection' button.

 

image.thumb.png.d7d0c28ad363128dc6a1a937ad4163bb.png

 

Yes, Blockchain sync occurs from start of the chain on March 19th and runs forward to current datetime.  So your sync is a couple of weeks back.   Hope this helps.

 

 

Link to comment

I am still struggling with getting online with pool plotting.

 

I started plotting to a different directory for my pool plots so I can keep them separated.  Original plots were saved to /plots and new ones are going to /chiapoolplots

 

My /chiapoolplots share has files in it (14 in there currently) so the plotter is working and the share is mapped correctly..

 

Under farming tab none of these plots is showing up (only older plots)

 

Under settings/farming I have:  

 

plot_directories:
  - /plots
  - /chiapoolplots

 

What am I missing?

Link to comment
14 minutes ago, guy.davis said:

 

Network | Connections page.  Notice the 'Add Connection' button.

 

image.thumb.png.d7d0c28ad363128dc6a1a937ad4163bb.png

 

Yes, Blockchain sync occurs from start of the chain on March 19th and runs forward to current datetime.  So your sync is a couple of weeks back.   Hope this helps.

 

 

Ah Thanks I see.

 

I have now added this Node for Europe: node-eu.chia.net:8444.

 

what are the Introducers? it wont let me add any of those.

 

also is there a way to do more than one plot at a time with Mad Max? 

Link to comment
4 hours ago, Ystebad said:

I am still struggling with getting online with pool plotting.

 

I started plotting to a different directory for my pool plots so I can keep them separated.  Original plots were saved to /plots and new ones are going to /chiapoolplots

 

My /chiapoolplots share has files in it (14 in there currently) so the plotter is working and the share is mapped correctly..

 

Under farming tab none of these plots is showing up (only older plots)

 

Under settings/farming I have:  

 

plot_directories:
  - /plots
  - /chiapoolplots

 

What am I missing?

 

Hi!  Please ensure you have one environment variable named 'plots_dir' with key=plots_dir and with value=/plots:/chiapoolplots.   Then restart the Machinaris container.  Hope this helps.

Link to comment
1 hour ago, guy.davis said:

 

Hi!  Please ensure you have one environment variable named 'plots_dir' with key=plots_dir and with value=/plots:/chiapoolplots.   Then restart the Machinaris container.  Hope this helps.

 

Don't see this anywhere in my config.  I assume this would go in the farming section.

 

Sorry to be dense, but unclear on the syntax: So insert this into my farming yaml?:

 

plots_dir:

  key=plots_dir

  value=/plots:/chiapoolplots

 

(will this also keep farming my old plots?  I thought this is what   plot_directories: under harvester was setting).

Link to comment
Posted (edited)
9 minutes ago, Ystebad said:

 

Don't see this anywhere in my config.  I assume this would go in the farming section.

 

Sorry to be dense, but unclear on the syntax: So insert this into my farming yaml?:

 

plots_dir:

  key=plots_dir

  value=/plots:/chiapoolplots

 

(will this also keep farming my old plots?  I thought this is what   plot_directories: under harvester was setting).

 

Hi, since we're on the Unraid forum, I assume we're talking about a Machinaris install on Unraid.  If so, you can access your Machinaris container environment variables on the Unraid Admin UI | Docker | select Machinaris from list, choose Edit:

 

image.thumb.png.ca3c12208a7f70ce29dd134a4cc22e6a.png

Hope this helps!

 

Edited by guy.davis
Link to comment
3 hours ago, guy.davis said:

 

Hi, since we're on the Unraid forum, I assume we're talking about a Machinaris install on Unraid.  If so, you can access your Machinaris container environment variables on the Unraid Admin UI | Docker | select Machinaris from list, choose Edit:

 

image.thumb.png.ca3c12208a7f70ce29dd134a4cc22e6a.png

Hope this helps!

 

AH!  I was trying to do everything from within the machinaris configuration settings from the webUI! Thank you so very much.

  • Like 1
Link to comment
13 hours ago, Michele Pietsch said:

--- Google translator
Hello :) I have a Windows 10 PC (mainnet fully synchronized)

How can I do that
blockchain_v1_mainnet.sqlite and blockchain_wallet_v1_mainnet_xxxxx.sqlite
copy to speed up syncing?
I've tried both files, but an error occurs

 

Hi, I haven't tried this myself, but heard from some it works.  Try copying the entire mainnet folder over from Windows and placing it here:  /mnt/user/appdata/machinaris/mainnet  Do that with the Machinaris container stopped, then restart.  I would take a backup of your existing /mnt/user/appdata/machinaris/mainnet folder before you do this though.

  • Thanks 1
Link to comment

Couple questions, maybe I missed it somewhere..

I have appx 900 plots using pool contract address and 400 old school...been replotting. The old school plots are on a Windows machine and pool plots on Unraid server using Machinaris to farm. Found out my windows machine was taking over a minute to verify proofs so it was pointless.  Anyways I set up Machinaris to access the windows shares, it recognized them fine and still less than a second access time. 

When I got the daily summary though it still showed only the pool plots even though in the Summary tab it shows all plots being scanned. Does this mean Machinaris will only do pools OR solo, not both?

Also found my first XFX proof since the above change but no XFX coin was "delivered". Not like its worth anything right now but still...

Any thoughts would be appreciated!

Link to comment
20 hours ago, guy.davis said:

 

Hi, I haven't tried this myself, but heard from some it works.  Try copying the entire mainnet folder over from Windows and placing it here:  /mnt/user/appdata/machinaris/mainnet  Do that with the Machinaris container stopped, then restart.  I would take a backup of your existing /mnt/user/appdata/machinaris/mainnet folder before you do this though.

--- Google translator
thanks, that's how it worked :D

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.