Parity disk has been disabled, what should I do?


9 posts in this topic Last Reply

Recommended Posts

Hello guys,

 

I just found my parity disk sdf has been disabled since midnight.

 

Here are the syslogs:

 

May 24 00:53:29 UNRAID kernel: ata6.00: exception Emask 0x10 SAct 0x1c00000 SErr 0x400000 action 0x6 frozen
May 24 00:53:29 UNRAID kernel: ata6.00: irq_stat 0x08000000, interface fatal error
May 24 00:53:29 UNRAID kernel: ata6: SError: { Handshk }
May 24 00:53:29 UNRAID kernel: ata6.00: failed command: WRITE FPDMA QUEUED
May 24 00:53:29 UNRAID kernel: ata6.00: cmd 61/40:b0:40:4c:af/05:00:ca:01:00/40 tag 22 ncq dma 688128 out
May 24 00:53:29 UNRAID kernel:         res 40/00:00:d0:55:af/00:00:ca:01:00/40 Emask 0x10 (ATA bus error)
May 24 00:53:29 UNRAID kernel: ata6.00: status: { DRDY }
May 24 00:53:29 UNRAID kernel: ata6.00: failed command: WRITE FPDMA QUEUED
May 24 00:53:29 UNRAID kernel: ata6.00: cmd 61/50:b8:80:51:af/04:00:ca:01:00/40 tag 23 ncq dma 565248 out
May 24 00:53:29 UNRAID kernel:         res 40/00:00:d0:55:af/00:00:ca:01:00/40 Emask 0x10 (ATA bus error)
May 24 00:53:29 UNRAID kernel: ata6.00: status: { DRDY }
May 24 00:53:29 UNRAID kernel: ata6.00: failed command: WRITE FPDMA QUEUED
May 24 00:53:29 UNRAID kernel: ata6.00: cmd 61/40:c0:d0:55:af/05:00:ca:01:00/40 tag 24 ncq dma 688128 out
May 24 00:53:29 UNRAID kernel:         res 40/00:00:d0:55:af/00:00:ca:01:00/40 Emask 0x10 (ATA bus error)
May 24 00:53:29 UNRAID kernel: ata6.00: status: { DRDY }
May 24 00:53:29 UNRAID kernel: ata6: hard resetting link
May 24 00:53:39 UNRAID kernel: ata6: softreset failed (1st FIS failed)
May 24 00:53:39 UNRAID kernel: ata6: hard resetting link
May 24 00:53:49 UNRAID kernel: ata6: softreset failed (1st FIS failed)
May 24 00:53:49 UNRAID kernel: ata6: hard resetting link
May 24 00:54:24 UNRAID kernel: ata6: softreset failed (1st FIS failed)
May 24 00:54:24 UNRAID kernel: ata6: limiting SATA link speed to 3.0 Gbps
May 24 00:54:24 UNRAID kernel: ata6: hard resetting link
May 24 00:54:29 UNRAID kernel: ata6: softreset failed (1st FIS failed)
May 24 00:54:29 UNRAID kernel: ata6: reset failed, giving up
May 24 00:54:29 UNRAID kernel: ata6.00: disabled
May 24 00:54:29 UNRAID kernel: ata6: EH complete
May 24 00:54:29 UNRAID kernel: sd 6:0:0:0: [sdf] tag#26 UNKNOWN(0x2003) Result: hostbyte=0x04 driverbyte=0x00 cmd_age=0s
May 24 00:54:29 UNRAID kernel: sd 6:0:0:0: [sdf] tag#26 CDB: opcode=0x35 35 00 00 00 00 00 00 00 00 00
May 24 00:54:29 UNRAID kernel: blk_update_request: I/O error, dev sdf, sector 0 op 0x1:(WRITE) flags 0x800 phys_seg 0 prio class 0
May 24 00:54:29 UNRAID kernel: sd 6:0:0:0: [sdf] tag#27 UNKNOWN(0x2003) Result: hostbyte=0x04 driverbyte=0x00 cmd_age=60s
May 24 00:54:29 UNRAID kernel: sd 6:0:0:0: [sdf] tag#27 CDB: opcode=0x8a 8a 00 00 00 00 01 ca af 5b 10 00 00 01 70 00 00
May 24 00:54:29 UNRAID kernel: blk_update_request: I/O error, dev sdf, sector 7695457040 op 0x1:(WRITE) flags 0x0 phys_seg 46 prio class 0
May 24 00:54:29 UNRAID kernel: md: disk0 write error, sector=7695456976

 

I referred some threads in the forum. And I am not sure if I should stop array and to rebuild the parity disk with the same hard disk or not.

 

Please kindly help check. Diagnostic file is attached. 

 

Thanks a lot!

 

Alex

unraid-diagnostics-20210524-2256.zip

Link to post
1 minute ago, trurl said:

No SMART for parity in those. Check connections and post new diagnostics.

 

My understanding is that since the disk is disabled so SMART is not available. Should I restart the array to get SMART back?

Link to post
7 minutes ago, rowid_alex said:

My understanding is that since the disk is disabled so SMART is not available.

That is a misunderstanding.

 

8 minutes ago, trurl said:

Check connections and post new diagnostics.

 

Link to post

SMART is still available for disable disks, but parity dropped offline, so there's no SMART, you should check/replace cables to rule since that looks more like a connection problem and them and post new diags.

Link to post
Just now, JorgeB said:

SMART is still available for disable disks, but parity dropped offline, so there's no SMART, you should check/replace cables to rule since that looks more like a connection problem and them and post new diags.

 

Understood. I will check the cable then. Thanks for the explaination.

Link to post
36 minutes ago, trurl said:

No SMART for parity in those. Check connections and post new diagnostics.

 

Hello I reboot the server and this time parity disk has SMART data. 

 

I found flag 0x000a UDMA CRC error count added one permanently. But everything else seems fine.

 

0x06  0x018  4               1  ---  Number of Interface CRC Errors

 

Please kindly suggest what should I do to enable the disk.

 

Thanks!

unraid-diagnostics-20210524-2352.zip

Link to post

BTW, I checked the location of the disk and it is connected to the SATA port on the motherboard directly. So it doesn't seems to be a cable issue...unless it happens the next time I think.

Link to post
13 minutes ago, rowid_alex said:

UDMA CRC error count added one permanently

That is a connection problem, usually a bad SATA cable, and consistent with how the disk dropped, so you should replace that before re-syncing parity.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.