[6.9.2] Upgraded from 6.8.3 to 6.9.2 and now Windows 10 Pro VM BSOD


Recommended Posts

I just upgraded from 6.8.3 to 6.9.2 and now my "main" Windows VM keeps crashing (blue screen of death, BSOD) about 2 minutes after the first user logs in.

 

I booted the VM into safe mode, downloaded BlueScreenView http://www.nirsoft.net/utils/blue_screen_view.html and used it to see that the cause is DRIVER_IRQL_NOT_LESS_OR_EQUAL 0x000000d1 and sometimes the "Caused By Driver" is ntoskrnl.exe (NT Kernel & System) and sometimes its ndis.sys (Network Driver Interface Specification).

 

I don't know the right way to fix this. I assume that there has been a KVM change in unRAID from 6.8.3 to 6.9.2 and now I need to update the VM drivers but I don't know which ones. My first through is the network driver due to ndis.sys being listed in the minidump, but running in safe mode with network connectivity seems to work fine with the VirtIO network driver.

 

Any suggestions or directions on something to try would be appriciated.

Link to comment

A little bit more data...

 

I've updated all VirtIO drivers to 0.1.185 and still got BSOD.

 

I removed the bridge interface from the VM and still get the BSOD.

 

I waited at the log in screen and also still get the BSOD (no user logged in).

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.