Upgraded HW from 2014, old USB failed to boot in new HW and other fun swap stuff


Recommended Posts

Posted (edited)

Old HW 

unRAID Pro: 6.8.3 | FLASH: Sandisk 4GB Cruiser Fit | CASE: Rosewill RSV-L4411 | MOBO: Asus Sabertooth 990FX R2.0 | CPU: AMD FX-8320 Black | MEMORY: Crucial 8GB DDR3 10600 ECC x3 | VIDEO: XFX ATI HD5450 PCIe | AUDIO:  Casatunes XLI (Creative HD PCIe) | CACHE|APP DRIVE: Samsung 860 EVO 1TB SSD | PARITY DRIVE: 4TB WD Red| DATA DRIVES: 5x2TB WD Greens + 2x4TB WD Reds

 

New HW: Asus TUF x570-Plus, Ryzen 9 3900X, Kingston 64GB ECC Ram, Nvidia P400 GPU, M.2 Samsung cache drive (and original plan, a new Samsung Bar Plus USB)

 

I spent the last week or so running new hardware on trial key, mem testing, passing through GPU to plex (Nvidia Drivers) etc.. Just general checking/running.

 

Started the swap last night, moved all the new HW into my rack case, with the original Flash drive.  But no matter what, I received the below error while booting. (I tried bring the flash drive up to my PC, scanning it, putting it in a different usb slot)  I don't boot UEFI, and one thing I did was take off the - in the EFI name folder, but I forgot to try UEFI on the original usb.  I didn't want to boot UEFI so I guess I just forgot.

 

image.thumb.png.43984ccfead1cfaf6f9e23da85deae8f.png

 

So, next... Since I'd tested the new Samsung in the temporary case, and had planned to swap it in to replace my old USB anyway (just not at first boot). I restored my flash backup onto it and attempted to boot it.  All I got was that standard message saying it's not a boot device, replace it and hit any key to continue. (this USB had booted on this MB earlier in the week).  I did run make_bootable.  I tried reformatting it, reinstalling unRAID, running make_bootable and nothing. It just would not boot.

 

Now, while not in full panic, I was not in a good place.  I've got random flash drives all over so I took the one I was actually using with the trial key (USB 2.0 8gb PNY of unknown age but certainly not new)  which already had 6.9.2 on it.  I just copied my backed up config folder over to it. This drive booted up, and of course had my pro.key.  I validated all the drives were in the right slots, transferred the license to this old PNY drive, and started the array.

 

On the bright side, the physical swap went smooth, everything came up (dockers/ VMs).  My windows 10 VM seems to even still be activated which I won't complain about. :)  Parity check is at 83% with no errors.  So that is all good

 

Googling the above Initramfs above wasn't turning up much help at all, and since it was pretty late (11-11:30pm) I didn't spend a ton of time trying to figure it out.  I don't think I had any hits with that error from this forum unfortunately.

 

In any case, I'm running on all new HW with an unknown old PNY USB drive.  Once the Parity check finishes, and everything it stable, I'll swap my old SSD cache drive onto the M.2. and be done for a while I hope.

 

Edited by Dmtalon
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.