My Unraid Server seems to be crashing


Kaneda215

7 posts in this topic Last Reply

Recommended Posts

Hello,

 

I apologize if I'm posting in the wrong section. Last week my server started to run very slowly:

1. Accessing files from two separate computers was extremely laggy and seemed to take an uncharacteristically long time. Additionally, my weekly parity-check was taking 10x times longer than normal (~2Mbs down from ~120Mbs). 

2. I already tried to swap out power cables and SATA connectors. 

3. I ran a SMART extended self-test in safe mode, for both Disk1 and my Parity. The Parity Completed without error.

4. Disk1 "Last SMART test result: Errors occurred - Check SMART report."

 

WD Red 4TB NAS Hard Drive - 5400 RPM Class SATA 6 Gb/s 64MB Cache 3.5 Inch - WD40EFRX

 

I've included the SMART report. I further apologize if I'm not giving you the appropriate amount of information... I'm very inexperienced when it comes to servers. Thank you SO much for any help you can provide. I've lost many hours trying to trouble shoot this server and am not getting anywhere. 

WDC_WD40EFRX-68N32N0_WD-WCC7K5SJE416-20210607-0654.txt

Link to post

Your description doesn't sound like what is usually meant when someone says "crash".

 

20 minutes ago, Kaneda215 said:

appropriate amount of information

Instead of SMART report, post Diagnostics (Tools - Diagnostics). It includes SMART for all attached disks, syslog, many other details about your hardware and configuration that give a much more complete understanding of your situation so we can make better informed recommendations.

Link to post

Constructor - thanks for the swift response and willingness to help.

 

19 minutes ago, trurl said:

Your description doesn't sound like what is usually meant when someone says "crash".

Sorry about the misnomer... I wasn't sure how to succinctly describe that a drive (or both... or some other hardware related issue) was seemingly failing. 

 

I've attached the diagnostic.

oriserver-diagnostics-20210607-2117.zip

Edited by Kaneda215
Link to post
10 hours ago, Kaneda215 said:

Constructor - thanks

Newbie 😉 - your welcome

 

Based on the failed extended SMART test for disk1 you should replace disk1. Unfortunately, it looks like parity was replaced (by same disk?) and now it considers parity to be a new disk and is waiting for you to rebuild parity. But you need to instead rebuild disk1 onto a new disk.

 

Does that accurately describe your situation? If so it will require some trickery to get Unraid to rebuild disk1 from that parity, assuming it is even valid.

 

Is there any important data on disk1?

 

 

Link to post

Since you have only 1 data disk parity is effectively a mirror so if that parity is indeed valid it would be possible to recover the data directly from parity instead of bothering with a rebuild of disk1 to a new disk.

 

In any case, let us know if I have anything wrong or tell us more details about what you have done.

 

And wait for further advice before doing anything.

Link to post

While troubleshooting, I removed the Parity and for whatever reason when I reconnected it, Disk1 tried to rewrite. I'm sure it was user error. Therefore, to my knowledge, the Parity drive is completely wiped... which sucks because Disk1, with the data, is so slow that it'd take >1 month to rebuild.

 

Thankfully, I backed up the server's contents to a completely separate external HDD. Sounds like disk1 is trash - hopefully WD will replace it under warranty.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.