[SOLVED] Cannot resolve Stale Configuration error


22 posts in this topic Last Reply

Recommended Posts

Hi all,

 

For the past 3-4 months whenever I restart my server I get a "Stale Configuration" at the bottom left of my screen and all array drives are unassigned. Pool drives retain their configuration.  I re-assign the drives and the array starts just fine. The problem is a Parity-Check in my case takes almost 48 hours, not to mention the extra strain it puts on the drives. 

 

I've read all forum posts on the subject, and tried every possible combination of creating a new config and re-ckecking parity I could think of, but to no avail.

 

Can somebody show me the correct procedure to get rid of this problem?

 

Thanks in advance,

 

Vassilis

 

PS : Please find attached my diagnostics zip.

thales-diagnostics-20210610-1836.zip

Link to post

There's problem reading super.dat, that's where the disks assignments are stored:

 

Jun  6 13:57:59 Thales kernel: kernel read not supported for file /config/super.dat (pid: 14582 comm: modprobe)
Jun  6 13:57:59 Thales kernel: read_file: read error 22
Jun  6 13:57:59 Thales kernel: md: could not read superblock from /boot/config/super.dat
Jun  6 13:57:59 Thales kernel: md: initializing superblock

 

Try recreating the flash drive, if that fails use a different one.

Link to post

Hi Jorge,

 

I've tried both recreating the old one and using a brand new flash drive but I keep getting the same error at startup (Stale Configuration) and all array disks show as unassigned.

Attached you will find my diagnostics after I replaced the flash drive and restarted a couple of times.

 

In  a separate, but possibly related issues, my server has been acting up lately and at random intervals it hangs unexpectedly, usually during the night. I mean IPMI shows the server as running but the server is completely unresponsive to web gui, ssh, smb etc.

 

Any help would be greatly appreciated.

 

Thanks,

 

Vassilis 

 

thales-diagnostics-20210616-1423.zip

Link to post

Other than that I'm not seeing anything out of the ordinary, can you try without the Nvidia driver? One of just two google results I found about that error mentioned an issue with that.

Link to post

It's starting to drive me crazy !

Stopped the array, removed nVidia driver, rebooted the server - Stale Config .... Created new config, without keeping any assignments, re-assigned all drives, restarted the array choosing 'parity is correct'. Rebooted the server - Stale Config again !!!

 

Attaching new diagnostics for whatever it's worh ....

thales-diagnostics-20210616-1621.zip

Link to post

Stale config happens when there is a mismatch between the super.dat and super.old configuration files.

Take the USB drive out and run a file check on a Windows machine to see if there is any file corruption and repair as needed.

 

Link to post

Just did the file check. No errors found, as per the attached screenshot.

 

It is a brand new USB (Samsung Bar Plus 32 GB) which I created using the Unraid tool, from a flash backup I took just before I shut down the server to replace it.

 

 

Unraid Flash Check.png

Link to post

Normally super.dat is created as soon as you make a (new) array assignment.

 

You can delete all super.* files and restart the system.

It requires you to do a new array assignment. When done and the array is started, check the presence of both super.dat and super.old

 

Link to post

Thank you for your help.

I followed your suggestions (deleted both super.* from /config) and then restarted. After startup I created a new config from the Tools menu, and reassigned all drives. Then I started the array again, selecting "Parity is valid" option. I checked and found that super.dat was recreated in the /config folder of the USB Flash.

 

I will restart the server again to see what happens and let you know...

 

Link to post
Posted (edited)

Finally ! I restarted this morning and all disk assignments were present.

Thanks a lot for all your guys help. Really appreciate it.

 

Best,

Vassilis

 

PS : How can I add SOLVED to the topic ?

Edited by VassilisA
Link to post
8 minutes ago, VassilisA said:

Finally ! I restarted this morning and all disk assignments were present.

Don't understand how redoing the flash drive didn't help and this did, but hey, glad it's solved.

 

9 minutes ago, VassilisA said:

PS : How can I add SOLVED to the topic ?

You can just edit the title, but I can do it this time.

Link to post
  • JorgeB changed the title to [SOLVED] Cannot resolve Stale Configuration error

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.