Strom sparen mit powertop


140 posts in this topic Last Reply

Recommended Posts

2 minutes ago, mgutt said:

Ich sehe gerade, dass du einen AMD Server hast. Meine Aussage bezieht sich auf Intel.

hm? bin seit Februar bei Intel.

 

Zum Rest habe ich nun mal andere Erfahrungen gemacht. Genug Off-Topic.

 

Link to post
  • Replies 139
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Ich habe deinen Beitrag mal hier hin verschoben.     Vom Prinzip irrelevant. Also eben das was powertop immer zurückgibt. Relevant ist das die Ausgabe, wenn du nur "powertop" ausführs

Posted Images

8 minutes ago, sonic6 said:

hm? bin seit Februar bei Intel.

Ich teste die Tage noch mal powersave. Evtl hat sich ja was seit 6.9 geändert.

Link to post

danke euch beiden, powertop -autotune brachte schon mal 6 Watt, jetzt schaue ich was noch geht. Habe z.B. im Bios die Soundkarte Deaktiviert und suche jetzt welche Optionen noch gehen. Beim Spinndown habe ich immernoch das Problem das eine Platte nicht Schlafen will (appdata etc. sind bereits verschoben)

Link to post
  • 2 weeks later...

Hallo zusammen,

ich habe meinen HP Microserver Gen8 mal abgelöst da er mir doch zuviel Saft gezogen hat.

Nun habe ich ein ganz neues System gebaut.

Ich habe ein C246M-WU4-CF mit einem I3-9100 und 32 GB RAM am Start. 😃

Für meine Zwecke satt und genug.

Ich bin nun beim optimieren und habe mal powertop --auto-tune ausgeführt.

Hier kommt als Ergebnis:

 

grafik.png.0c306e3d5db99d3962cb6d537b190ba6.png

 

Leider reichen meine Kentnisse noch nicht soweit das ich das interpretieren kann.

Die Googletreffer machen mich leider auch nicht schlauer.

 

Kann mich da einer aufklären was das heißt?

 

Beste Grüße

Averall

Edited by Averall
Link to post

Ich habe deinen Beitrag mal hier hin verschoben.

 

8 minutes ago, Averall said:

Kann mich da einer aufklären was das heißt?

 

Vom Prinzip irrelevant. Also eben das was powertop immer zurückgibt. Relevant ist das die Ausgabe, wenn du nur "powertop" ausführst. Dann kannst du die C-States einsehen. Optimal wäre C8/C9 beim Package. C2/C3 ist normal, wenn man Karten verbaut hat. Gar keine C-State Aktivität wäre schlecht.

 

Ansonsten wäre dann noch ein Messgerät hilfreich, damit man überhaupt weiß wie viel der Server gerade verbraucht:

https://gutt.it/strommessgeraete-im-test/

Link to post

Hallo zusammen,

@mguttdanke fürs Verschieben hierhin.

 

Habe jetzt mal die letzten 2 Tage alle Beiträge hier gelesen und versucht das Beste für mein neues System zu finden. Das Experimentieren hat was länger gedauert.

 

Folgendes Ergebnis habe ich jetzt dank der Beiträgen hier hinbekommen:

Im Durchschnitt zieht sich die Kiste im Idle jetzt 18 W. Allerdings habe ich das mit einem auf Tasmota geflashten Nous A1 Stecker gemessen. Den habe ich auch mit einer 60 Watt Lampe kalibriert. Allerdings "springt" der Wert auch mal zwischen 16 - 23 Watt

hin und her. Ich werde noch mal mit einer Fritz Steckdose den Wert erneut messen, da ich nicht weiß ob das der Stecker ist oder das System.

grafik.png.21450b95099786256477a72cad70b9a6.png

 

Powertop gibt jetzt das bei mir aus (HDD´s schlafen) :

 

grafik.thumb.png.f91857bbfec998f017f2d8c77a6daa5e.png

grafik.png.8b8d4bea5871d33a8932b9ae151589b4.png

 

Ich versuche weiterhin ob man das noch tiefer bekommt. Nach euren Kommentaren hier sollte noch was bei den Pkg Werten drin sein.

Vielen Dank für die ganzen Hinweise in dem Thread. Jetzt aber ab an den Grill und das Bier.

 

Beste Grüße und kühles Wochenende

Averall

Link to post
7 minutes ago, Averall said:

Powertop gibt jetzt das bei mir aus (HDD´s schlafen) :

 

Da lässt sich ablesen, dass deine CPU gerade was zu tun hat. Schließlich steht bei all deinen Kernen eine Mindestaktivität von 5% und C10 erreicht auch nur 70%. 

 

Wenn ich powertop starte, dann habe ich über 90% C10 pro Kern, erreiche aber wegen der 10G Karte nur C2 beim Package:

image.png.cdf705365ca93affad2c81c9deeb69e6.png

 

 

 

Link to post

Hi noch mal,

@mgutt oh hatte noch den Docker Dienst eingeschaltet.

 

Jetzt sieht das so aus wenn ich den Docker und VM Dienst beende:

 

grafik.png.40b53e09a3eec58f733e0415ff793d76.png

 

grafik.thumb.png.74bda508580c2cb3b1f9f95e2478364a.png

grafik.png.47c29dcf19e1b0f38c0ca87cd566e9ad.png

 

Aber so tief wie bei @mgutt gehen meine Kerne nicht 🤨

Also wenn die nicht Skat spielen wüsste ich nicht was die da machen ??

In der Unraid Übersicht springt zwischen durch auch immer mal ein oder mehrere Kerne auf 27 oder gar 50% und geht direkt wieder runter.

Das System kann doch nicht mit sich selber so beschäftigt sein.

Puh, da muss ich mal gucken was das System da noch treibt.

 

Beste Grüße

Averall

Link to post
1 minute ago, Averall said:

Puh, da muss ich mal gucken was das System da noch treibt.

Hattest du bei Docker evtl die erweiterte Ansicht aktiv? Dann hast du deswegen eine dauerhafte Last.

 

Ansonsten mal im WebTerminal "htop" ausführen und schauen was da ständig aktiv ist.

Link to post
  • mgutt changed the title to Strom sparen mit powertop
  • 4 weeks later...

Hallo zusammen, 

 

ich habe aktuell ein Test Board für einen Backup Server am laufen. Ein Biostar J1800MH2 mit einem Intel J1800 Dual Core. 
 

Habe hier viel gelesen und komme nicht unter 14Watt mit den Platten spindown. Powertop Ausgabe hab ich mit angehangen.

 

Bekomme ich so ein Low Power Board eigentlich noch tiefer oder ist das schon das Maximum was man rausholen kann? Im Bios sieht es leider etwas mager aus was die C-State Einstellungen angeht. Kann auf C7 gehen, bringt aber nix im Vergleich zu C3 
 

Was meint ihr? 
 

EDIT: 

 

Hab gestern Parity Check laufen gelassen und heute früh nochmal aufs System geschaut. Im Dashboard kommt es mir so vor als wenn die CPU Anzeige weiter runter geht und nicht mehr so viel ausschlägt wie gestern Abend. Zudem liegt der Wert jetzt bei 13,3 Watt. CPU steht übrigens in Tips und Tweaks auf Performance, was gestern im verglich zu On Demand oder PowerSafe keinen messbaren Unterschied bewirkt hat. 
 

FF18BEC4-33BC-4B2E-A84B-39973384C561.jpeg

6D4CB0A9-6DE3-4575-B2F4-92CBD36A5422.jpeg

Edited by DiaboloVampire
Neue Erkenntnisse
Link to post
16 hours ago, DiaboloVampire said:

Im Bios sieht es leider etwas mager aus was die C-State Einstellungen angeht. Kann auf C7 gehen, bringt aber nix im Vergleich zu C3

C7 musst du schon einstellen. Aktuell erreichst du gar keinen C-State. Links das Package ist wichtig, nicht die Kerne. Allerdings hast du so viel Last auf den Kernen, dass das auch logisch ist. Zwei Kerne stehen auf 40% active. Das Package kann C2 usw erst erreichen wenn die CPU nichts macht.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.