VM templates will not update settings when changed

Recommended Posts



I'm having an issue where I cannot change any of the settings in my VM template unless I manually update the XML itself. I even tried creating a new VM and it won't accept my inputs, it only goes to the default settings. I'm running UnRAID 6.9.2. Anyone else having this issue? any input would be appreciated! I haven't had the best of luck with these forums and I'm attempting to give this another shot here.



Link to comment
  • 3 weeks later...
  • 2 months later...

@acurunner79 may try wiping your system libvirt.img where the data is stored and reboot (or restart VM Service)


location is usually /mnt/user/system/libvirt/




depending now how far you are and your VM's are updated, make your notes how you did set them up cause you have to redo them, after wiping just add a VM with the same settings and point to the existing image (usually vdisk1.img)






On 6/17/2021 at 5:34 AM, acurunner79 said:

I haven't had the best of luck with these forums and I'm attempting to give this another shot here.


On 6/25/2021 at 8:25 PM, acurunner79 said:

It's been over a week.... Are these forums just not the place to ask questions? 


and may consider leaving these things out as may some ppl dont like this attitude, as you see on the amount on help here its not common ...

  • Thanks 1
Link to comment

@alturismo Thank you for the help! I've done the steps above, I can now create a vm and the setting do save.


After doing so, my vm will not allow vnc to open. It starts up and then the vnc connect disconnects. I also tried tried using my gpu which seems to saves but when I try to run my vm I get an error "internal error: qemu unexpectedly closed the monitor"


Screen Shot 2021-09-08 at 3.13.07 PM.png

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.