[SUPPORT] DiamondPrecisionComputing - ALL IMAGES AND FILES


Recommended Posts

36 minutes ago, ainuke said:

Ok, did that, but now when I start sonarr or nzbget containers, I get "Execution Error   No such container"

Restart Gluetun and make sure that there aren't any errors staring up in the log. Then refresh the page and double check the nzbget and sonarr network settings.

 

Whenever you change settings in a template it recreates the container with a new GUID. Since sonarr and nzbget use that to determine the container to use as the network connection.

Link to comment
On 8/21/2021 at 10:27 AM, Opawesome said:

@biggiesize, if I may: how about adding a choice like "other/custom" in the dropdown menu for the "VPN_SERVICE_PROVIDER" variable in your docker container template, as well as adding the variable "OPENVPN_CUSTOM_CONFIG" right after, with a nice little description such as "OPTIONAL if you selected 'other/custom' in the 'VPN_SERVICE_PROVIDER' list above, please enter here the path to the .ovpn configuration file that Gluetun should use. https://github.com/qdm12/gluetun/wiki/Openvpn-file" ?

Just wanted to let you know that the dev added a "custom" option for "VPN_SERVICE_PROVIDER". I plan on getting the template updated with it and any relevant variables sometime today.

Link to comment
11 hours ago, biggiesize said:

Restart Gluetun and make sure that there aren't any errors staring up in the log. Then refresh the page and double check the nzbget and sonarr network settings.

 

I'm getting a "ERROR http server: http: Server closed" error when restarting Gluetun, with both the other containers stopped.

Link to comment
1 hour ago, biggiesize said:

Can you post the Gluetun conatiner log after you try to start it?

Sorry, that was my bad. I was looking too far up in the log; the http server error was from when it was shutting down.

Everything is working now, although to get access to the containers' UI (NZBGet and Sonarr) on the LAN, their ports need to be manually specified/added. From the description, I thought that was the purpose of ADDIDIONAL_FIREWALL_INPUT_PORTS?

Not really worried about it at this point, given that it's functional; just curious.

 

Thanks for your help!

 

Link to comment
29 minutes ago, ainuke said:

Sorry, that was my bad. I was looking too far up in the log; the http server error was from when it was shutting down.

Everything is working now, although to get access to the containers' UI (NZBGet and Sonarr) on the LAN, their ports need to be manually specified/added. From the description, I thought that was the purpose of ADDIDIONAL_FIREWALL_INPUT_PORTS?

Not really worried about it at this point, given that it's functional; just curious.

 

Thanks for your help!

 

Just a little back story... Originally for containers on Unraid, you only needed to add the individual ports as variables to the VPN container that were needed. This was largely a security flaw within the iptables settings (the rules VPNs use to determine if traffic is allowed). With that flaw patched you still need to specify the ports in individual variables so that Unraid knows which ports go to which containers but you also add the list of ports to the ADDITIONAL_FIREWALL_INPUT_PORTS so that the VPN itself know it's OK to allow those ports to communicate into the VPN tunnel.

Also, just a heads up, I will be pushing a new template out either today to tomorrow (hopefully) that includes lots of changes. You may have to re-enter info as some of the variable names have changed to align with the dev's variable names. I understand this might break users configurations temporarily but I would rather rip the band-aid off sooner than later. :)

Link to comment

New Topic:

Is there an easy way to run speedtest through the GluetunVPN?

Using LibreSpeed(linuxserver), if I use the "--network=container:GluetunVPN" parameter, the container fails to install with an error

Error response from daemon: conflicting options: port publishing and the container type network mode

 

I just picked this speed test docker on a whim; if there's a better way to speed test the vpn, I'd be happy to hear it. I'm currently getting <1Mb/s on NBZGet, which is waaaay down from where it was a month ago. Speed to the server minus VPN is 900Mb/s.

Trying to track down what's changed...

Link to comment
1 hour ago, ainuke said:
Error response from daemon: conflicting options: port publishing and the container type network mode

That looks like 2 issues. 

  1. Make sure you set the Network Type drop-down to None
  2. Looks like the port used for LibreSpeed is either attached to both the LibreSpeed and Gluetun containers or the port is already in use by something else.

The simplest way is to open the terminal for the container and run the below command

 

apk add speedtest-cli && speedtest-cli

 

image.png.d90f77a772f367cccf9fcdca613a7520.png

Link to comment
2 hours ago, biggiesize said:

That looks like 2 issues. 

  1. Make sure you set the Network Type drop-down to None
  2. Looks like the port used for LibreSpeed is either attached to both the LibreSpeed and Gluetun containers or the port is already in use by something else.

The simplest way is to open the terminal for the container and run the below command

 

apk add speedtest-cli && speedtest-cli

 

image.png.d90f77a772f367cccf9fcdca613a7520.png

Thank you so much!

All sorted now.

 

Erik

Link to comment
  • 3 weeks later...

Hi everyone!

 

last update broke my instance of Gluetun, the container seems in shutdown loop: 

 

2021/09/30 09:59:05 INFO Shutdown successful
2021/09/30 09:59:06 ERROR cannot read servers from file: json: cannot unmarshal string into Go struct field ProtonvpnServer.protonvpn.servers.exit_ip of type []net.IP

2021/09/30 09:59:06 INFO Shutdown successful
2021/09/30 09:59:06 ERROR cannot read servers from file: json: cannot unmarshal string into Go struct field ProtonvpnServer.protonvpn.servers.exit_ip of type []net.IP

2021/09/30 09:59:06 INFO Shutdown successful
2021/09/30 09:59:07 ERROR cannot read servers from file: json: cannot unmarshal string into Go struct field ProtonvpnServer.protonvpn.servers.exit_ip of type []net.IP

2021/09/30 09:59:07 INFO Shutdown successful
2021/09/30 09:59:09 ERROR cannot read servers from file: json: cannot unmarshal string into Go struct field ProtonvpnServer.protonvpn.servers.exit_ip of type []net.IP

2021/09/30 09:59:09 INFO Shutdown successful
2021/09/30 09:59:11 ERROR cannot read servers from file: json: cannot unmarshal string into Go struct field ProtonvpnServer.protonvpn.servers.exit_ip of type []net.IP

2021/09/30 09:59:11 INFO Shutdown successful
2021/09/30 09:59:15 ERROR cannot read servers from file: json: cannot unmarshal string into Go struct field ProtonvpnServer.protonvpn.servers.exit_ip of type []net.IP

2021/09/30 09:59:15 INFO Shutdown successful
2021/09/30 09:59:22 ERROR cannot read servers from file: json: cannot unmarshal string into Go struct field ProtonvpnServer.protonvpn.servers.exit_ip of type []net.IP

2021/09/30 09:59:22 INFO Shutdown successful
2021/09/30 09:59:35 ERROR cannot read servers from file: json: cannot unmarshal string into Go struct field ProtonvpnServer.protonvpn.servers.exit_ip of type []net.IP

2021/09/30 09:59:35 INFO Shutdown successful
2021/09/30 10:00:01 ERROR cannot read servers from file: json: cannot unmarshal string into Go struct field ProtonvpnServer.protonvpn.servers.exit_ip of type []net.IP

2021/09/30 10:00:01 INFO Shutdown successful
2021/09/30 10:00:53 ERROR cannot read servers from file: json: cannot unmarshal string into Go struct field ProtonvpnServer.protonvpn.servers.exit_ip of type []net.IP

2021/09/30 10:00:53 INFO Shutdown successful
2021/09/30 10:01:54 ERROR cannot read servers from file: json: cannot unmarshal string into Go struct field ProtonvpnServer.protonvpn.servers.exit_ip of type []net.IP

2021/09/30 10:01:54 INFO Shutdown successful
2021/09/30 10:02:54 ERROR cannot read servers from file: json: cannot unmarshal string into Go struct field ProtonvpnServer.protonvpn.servers.exit_ip of type []net.IP

 

Anyone else with the same issue?

 

Link to comment

Hej, I have the same problem, Gluetun was updated shortly and now I am getting the following error messages.

 

2021/09/30 12:41:29 ERROR cannot read servers from file: json: cannot unmarshal string into Go struct field ProtonvpnServer.protonvpn.servers.exit_ip of type []net.IP

2021/09/30 12:41:29 INFO Shutdown successful
2021/09/30 12:43:03 ERROR cannot read servers from file: json: cannot unmarshal string into Go struct field ProtonvpnServer.protonvpn.servers.exit_ip of type []net.IP

2021/09/30 12:43:03 INFO Shutdown successful

 

Link to comment
5 minutes ago, biggiesize said:

The dev has rolled back the last change. You should be able to do a force update on the container and be moved working again.

 

It works also removing servers.json.

They already updated the :latest but even with the last commit I'm still facing the issue 

Link to comment

Hello all. Im trying to set up the container to work with ProtonVPN. There are a lot of config options in the container template; I dont know which are required or not. Im wanting to use the container as a proxy for certain browsers on some of my devices. I was hoping that I could use my local PiHole for DNS/Adblocking if at all possible. Anyone able to share a sanitised version of their config?Hello all. Im trying to set up the container to work with ProtonVPN. There are a lot of config options in the container template; I dont know which are required or not. Im wanting to use the container as a proxy for certain browsers on some of my devices. I was hoping that I could use my local PiHole for DNS/Adblocking if at all possible. Anyone able to share a sanitised version of their config?

Link to comment
9 hours ago, darrenyorston said:

Hello all. Im trying to set up the container to work with ProtonVPN. There are a lot of config options in the container template; I dont know which are required or not. Im wanting to use the container as a proxy for certain browsers on some of my devices. I was hoping that I could use my local PiHole for DNS/Adblocking if at all possible. Anyone able to share a sanitised version of their config?

Hello there :)

 

Other than the variables marked as required in the template, for ProtonVPN you need to set these variables:

 

VPNSP=protonvpn

OPENVPN_USER

OPENVPN_PASSWORD

 

I don't see why you couldn't use PiHole for that purpose. You would need to set these variables:

 

DOT=off

DNS_PLAINTEXT_ADDRESS=<PiHole IP>

 

You shouldn't need to Add the variables, just change them in the template.

 

Also, the dev has an extensive Wiki on the various settings here:

https://github.com/qdm12/gluetun/wiki

Link to comment

Hello just wondering if I could get some help,

I am trying to run nzbget through Gluetunvpn, using unraid

 

For nzbget 

Extra Parameters: --net=container:GluetunVPN

 

For GlueTUNvpn

I added a port for nzbget 6789,

 

any everything seems good until I test the connection to the Usenetserver I get the error below

Could not resolve hostname news.usenetserver.com: Error -2 - Name or service not known

 

the nzbget container can resolve the hostname just fine when it is not routed through gluetunvpn,

 

any help would be good thanks.

 

Link to comment
37 minutes ago, schuu said:

Could not resolve hostname news.usenetserver.com: Error -2 - Name or service not known

I had the same issue a while back. For me it was being flagged as malicious in Unbound. Try adding "usenetserver.com", without quotes, to the UNBLOCK variable.

Link to comment
15 hours ago, biggiesize said:

I had the same issue a while back. For me it was being flagged as malicious in Unbound. Try adding "usenetserver.com", without quotes, to the UNBLOCK variable.

That seemed to have done the trick, thanks mate,

Link to comment
  • 2 weeks later...

Hello, First thank you for your work on these apps.

 

I'm trying to use ddns-updater with Dreamhost. I have it working, however, when I try to use the host: directive in the config.json file, it yells at me that only "@" is supported. Am I unable to update other hostnames such as www.domain.com instead of juse domain.com?

 

Thank you!

Link to comment
55 minutes ago, Enphor said:

Hello, First thank you for your work on these apps.

 

I'm trying to use ddns-updater with Dreamhost. I have it working, however, when I try to use the host: directive in the config.json file, it yells at me that only "@" is supported. Am I unable to update other hostnames such as www.domain.com instead of juse domain.com?

 

Thank you!

Unfortunately, I dont know the correct answer to your question. It may be for your provider @ is the only supported record. Below is a link to the example config the dev has provided, along with the available settings, specifically for Dreamhost.

 

You can always open an issue on the Github repo with your question. The dev is usually good about working through those quickly.

 

Also, something I just thought of is make sure the record your trying to update is an A or AAAA record. CNAME records are not yet supported but are in the roadmap.

 

https://github.com/qdm12/ddns-updater/blob/master/docs/dreamhost.md

Link to comment
3 hours ago, biggiesize said:

Unfortunately, I dont know the correct answer to your question. It may be for your provider @ is the only supported record. Below is a link to the example config the dev has provided, along with the available settings, specifically for Dreamhost.

 

You can always open an issue on the Github repo with your question. The dev is usually good about working through those quickly.

 

Also, something I just thought of is make sure the record your trying to update is an A or AAAA record. CNAME records are not yet supported but are in the roadmap.

 

https://github.com/qdm12/ddns-updater/blob/master/docs/dreamhost.md

 

Thank you , I know for certain that the Dreamhost API allows for full control of the records. I was using it with pfsense DDNS setup successfully for multiple A records. I'll see about opening an issue on the Github repo, thank you for your response!

Link to comment
  • 2 weeks later...

Any idea why I get "OCI runtime exec failed: exec failed: container_linux.go:367: starting container process caused: exec: "bash": executable file not found in $PATH: unknown" when I try the Console?  I mean it looks like the container path, but I don't know why that would be not already working, and I have no idea how to change it.  I can send docker commands. Tried installing 'bash' that way, and the install worked fine, but bash actually missing doesn't appear to be the issue.

 

Thanks for all your work on this! It's the only good solution for my setup and I'd be SOL without it.

Link to comment
50 minutes ago, docfallingapart said:

OCI runtime exec failed: exec failed: container_linux.go:367: starting container process caused: exec: "bash": executable file not found in $PATH: unknown

I believe he only uses /bin/sh and not bash in the container. Only thing I can think of ATM is the "Console shell command" field in the container settings is "bash" instead of "shell".

Link to comment
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.